Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 06:52
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Comicmaster
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Author Message
josepinto

Joined: 19 Aug 2006
Posts: 21

PostPosted: Tue 08 Jun 2010, 12:28    Post_subject:  Comicmaster  

http://sourceforge.net/projects/comicmaster/

Or another comic reader.
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1170
Location: Australia

PostPosted: Sun 20 Jun 2010, 06:06    Post_subject:  

Hi Josepinto,

I compiled it, but I don't know what Puppy you use so it may not work. Let me know which Puppy you use and I'll try and compile it right for you.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
ajlec2000

Joined: 27 Jan 2007
Posts: 50

PostPosted: Sun 20 Jun 2010, 09:31    Post_subject:  

Personally, I'd like it for a 4.3.1 hard drive install.
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1170
Location: Australia

PostPosted: Sun 20 Jun 2010, 21:54    Post_subject:  

Hey, sorry guys, I had no luck getting it to work in 4.3.1 because it couldn't detect sqlite, even though it was installed on the system. I found this comic reader though,

http://www.fantastic.me.uk/comic.html

All it requires is java and you're good to go.

Set the run action to
Code:
java -jar


If you want to try the ComicMaster I compiled it's here but it most likely won't work.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Sun 20 Jun 2010, 23:26    Post_subject:  

There's QT3-based qcomicbook.
Back to top
View user's profile Send_private_message 
josepinto

Joined: 19 Aug 2006
Posts: 21

PostPosted: Thu 24 Jun 2010, 10:15    Post_subject: Puppy used  

battleshooter wrote:
Hi Josepinto,

I compiled it, but I don't know what Puppy you use so it may not work. Let me know which Puppy you use and I'll try and compile it right for you.

Battleshooter


Hi battleshooter,

I use Lucid Puppy 5.01. I will try the pet you compiled.

José Pinto
Back to top
View user's profile Send_private_message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Thu 24 Jun 2010, 11:10    Post_subject:  

Another option is to compile Evince, which will get you a combined PDF, postscript, DjVu, and Comic reader. Fluppy has it, I think 2.14X has it, but I don't know if anyone's built it for other Puplets. If you use an older version of Evince, it'll compile without the need to update libpoppler.
Back to top
View user's profile Send_private_message Visit_website 
kumosan

Joined: 28 Jul 2010
Posts: 14

PostPosted: Wed 28 Jul 2010, 10:15    Post_subject:  

Hi, I am the author of ComicMaster. Found this discussion via Google. Would have been easier you contacted me to help you solve installation problems, than talk here. Wink

I am always willing to help and also open for feature requests.

@battleshooter
When you have sqlite installed, but ComicMaster cannot find/use it, I suspect two possible problems.

1. Wrong version of sqlite (sqlite2?). Most unlikely.
2. You Qt libs are compiled without sqlite support.

I don't know what packaging system Puppy Linux uses. Some other distributions split Qt in several packages with one of them database support.
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1170
Location: Australia

PostPosted: Thu 29 Jul 2010, 02:24    Post_subject:  

Oh hey man,

Thanks for dropping by. Sorry about not contacting you, it's just that the concept is completely foreign to me. When I try to compiling something and it doesn't work, I usually assume it's my fault, and just leave it. I wasn't saying ComicMaster was a bad program or anything, just that I couldn't make it available for Puppy so offered other solutions.

Thanks for the tips though, I'll take a look and give it another shot. I'll let you know how it goes too if you want.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
kumosan

Joined: 28 Jul 2010
Posts: 14

PostPosted: Thu 29 Jul 2010, 04:46    Post_subject:  

battleshooter wrote:
I'll let you know how it goes too if you want.


Please do. Removing a crash bug is easy, fixing a flawed program flow, too. However, installation related problems are very hard for me. I am lacking experience in that area. Too many possible configurations/distributions, too few machines to test. Embarassed

Btw. you need the unrar/rar and/or unzip/zip binaries in your PATH.
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1170
Location: Australia

PostPosted: Thu 29 Jul 2010, 05:32    Post_subject:  

Ok, I'd be glad to give it a go. Hopefully I'll have time this weekend.

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
ttuuxxx


Joined: 05 May 2007
Posts: 10847
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 29 Jul 2010, 06:15    Post_subject:  

yes 2.14x has evince, I forget if I included the comic plugin, hmmm anyone have a comic link where I can test it?
I came across ghunter which says its a comic viewer, but I can't see it because its sooooo small of a app.
link
http://www.murga-linux.com/puppy/viewtopic.php?p=437865#437865
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
ttuuxxx


Joined: 05 May 2007
Posts: 10847
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 29 Jul 2010, 06:28    Post_subject:  

There's also a shareware ($10 to buy) app, that works out of the box, it only has a nag screen and never runs out of share time.
http://www.radicalbreeze.com/radicalcomic/RadicalCodex.tar.gz
just extract it and click on /RadicalCodexTar/radicalcodex
its actually very nice app.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send_private_message Visit_website 
kumosan

Joined: 28 Jul 2010
Posts: 14

PostPosted: Thu 29 Jul 2010, 16:58    Post_subject:  

battleshooter wrote:
Ok, I'd be glad to give it a go. Hopefully I'll have time this weekend.

Battleshooter


If you do, best use this snapshot from sourceforge:

http://comicmaster.git.sourceforge.net/git/gitweb.cgi?p=comicmaster/comicmaster;a=snapshot;h=01d5ee9f12b56e3ef4be805fe9e8fd5ab38b9c6f;sf=tgz

Several bugs fixed and the control window opens much faster. I also added a few command options, e.g. ComicMaster -f <cbr/cbz> to open a cbr/cbz file directly. This way cbr/cbz files can be associated with ComicMaster in the midnight commander.
Back to top
View user's profile Send_private_message 
battleshooter


Joined: 14 May 2008
Posts: 1170
Location: Australia

PostPosted: Fri 30 Jul 2010, 04:10    Post_subject:  

Hi Kumosan,

How does link you gave me compile, by qmake in the src directory or cmake . in the main folder?

Battleshooter

_________________
LMMS 1.0.2, Ardour 3.5.389, Kdenlive 0.9.8
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 3 Posts_count   Goto page: 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0718s ][ Queries: 11 (0.0037s) ][ GZIP on ]