Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 23 Apr 2014, 19:21
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Linksys WUSB54GSC Woes (SOLVED - sort of...)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
heywoodj

Joined: 15 Mar 2009
Posts: 61

PostPosted: Tue 29 Jun 2010, 00:00    Post subject:  Linksys WUSB54GSC Woes (SOLVED - sort of...)  

I've had good luck running various PCMCIA wireless network cards on Puppy on this machine, but I'm evaluating this USB card for future use.

This usb network adapter, Linksys WUSB54GSC, is giving me trouble. Apparently version 1, it appears to have the Broadcom BCM43xx chipset, not the Ralink as in the similar sounding model, WUSB54GC (See here:http://www.modem-help.co.uk/Linksys/WUSB54GSC-Compact-Wireless-G-USB-Network-Adapter.html)

Network Wizard does not auto-load an interface. Manually trying various modules loads the modules, but no interface is ever detected.

Yet, it did setup and run properly in Windows (obligatory "Yuck!"), which tells me :1. the USB port is good; 2. the network adapter is good; and 3. the drivers are good.

From there I rebooted into Puppy and ran Network Wizard to try ndiswrapper. Ndiswrapper installation then claims invalid drivers.

So, what's the next step? I've also tried via LuPu, but still no joy.

System: Toshiba PII laptop w/192 MB running Turbopup Extreme (4.2.1 variant) on full install.
Network card: Linksys WUSB54GSC ; FCC ID : Q87 WUSB54GSC

Last edited by heywoodj on Sun 04 Jul 2010, 22:36; edited 1 time in total
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5139
Location: Australia

PostPosted: Tue 29 Jun 2010, 08:48    Post subject:  

Wifi devices with Broadcom USB chipsets are supported by the rndis_wlan driver.
heywoodj wrote:
See here:http://www.modem-help.co.uk/Linksys/WUSB54GSC-Compact-Wireless-G-USB-Network-Adapter.html)

That link indicates this device ID: USB\VID_13B1&PID_0026
which is definitely supported by the rndis_wlan module, so it's a question of whether you have the same device ID.
You can check with this command -
Code:
cat /proc/bus/usb/devices

If you have the same device ID, you could manually load the driver like this
Code:
modprobe rndis_wlan

then run the "dmesg" command to look for any errors relating to the rndis_wlan module.
Back to top
View user's profile Send private message 
heywoodj

Joined: 15 Mar 2009
Posts: 61

PostPosted: Wed 30 Jun 2010, 01:16    Post subject:  

Good call on the rndis_wlan module, thank you, tempestuous.

After verifying device ID, Network Wizard was happy with rndis_wlan, and saw available networks and connected and negotiated DHCP properly.... as long as the network was unencrypted.

Now, WPA stops everything. The wizard times-out during the "use this profile" step, although the LED on the adapter is blinking madly.

Is my next step to try and connect from the commandline? I haven't needed to do that for some time.
Back to top
View user's profile Send private message 
heywoodj

Joined: 15 Mar 2009
Posts: 61

PostPosted: Mon 05 Jul 2010, 06:45    Post subject:  

Getting it to be work with WPA was giving me fits. I found a guy in the Gentoo forum who solved it by going to a newer kernel from 2.6.25.x to 2.6.26.x, I believe it was.

Since I was running TurboPup Extreme with the 2.6.25.16 kernel, I tried LuPu 5.0 Live with the 2.6.33.2. Network Wizard didn't auto-detect, but loading the rndis_wlan module allowed me to see and connect to the WPA encrypted network, where I am right now.

WooHoo!

However, this puts me in a predicament -- I'm running TurboPup because it allows my low-spec laptop to run decently. I was considering using this network card on an even lower-spec machine.

LuPu is nice, but the system requirements are more demanding than TurboPup. So, what to do....Suggestions? (Short of junking my junkboxes,that is!)

Edit:Something in my system-- usb port, wireless adapter, other hardware or software -- flaked out and stopped connecting. It's taken me a while to reconnect.

To be continued...
Back to top
View user's profile Send private message 
alberik

Joined: 28 Feb 2012
Posts: 1

PostPosted: Tue 28 Feb 2012, 01:55    Post subject: same quest
Subject description: registered new interdace
 

dmesg show me

usbcore: registered new interface driver rndis_wlan but I don't know how to access.

The wizard network show again:
puppy cannot see any active networks interfaces

Do I did something wrong ? i did exactly the same process than heywoodj
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0601s ][ Queries: 11 (0.0169s) ][ GZIP on ]