Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 15:05
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Dialup/Wireless Modem Upgrade Packages for Puppy 4.3+
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 13 [192 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Author Message
rerwin


Joined: 24 Aug 2005
Posts: 1536
Location: Maine, USA

PostPosted: Wed 30 Nov 2011, 22:13    Post subject:  

Hernâni,
Thank you for posting your problem here. I suspect you are using the wrong update dotpet package for the version of Puppy you have. But you have not told us which it is. Be aware that the 3G_pupdial-wireless-13.pet package is only for puppies 4.2 and older, and has not been maintained for a long time. Please do not use it.

The puppies I can help you with are 4.3.1 (plus an update package) and Lucid Pup 5.2.8. Lupu 5.2.8 should already support your 3G modem. You can get the very latest version of it here:
http://www.murga-linux.com/puppy/viewtopic.php?p=554253#554253

If you are using "wary", the modem should also "just work" there. If you have trouble with the modem and lupu 5.2.8, please report that here, so I can work it.

Welcome to this thread.
Richard
Back to top
View user's profile Send private message 
Hernâni

Joined: 29 Nov 2011
Posts: 8

PostPosted: Thu 01 Dec 2011, 21:13    Post subject:  

Richard,

Thank you very much for trying to help me.

I really would like to be using this Puppy because it is incredible.

So, my Puppy is Lupu 5.2.8

I'm going to follow your advice. I'm using this O.S since tow weeks ago. Before I was using Debian Squeeze wich is also very good.

I really apreciate your work.

Thank you one more time.

Best wishes

Hernâni
Back to top
View user's profile Send private message 
Hernâni

Joined: 29 Nov 2011
Posts: 8

PostPosted: Mon 05 Dec 2011, 10:03    Post subject: Modem 3g  

Richard,

I did everything that you said for me to do, but with no success. Lupu 5.2.8.003 doesn't solve the problem. The modem is recognized but the connection hangs up allways.

The error message is this:

WvDial: Internet dialer version 1.53
Initializing modem.
Sending: ATZ
ATZ
OK
Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
Sending: AT+CGDCONT=1,"IP","internet.tmn.pt"
AT+CGDCONT=1,"IP","internet.tmn.pt"
OK
Modem initialized.
Sending: ATDT*99#
Waiting for carrier.
ATDT*99#
CONNECT
Carrier detected. Starting PPP immediately.
Starting pppd at Mon Dec 5 13:50:14 2011
pid of pppd: 2156
Disconnecting at Mon Dec 5 13:50:19 2011
The PPP daemon has died: A modem hung up the phone (exit code = 16)
man pppd explains pppd error codes in more detail.
Try again and look into /var/log/messages and the wvdial and pppd man pages for more information.


I would apreciate any help.
Thank you very much
Hernâni
Back to top
View user's profile Send private message 
gseller

Joined: 02 Apr 2012
Posts: 2

PostPosted: Mon 02 Apr 2012, 01:47    Post subject: Question  

Hi.
I've got ZTE USB modem too and using Wary Puppy 5.2.2
I have to say that after probing several times finnally I could access to internet on the first day I installed Puppy.
BUT two days after... and with no changes in the system at all, I'm getting a "bad init string" error.
Because of I considered myself a "lucky guy", I saved the "succesful" configuration of when I coud access to internet.
I attached that .png image.

But now...

Initializing modem.
Sending: ATZ
ATZ
OK
Sending: ATQ0 V1 E1 +FCLASS=0
ATQ0 V1 E1 +FCLASS=0
OK
Sending: AT+CGDCONT=1, "IP", "adslmovil"
AT+CGDCONT=1, "IP", "adslmovil"
ERROR
Bad init string.

How can it be?

How can i fix?

Thanks!
02.png
 Description   
 Filesize   52.76 KB
 Viewed   1377 Time(s)

02.png

01.png
 Description   
 Filesize   159.56 KB
 Viewed   1389 Time(s)

01.png

Back to top
View user's profile Send private message 
Hernâni

Joined: 29 Nov 2011
Posts: 8

PostPosted: Mon 02 Apr 2012, 03:44    Post subject:  

Hello gseller!

Where it says adslmovil put internet

Maybe it helps.

Good luck

Hernâni
Back to top
View user's profile Send private message 
gseller

Joined: 02 Apr 2012
Posts: 2

PostPosted: Mon 02 Apr 2012, 04:13    Post subject:  

Hi
Thanks for your response.
This is so strange.
I changed the usb port, made the pupdial probes again and it worked, but really slow surfing the net.
I disconnected and reboot several times but I couldn't connect again.
What is it wrong here?
I used "internet" but no results. I let "adslmovil" and worked, slow, but it worked.
I'm trying to connect again and find out how to do it with good inernet speed.
Back to top
View user's profile Send private message 
dogle

Joined: 11 Oct 2007
Posts: 354

PostPosted: Fri 27 Sep 2013, 15:33    Post subject:  

Are the 4.3+ .pets, in which Rerwin has invested such immense labour, no longer hosted/available?
Back to top
View user's profile Send private message 
RetroTechGuy


Joined: 15 Dec 2009
Posts: 2668
Location: USA

PostPosted: Sat 28 Sep 2013, 11:14    Post subject:  

dogle wrote:
Are the 4.3+ .pets, in which Rerwin has invested such immense labour, no longer hosted/available?


Couldn't tell you for sure. Have you looked here for packages?

http://distro.ibiblio.org/puppylinux/

For series 4 packages:
http://distro.ibiblio.org/puppylinux/pet_packages-4/

_________________
Add swapfile
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1536
Location: Maine, USA

PostPosted: Sat 28 Sep 2013, 14:07    Post subject:  

RetroTechGuy,
Thank you, for asking about this effort. Since the upload/download size limit was reduced to 256KB, I assume that the packages in this thread and in the "simplified 4.3.1.1. upgrade" thread cannot now be downloaded. Not to worry.

My plan is to replicate the set of packages constituting 4.3.1.1 in my new mediafire account, where I am currently in the process of upgrading lucid pup 5.2.8. They reside on my Aptiva, which I have not used for awhile, so hope it still works. Either besides those packages, or instead of them, I expect to add a remastered ISO file containing everything that does not present a conflict (among some drivers).

I also have a set of updates made to lucid pup that should fit into 4.3.1, although when I tested them with it there were some problems. When I get that sorted, I hope to create a 4.3.1.2 ISO file and package set. But that will be awhile. In the meantime, please feel free to request support from me, best by PM, to get my attention. I am glad to see there is still some interest in 4.3.1.
Richard
Back to top
View user's profile Send private message 
dogle

Joined: 11 Oct 2007
Posts: 354

PostPosted: Tue 04 Feb 2014, 19:08    Post subject:  

Maybe it's worth bumping this thread for the benefit of my fellow 4-series enthusiasts ....

Following the introduction of of a new 3G service in my patch, I was keen to take a sniff at it.

I'm glad to report that I was able to connect with minimal difficulty (via Huwawei E169) using my plain-vanilla, cherished 4.3.1 ... Richard, you have done one fantastic job with this!

I seem to be in a signal shadow area, so it was very important to me to invoke the code AT+CSG to force the modem to report signal strength on connection (so I can work out whether I need to build a mast).

This worked brilliantly at first, providing me with very valuable information. Then - I don't know why - I lost it; I could not force AT+CSG to happen despite hours of trying to re-edit wvdial.config. (Could this be something to do with (the then) PupDial's determination to be helpful by insisting on fixing the wvdial.config on disconnect, and on exit? .... more likely my own incompetence!).

The solution, after many hours of hair tearing and searching, came from rerwin's sublime tip:
"please delete from /etc/wvdial.conf all of the lines in the [wireless] section (except for Init5 if you have used an APN). Then run PupDial and immediately exit from it, to restore the default content for re-editing."

Back in business now! Signal strengths on demand .... Richard, thank you so much.
Back to top
View user's profile Send private message 
chosenbygrace

Joined: 04 May 2014
Posts: 2

PostPosted: Sun 04 May 2014, 03:57    Post subject: What about the common clear wireless "4G" modems?
Subject description: I'm using the Atlas version I think
 

When I got onto the lupu desktop top I tried one of the "eth" settings since I wasn't automatically connected to the net like other linux distros have done for me, eh hem, and on the last eth setting it claimed I was connected, however other apps said I wasn't.

So, what the heck? I ended up deleting it from my usb stick to try other versions of puppy, I might not though since this was such a bad experience. I had no prob with ubuntu, linux mint, peppermint, porteus, knoppix or parted magic connecting, so, this seems to me to be a not so good OS. Also if any developer is reading this, please include Chrome by default in some version of Puppy, not Chromium, or at least both if you "must".
Back to top
View user's profile Send private message 
cthisbear

Joined: 29 Jan 2006
Posts: 3453
Location: Sydney Australia

PostPosted: Sun 04 May 2014, 05:03    Post subject:  

chosenbygrace:

Another whingeing loser.

Didn't allow us to help.

Chosen as a disgrace.

Piss off....Chris.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 13 [192 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Networking » Dialup
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0817s ][ Queries: 12 (0.0079s) ][ GZIP on ]