(OLD) (ARCHIVED) Puppy Linux Discussion Forum Forum Index (OLD) (ARCHIVED) Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info

This forum can also be accessed as http://oldforum.puppylinux.com
It is now read-only and serves only as archives.

Please register over the NEW forum
https://forum.puppylinux.com
and continue your work there. Thank you.

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups    
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 09 Mar 2021, 06:23
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Puppy Arcade 8 - PET and SFS
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Tue 27 Jul 2010, 15:34    Post subject:  Puppy Arcade 8 - PET and SFS
Subject description: Add Puppy Arcade to any Puppy
 

Puppy Arcade 8 - PET and SFS versions

I've had a few requests for this, so here it is.

Summary:

"Puppy Arcade" is a collection of video game emulators and tools making your PC a retro-gaming arcade and multi-emulator frontend. You can use "Rom-Loader" and "RejoystickCC", to use your joypad to browse and load all your ROMs Smile

Also see the "Frontend-Chooser" - set which default emulator frontends to load, when using the menu items. Finally, "QuickStart" helps you download and set new default emulators, as well as other help. Very Happy

All of these apps and emulators can be found in the Puppy menu, under 'Fun'.

NOTE: "Rom-Loader" requires certain jwm settings, in order to load in 'fullscreen', which are added by the 'pinstall.sh' script.


DOWNLOAD HERE:

Puppy Arcade 8 pet file - for all Puppy versions
(md5: 390544aaeec6a86dab99d282e8f9140f)

Puppy Arcade 8 sfs3 file - for Puppy 4.2.x and earlier
(md5: 26626c3c940f70e189afec51099a5ec6)

Puppy Arcade 8 sfs4 file - for Puppy 4.3.x and later (rename the file to finish with '_XXX', where 'XXX' is your Puppy version)
(md5: b7b2fea7b8990ac1dcf2df26c4bbc7be)

(These include all apps and their required libs)


How to install the PET:

- Download the PET file
- Run it, install using PetGet, as usual.

How to install the SFS:

- Download the SFS file and copy or move to '/mnt/home'
- Rename the sfs, changing '420' to match your version of Puppy, if required
- Example: on 4.3.1, rename the '420' to '431', so the filename finishes '_431.sfs'
- NOTE: Puppeee users should use PuppeeeArcade.sfs (at the Puppeee website)
- Then, reboot and run the '/pinstall.sh' file to enable fullscreen for Rom-Loader (jwm only)

How to use and setup:

You'll need to setup a ROM directory for some emulators and/or download the required BIOS files, using the BIOS checker.

You'll also need to set your preferred controls in the emulators. To access emulator settings, you may need to change the settings in the "Frontend Chooser" to access the original emulators. Also, for N64 emulation, you will need to enable OpenGL, by installing the correct drivers for your card.

About Rejoystick config file warnings: To remove them, just plug in a joypad and load Rejoystick or RejoystickCC to setup your controls.. Or, if you have no joypad, create a blank text file in '/root' called '.rejoystickrc'

Note: This version differs from the Live CD in that I have reverted to GXMAME and have updated the various tools I created accordingly.
I have also moved some menu entries and updated/improved a few of the custom tools.

If not using JWM, you can remove the '-f' parameter from the command in the rom-loader .desktop file, in '/usr/share/applications', to remove the fullscreen behaviour of Rom-Loader.

More info can be found on the Puppy Arcade (Live CD) threads:

Puppy Arcade Homepage
Puppy Arcade 8
Puppy Arcade 7

Enjoy!
romloader.png
 Description   
 Filesize   81.32 KB
 Viewed   8212 Time(s)

romloader.png

pa8.png
 Description   
 Filesize   99.21 KB
 Viewed   8198 Time(s)

pa8.png


_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search

Last edited by sc0ttman on Wed 18 Aug 2010, 06:29; edited 11 times in total
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2267
Location: Out wandering... maybe.

PostPosted: Fri 30 Jul 2010, 04:53    Post subject:  

Hmm... seems to work for me, so far, on 4.3.1 Retro (probably wouldn't be working for me if I wasn't using the older kernel?). Just to be sure, I ran trio's sfs-compatibility checker against it. Smile

I haven't actually run anything yet, but I have run most of it past ldd, and nothing seems to come up missing. (Uninstalled the Arcade 5 .pet first and rebooted, of course.)

_________________
[ Puppy 4.3.1 JP, Frugal install ] * [ XenialPup 7.5, Frugal install ] * [XenialPup 64 7.5, Frugal install] * [ 4GB RAM | 512MB swap ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Fri 30 Jul 2010, 08:27    Post subject:  

Makoto wrote:
Hmm... seems to work for me, so far, on 4.3.1 Retro (probably wouldn't be working for me if I wasn't using the older kernel?). Just to be sure, I ran trio's sfs-compatibility checker against it. Smile

I haven't actually run anything yet, but I have run most of it past ldd, and nothing seems to come up missing. (Uninstalled the Arcade 5 .pet first and rebooted, of course.)

Yes it works for you cos you're using the retro kernel.. But I am surprised you didn't need to hunt for loads of libs with this version..

Any problems with it, let me know...

_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2267
Location: Out wandering... maybe.

PostPosted: Fri 30 Jul 2010, 13:41    Post subject:  

Well, nothing popped up on any of the ldd runs. Smile

I already have the OpenGL and full SDL support installed, so in theory, it shouldn't complain that they're not there. Hopefully. Very Happy
Does it include a version of GTK? If so, which version? (I noticed that one of the problems I was having due to the version of GTK included with 4.3.1 (file save dialogs running off the bottom of the screen), that was supposed to be fixed if I did install a different version of GTK, was no longer happening. Smile)

_________________
[ Puppy 4.3.1 JP, Frugal install ] * [ XenialPup 7.5, Frugal install ] * [XenialPup 64 7.5, Frugal install] * [ 4GB RAM | 512MB swap ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Sat 31 Jul 2010, 09:05    Post subject:  

Makoto wrote:
Well, nothing popped up on any of the ldd runs. Smile

Lovely!

Makoto wrote:
Does it include a version of GTK?

I didn't include any GTK package with this, as far as I know! Very Happy

(also, I just added the full version (libs included) to the main post)

_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2267
Location: Out wandering... maybe.

PostPosted: Sat 31 Jul 2010, 14:09    Post subject:  

Weird. I don't know why the dialog boxes would suddenly fix themselves, then. Very Happy

Should I go ahead and replace the SFS with the 'full' version, anyway?

_________________
[ Puppy 4.3.1 JP, Frugal install ] * [ XenialPup 7.5, Frugal install ] * [XenialPup 64 7.5, Frugal install] * [ 4GB RAM | 512MB swap ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Sat 31 Jul 2010, 15:02    Post subject:  

Quote:
Should I go ahead and replace the SFS with the 'full' version, anyway?

No, not yet.. Unless you wanna help me test it?

There's still a few bugs to iron out, I forgot to include a few things, such as missing icons, and jwm settings..

Also some more changes need to be made to some files in order to make them work nicely on other Puppy versions..

_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2267
Location: Out wandering... maybe.

PostPosted: Sat 31 Jul 2010, 23:55    Post subject:  

Okay. I'll think about it, then. Smile

And my GTK file dialogs have inexplicably gone back to the way they were. Shocked (c'mon, this sort of thing is only supposed to happen under Windows... Razz)

_________________
[ Puppy 4.3.1 JP, Frugal install ] * [ XenialPup 7.5, Frugal install ] * [XenialPup 64 7.5, Frugal install] * [ 4GB RAM | 512MB swap ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Fri 06 Aug 2010, 09:28    Post subject:  

See main post:

Updated the package, it should now be ready to go in most versions of Puppy.

Changelog:
- added all required icons for GUIs, menu entries, etc
- removed unneeded extras and files
- improved mame and saturn helper GUIs
- improved RejoystickCC, for smoother usage without a joypad
- moved and renamed menu entries for simpler navigation
- all libs added
- pinstall script added to auto-add required jwm settings for rom-loader fullscreen (sfs users need to run it themseves after reboot)


Both PET and SFS (sfs3) packages added. 4.3 users will need to convert the sfs before they can use it, using Trios utility.

_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search
Back to top
View user's profile Send private message 
sandungas

Joined: 22 May 2010
Posts: 59

PostPosted: Sat 07 Aug 2010, 22:28    Post subject:  

Im trying to load puppyarcade8_420-sfs4.sfs in puppeee v1 (based on puppy 4.3.1) but the file is not detected by "bootmanager"
I tryed to rename the file (replacing this 420 by 431) but still does not work
So... what i need is this ?
sc0ttman wrote:
4.3 users will need to convert the sfs before they can use it, using Trios utility.

Im newbie with this, can somebody link me to the app thread or a manual of how to do this conversion ?
Back to top
View user's profile Send private message 
sandungas

Joined: 22 May 2010
Posts: 59

PostPosted: Sat 07 Aug 2010, 22:41    Post subject:  

Mmmm, i found an app preinstalled in puppeee (sfs converter 1.3)
The help buttton in this app link to this "readme.txt"
Quote:
Puppy Linux Version 4.3x with 2.6.29 kernel, uses sfs version 4.x and cannot load older sfs version 3.x (used by many previous puppy versions)
What SFS converter does is to auto detect and convert v 3.x to v 4.x or the other way around.

This is the explain of the incompatibility problem, right ?
Now i understand Wink i will try the conversion and will report feedback later

Thanks for this pack of emus, is gonna be funny to play with games of my older geek toy (ZX spectrum) in my newer geek toy (asus eeepc) Very Happy
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Sun 08 Aug 2010, 12:10    Post subject:  

sandungas wrote:
Im trying to load puppyarcade8_420-sfs4.sfs in puppeee v1 (based on puppy 4.3.1) but the file is not detected by "bootmanager"
I tryed to rename the file (replacing this 420 by 431) but still does not work

You downloaded the correct file, butyou need to rename it to puppyarcade8_431.sfs.. Then check the boot manager, to make sure it will be loaded after reboot.. Then reboot.

I hope that helps Very Happy

_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 2267
Location: Out wandering... maybe.

PostPosted: Sun 08 Aug 2010, 21:30    Post subject:  

Hmm... updated to the newer SFS, and my Puppy began acting a little odd (ROX crashing, somewhat). Not really sure it's related, but I'm also not sure if my 4.3.1 does as well with SFSes as 4.2.1 did (I had a few problems with them when first trying 4.3.1), so I've removed it from Boot Manager for the moment. I may test it again later, or just install the .pet. Neutral
_________________
[ Puppy 4.3.1 JP, Frugal install ] * [ XenialPup 7.5, Frugal install ] * [XenialPup 64 7.5, Frugal install] * [ 4GB RAM | 512MB swap ]
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2806
Location: UK

PostPosted: Mon 09 Aug 2010, 02:38    Post subject:  

Makoto wrote:
Hmm... updated to the newer SFS, and my Puppy began acting a little odd (ROX crashing, somewhat). Not really sure it's related, but I'm also not sure if my 4.3.1 does as well with SFSes as 4.2.1 did (I had a few problems with them when first trying 4.3.1), so I've removed it from Boot Manager for the moment. I may test it again later, or just install the .pet. Neutral

Hmmm.. ROX should not be affected by this package.. It worked well for me on a few other Puppies (4.2 and 4.3)..

Quick Tip:

Use the PET package as a test maybe? and use "pet2sfs" to convert it to an sfs, to save another download...

_________________
Pkg, mdsh, Woofy, Akita, VLC-GTK, Search
Back to top
View user's profile Send private message 
sandungas

Joined: 22 May 2010
Posts: 59

PostPosted: Mon 09 Aug 2010, 17:53    Post subject:  

sc0ttman wrote:
sandungas wrote:
Im trying to load puppyarcade8_420-sfs4.sfs in puppeee v1 (based on puppy 4.3.1) but the file is not detected by "bootmanager"
I tryed to rename the file (replacing this 420 by 431) but still does not work

You downloaded the correct file, butyou need to rename it to puppyarcade8_431.sfs.. Then check the boot manager, to make sure it will be loaded after reboot.. Then reboot.

I hope that helps Very Happy

Then i used the correct filename, and after writing my previous message i realized that the file in fact was a sfs v4 (the one i need with the name i need)
But i cant see it in bootmanager, maybe i have another kind of problem

The strange thing is that i can see (and load) another .sfs files, but i have not tested too much files (just 2 from here http://puppeee.com/files/sfs/ ), i will try a few more to be sure that this is the only one i cant load
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies. View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Games
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0726s ][ Queries: 12 (0.0218s) ][ GZIP on ]