Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Dec 2014, 18:18
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
gtkpod 2.0.2 (outdated 2011 version)
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Tue 19 Apr 2011, 22:15    Post_subject:  

Go ahead and try it.
I don't have Wary, myself, but the differences mainly relate to Xorg version and kernel version. Neither of these differences should affect gtkpod.
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 20 Apr 2011, 01:54    Post_subject:  

tempestuous wrote:
Go ahead and try it.
I don't have Wary, myself, but the differences mainly relate to Xorg version and kernel version. Neither of these differences should affect gtkpod.


I shall give it a go. Thanks

Eathray
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 20 Apr 2011, 12:47    Post_subject:  

Tempestuous,

I installed GTKPod and am working through the set up.

I launched it through the console and got the error message:
"libcurl-gnutls.so.4 cannot open shared file or directory, no such directory found.

Next I input the code to follow and checked the var/log/messages; it doesn't seem to be recognized. here is the last few lines:

Apr 20 08:40:44 puppypc user.notice usbmuxd[21134]: [3] usbmuxd v1.0.5 starting up
Apr 20 08:40:44 puppypc user.info usbmuxd[21153]: [4] Creating socket
Apr 20 08:40:44 puppypc user.info usbmuxd[21153]: [4] Not dropping privileges to root
Apr 20 08:40:44 puppypc user.info usbmuxd[21153]: [4] Initializing USB
Apr 20 08:40:44 puppypc user.info usbmuxd[21153]: [4] 0 devices detected
Apr 20 08:40:45 puppypc user.notice usbmuxd[21153]: [3] Initialization complete

The usbmuxd seems to be launched as you said it would be, but it doesn't seem to be recognizing the shuffle (line 5: "0 devices detected"). What do you think?

Thanks

Eathray
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Wed 20 Apr 2011, 19:59    Post_subject:  

Eathray wrote:
libcurl-gnutls.so.4 cannot open shared file or directory

OK, so Wary has a different version of libcurl (or it's missing). That just means you won't have cover art download support.


Eathray wrote:
Next I input the code to follow

The manual commands only apply to the Ipod-Touch and iPhone.

With a Shuffle, you should just go into the Preferences menu and tell gtkpod what model you have ...
... which raises the point that you didn't tell us which version (generation) of Shuffle you have.
If you have a fourth generation 4G model, you may be out of luck.
http://gtkpod.wikispaces.com/Supported+iPods#ShuffleFourth
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 20 Apr 2011, 20:08    Post_subject:  

tempestuous wrote:
Eathray wrote:
libcurl-gnutls.so.4 cannot open shared file or directory

OK, so Wary has a different version of libcurl (or it's missing). That just means you won't have cover art download support.


Eathray wrote:
Next I input the code to follow

The manual commands only apply to the Ipod-Touch and iPhone.

With a Shuffle, you should just go into the Preferences menu and tell gtkpod what model you have ...
... which raises the point that you didn't tell us which version (generation) of Shuffle you have.
If you have a fourth generation 4G model, you may be out of luck.
http://gtkpod.wikispaces.com/Supported+iPods#ShuffleFourth


Please excuse my ignorance. I'm a little out of my element on this. I'll try to figure out which version it is and come back with the info in a bit.

Thanks

Eathray
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 20 Apr 2011, 20:17    Post_subject:  

tempestuous wrote:
Eathray wrote:
libcurl-gnutls.so.4 cannot open shared file or directory

OK, so Wary has a different version of libcurl (or it's missing). That just means you won't have cover art download support.


Eathray wrote:
Next I input the code to follow

The manual commands only apply to the Ipod-Touch and iPhone.

With a Shuffle, you should just go into the Preferences menu and tell gtkpod what model you have ...
... which raises the point that you didn't tell us which version (generation) of Shuffle you have.
If you have a fourth generation 4G model, you may be out of luck.
http://gtkpod.wikispaces.com/Supported+iPods#ShuffleFourth


Okay, that was easier than I thought it would be.

This is the A1271, EMC 2262 (which according to an Apple site is 3'rd generation Very Happy )

K, sorry about misunderstanding the directions. When there's a lot of info, I sometimes get overload.

I'm going to try launching gtkpod from the menu, then inserting the shuffle, and will report back.

Thanks,

Eathray
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 20 Apr 2011, 20:28    Post_subject:  

Tempestuous,

K, that was a big nothing.

I need to go back through the directions you provided, but you mentioned the preferences. GKPod is not loading for me, so there's no preferences to select.

I will read through the directions and try to figure out what I've missed, and I'll get back to you with a real question.

thanks

Eathray
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Wed 20 Apr 2011, 20:54    Post_subject:  

Eathray wrote:
GKPod is not loading for me

If you mean that the gtkpod gui fails to display when you launch it from the menu, I suggest you launch it from the commandline instead, as such -
Code:
gtkpod

If nothing else, you should see some error messages which would reveal why it's failing to launch.
If the error messages are serious, it means that you cannot use gtkpod with Wary, and you must use Puppy 5.2.x instead.
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Wed 20 Apr 2011, 21:13    Post_subject:  

tempestuous wrote:
Eathray wrote:
GKPod is not loading for me

If you mean that the gtkpod gui fails to display when you launch it from the menu, I suggest you launch it from the commandline instead, as such -
Code:
gtkpod

If nothing else, you should see some error messages which would reveal why it's failing to launch.
If the error messages are serious, it means that you cannot use gtkpod with Wary, and you must use Puppy 5.2.x instead.


It does not launch from the command line and gives the same error message about: "libcurl-gnutls.so.4 cannot open shared file or directory, no such file or directory"

Seems to be getting stuck on that.

I've been looking for that lib file since I first got that message, but I can't find it. I'd like to try installing it and see if it suddenly works... Do you happen to know where I can find it?

thanks

Eathray
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Wed 20 Apr 2011, 22:53    Post_subject:  

Seven posts earlier you said this -
Eathray wrote:
I launched it through the console and got the error message:
"libcurl-gnutls.so.4 cannot open shared file or directory, no such directory found.

... you didn't reveal at that time that gtkpod failed to launch!

Now that you have revealed this critical piece of information, it's clear that gtkpod won't launch unless it finds libcurl.
So I now need you to look in /usr/lib (using ROX) to see if there's a version of libcurl-gnutls and libcurl, and if so, give me the exact filenames. The filenames will be of this format:
libcurl-gnutls.so.x.x.x
libcurl.so.x.x.x
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Thu 21 Apr 2011, 00:32    Post_subject:  

tempestuous wrote:
Seven posts earlier you said this -
Eathray wrote:
I launched it through the console and got the error message:
"libcurl-gnutls.so.4 cannot open shared file or directory, no such directory found.

... you didn't reveal at that time that gtkpod failed to launch!

Now that you have revealed this critical piece of information, it's clear that gtkpod won't launch unless it finds libcurl.
So I now need you to look in /usr/lib (using ROX) to see if there's a version of libcurl-gnutls and libcurl, and if so, give me the exact filenames. The filenames will be of this format:
libcurl-gnutls.so.x.x.x
libcurl.so.x.x.x


Honest, I wasn't trying to hide the critical info... I'm still a newbee at a lot of things! I meant to say, I tried to launch it but it didn't.

Okay, here are the files:

libcurl.so
libcurl.so.4
libcurl.so.4.1.1

That appears to be it. No libcurl-gnutls.so of any number, at least in that location.

I've been looking for the file libcurl-gnutls.so.4, and there's lots of mention of it in the forums... I just haven't found it to download.

Thanks,

Eathray
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Thu 21 Apr 2011, 02:28    Post_subject:  

EDIT:
Wary requires many additional libraries for this gtkpod-1.0 package to work.
These libraries are now attached to the first post in this thread.

Edited_time_total
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Thu 21 Apr 2011, 10:38    Post_subject:  

tempestuous wrote:
OK, this is a bit rough; I just packaged the libcurl-gnutls files from Puppy 5.1, so they're not 100% binary compatible with Wary, but they should be OK.
Install this dotpet, then launch gtkpod from the commandline again.


Well, that must have worked, because it doesn't ask for the libcurl-gnutls file anymore...

Now it wants liblber-2.4.so.2

Embarassed

What next?

Thanks,

Eathray
Back to top
View user's profile Send_private_message 
Eathray

Joined: 06 Sep 2009
Posts: 506

PostPosted: Thu 21 Apr 2011, 12:08    Post_subject:  

Eathray wrote:
tempestuous wrote:
OK, this is a bit rough; I just packaged the libcurl-gnutls files from Puppy 5.1, so they're not 100% binary compatible with Wary, but they should be OK.
Install this dotpet, then launch gtkpod from the commandline again.


Well, that must have worked, because it doesn't ask for the libcurl-gnutls file anymore...

Now it wants liblber-2.4.so.2

Embarassed

What next?

Thanks,

Eathray


How do you guys find these libraries, anyway? I keep looking for this stuff and all I find is people talking ABOUT them... then you pop in with a full .pet package.

Eathray
Back to top
View user's profile Send_private_message 
tempestuous

Joined: 10 Jun 2005
Posts: 5293
Location: Australia

PostPosted: Thu 21 Apr 2011, 15:21    Post_subject:  

EDIT:
Wary requires many additional libraries for this gtkpod-1.0 package to work.
These libraries are now attached to the first post in this thread.

Edited_time_total
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 2 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1101s ][ Queries: 12 (0.0179s) ][ GZIP on ]