Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 29 Nov 2014, 04:51
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppeee 4.4 Beta Testing
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 14 [207 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 12, 13, 14 Next
Author Message
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Wed 10 Nov 2010, 12:13    Post subject:  

Thank you very much for the detailed feedback. You're the first with that model to really tell me how things are working.

I'll look into the touchscreen drivers on the wiki.

How did you fix the brightness with other distros?

I don't believe the Linux synaptics driver supports pinching.

The hotkeys are programmable using xbindkeys. The rotate command should be set to something like "xrandr -o inverted", and "xrandr -o normal" to put it back. I can knock together a script for this so it does the right thing when the button is pressed.
Back to top
View user's profile Send private message Visit poster's website 
dougeeebear

Joined: 08 Apr 2009
Posts: 170
Location: Mid-South, USA

PostPosted: Thu 11 Nov 2010, 11:33    Post subject:  

Any chance of getting Fluppy's Control Panel integrated into Puppeee?
Also would a pet be out of the question?

Thanks
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Thu 11 Nov 2010, 13:02    Post subject:  

Yes it will be in beta4 which I plan to release in a few days.
Back to top
View user's profile Send private message Visit poster's website 
dougeeebear

Joined: 08 Apr 2009
Posts: 170
Location: Mid-South, USA

PostPosted: Thu 11 Nov 2010, 13:14    Post subject:  

Quick note regarding your pet files directory on puppeee.com, it seems as if they all need permissions set, because I don't seem to be able to download any of them.
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Thu 11 Nov 2010, 13:25    Post subject:  

They work for me. What error are you getting?
Back to top
View user's profile Send private message Visit poster's website 
dougeeebear

Joined: 08 Apr 2009
Posts: 170
Location: Mid-South, USA

PostPosted: Thu 11 Nov 2010, 13:54    Post subject:  

If I click on any one them, they open up like a text file.
Right-click / Save As... doesn't work either.
This is in Windows with Firefox.

EDIT:
It looks like it did work ok using "Save As..."
The Firefox download manager apparantly just doesn't recognise the pet file sizes.
Back to top
View user's profile Send private message 
2lss

Joined: 20 Sep 2009
Posts: 225

PostPosted: Thu 11 Nov 2010, 19:02    Post subject:  

I gave the latest 4.4 beta a try the other day on my 900 and for the most part, everything was working great. Flash video playback was nearly perfect at 360p and didn't load the cpu up nearly as much as before. I'm not sure if you updated xorg or something but its working very good.

I only see three issues so far. For one, the cursor moves in little grids, which I'm assuming its an issue with the elantech driver like in 4.3

The other issue is that chrome still locks up (for me) on some flash sites and/or the flash plugin crashes. Youtube works fine but some sites with elegant advertisements seem to cause it problems. All in all it happens less than the previous chrome versions so I'm hoping the developers will work out the issues in newer releases.

The last issue (or maybe its a preference) is the small system and chrome fonts. For me its a little difficult to read on a small screen.

Other than that it looks like its going to be another awesome eeepc puplet Smile
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Thu 11 Nov 2010, 21:39    Post subject:  

Yes, it'll need another build without the elantech driver.

You can try Gnash instead of Flash if you want. http://puppeee.com/files/pet/gnash-0.8.8-i486.pet
It generally works on Youtube, but it's pretty iffy for other sites, but should be good performance where it does work.

The font problem is complicated. If I force the minimum size bigger, some sites do not render correctly. I'm still trying to find a good fix.
Back to top
View user's profile Send private message Visit poster's website 
John Lewis

Joined: 03 Dec 2007
Posts: 148
Location: Albany West Australia

PostPosted: Fri 12 Nov 2010, 00:55    Post subject:  

Hi jemimah,

Just gave this latest a try on my 701SD.

It looks great and loads fast.

The only snags are: I couldn't get wireless. It claimed not to find card even though enabled in bios. I tried to check with lsmod but didn't get a list of anything at all for some reason. Just headings Module Size and Used by but no list. Odd.
No audio controls. AlsaMixer doesn't start and the speaker function keys don't work. Screen brightness and suspend to ram worked.

John Lewis
Back to top
View user's profile Send private message 
Partack

Joined: 04 Mar 2009
Posts: 5

PostPosted: Fri 12 Nov 2010, 05:14    Post subject:  

Hello Jemimah!

I just typed a whole bunch of stuff but but it got deleted some how =( so i'll have to do it again -__-;

so, the Ultrabright button in eee-control worked great! Sorry for not seeing it before, i'll look at what controls are available to me more closely next time .__.;

your screen rotation command: xrandr -o inverted (for inverted) and xrandr -o normal (to put it back)
worked fine except the cursor became hidden, yet it still functioned.
and your fix for that: ctrl-alt-f1 then ctrl-alt-f4
worked perfectly too and the cursor came back =)

You told me that screen rotation would be implemented next release, i would very much like it to rotate at 90 degrees, please, as portrait is usually quite nice for reading. not to mention it's the buttons behavior in windows.

as a suggestion, perhaps the rotate screen button could be implemented in the following way:
# Single press:
Rotate the screen 90 Degrees

# Long Hold:
Lock the screen

i think that would be quite useful and comfortable in my opinion.

I believe the behavior for it in windows was this:

# A single press:
brings up a menu made by asus

# A press-hold:
would show a little icon in the center of the screen illustrating what rotation you would make the screen if you let go of the button and it would always start from the 'normal' upright position, even if you were already in that orientation..

..just to let you know.. I don't expect you to make it exactly the same (in-fact i didn't really like it that way and a few comments on other forums have been in a similar light.. someone even made a program to replace the asus one so that it doesn't behave that way anymore =P)

if there's anything else, just let me know and i'll test it out for yah =)

thanks very much again for your hard work and patience
~PtK
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Fri 12 Nov 2010, 12:06    Post subject:  

Partack,

Using the new kernel I sent you, can you see if the egalax driver loaded by running
Code:
lsmod|grep egalax


Also can you send me a copy of your /proc/bus/input/devices file?
Back to top
View user's profile Send private message Visit poster's website 
Partack

Joined: 04 Mar 2009
Posts: 5

PostPosted: Sat 13 Nov 2010, 14:28    Post subject:  

jemimah wrote:
Using the new kernel I sent you, can you see if the egalax driver loaded by running
Code:
lsmod|grep egalax


made sure it was exactly as you typed, even copy and pasted to make double sure.. nothing happened when i entered that command in a terminal.

jemimah wrote:
Also can you send me a copy of your /proc/bus/input/devices file


sure, i'll send it over to you via PM =) you should get it soon.
(sorry for how slow this post was.. uni assignment. =P)
~PtK
Back to top
View user's profile Send private message 
jemimah


Joined: 26 Aug 2009
Posts: 4309
Location: Tampa, FL

PostPosted: Sat 13 Nov 2010, 15:52    Post subject:  

I've compiled the evtouch xorg driver and also added the proprietary driver from the eeti website and compiled eeti's tkusb kernel module. These will be in the next Puppeee beta.

There is a discussion of configuring touchpads on puppy here: http://www.murga-linux.com/puppy/viewtopic.php?p=295649&search_id=1818654958#295649 If we can get thing working, I can fix the xorgwizard to work automatcally. Somethings in Puppeee are different than other Puppy version - such as the evdev module is compiled into the kernel but a lot of this stuff will be similar.

And also pretty good documentation if you download the official drivers here: http://home.eeti.com.tw/web20/eGalaxTouchDriver/linuxDriver.htm. But I'm uncertain if the official eeti drivers will support the t101mt or not so we'll have to experiment.
Back to top
View user's profile Send private message Visit poster's website 
Stripe

Joined: 23 Jun 2010
Posts: 658
Location: In a field. England

PostPosted: Sun 14 Nov 2010, 10:44    Post subject:  

Hi all

Got a couple of new sfs files to test for puppeee/fluppy, both are media players compiled totaly from source and both include the latest stable mplayer-1.0rc3
Note: these are only test versions and have had all help files and docs stripped to test the binaries and their dependancies

GMplayer1.0.0.sfs has the popular gnome-mplayer-1.0.0 front end and the link is:
https://docs.google.com/leaf?id=0BwWD08HgAd2yMGFmYWRmODgtMmE3MC00ZDlhLTlhM2ItZDkyMzAwZDdlMjBl&sort=name&layout=list&num=50

SMplayer.0.6.9.sfs has the larger smplayer-0.6.9 front end and the link for this is:
https://docs.google.com/leaf?id=0BwWD08HgAd2yOGU5ZTM5MDMtMTZiOC00YTIyLTk4ZWMtYjc0N2FiZDA2NjU4&sort=name&layout=list&num=50

Have fun and please let me know what you think
Stripe
Back to top
View user's profile Send private message 
morgonzola


Joined: 21 Apr 2010
Posts: 160
Location: Los Angeles, CA

PostPosted: Wed 17 Nov 2010, 13:08    Post subject:  

hey so have you seen the new iron? any thoughts about it?

the pet is here
(i know its a lupu pet but it is a pet regardless)

and i think it needs glibc =>2.11.1

the wiki page is here
actual site is here

im using pupeee 1.0 right now and it has glibc2.10 and i have heard you don't update this without breaking your system. does this pupeee have glibc >=2.11.1?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 14 [207 Posts]   Goto page: Previous 1, 2, 3, 4, 5, ..., 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0945s ][ Queries: 12 (0.0132s) ][ GZIP on ]