Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 31 Oct 2014, 05:28
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Audacity 1.2.6
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
Wally

Joined: 29 May 2010
Posts: 147
Location: Heaven, Dell X1:NO HDD, NO CD, NO FAN Pup 4.3.1 USB Boot............................ {RAP SUCKS!}

PostPosted: Sat 18 Sep 2010, 07:48    Post_subject:  Audacity 1.2.6
Sub_title: Does anybody have it?
 

Hi,

I would like a copy of Audacity 1.2.6 because it is a stable release, as opposed to 1.3.9.

Does anybody have it as a pet or otherwise? (preferably for Pup 4.3.1)

Thank you,
W
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Sat 18 Sep 2010, 09:48    Post_subject:  

I have the 1.2.6 package from Grafpup 2. I don't remember what wx version it uses, but I'm guessing it was statically compiled.

But I really recommend using 1.3.x. It has been pretty stable for years, and it has the major advantage that it can recover your project if it crashes... although I'm not sure that I have had any crashes with 1.3.x - I certainly have with 1.2.6.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Sat 18 Sep 2010, 20:17    Post_subject:  

Sorry, no it isn't statically compiled, so you'll need to find a compatible wxgtk somewhere. It might be easier to build a new package instead.

I upxed the binary to make it smaller.

Code:
# ldd audacity
        linux-gate.so.1 =>  (0xffffe000)
        libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0xb7f17000)
        libmad.so.0 => /usr/lib/libmad.so.0 (0xb7f02000)
        libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb7e08000)
        libvorbisfile.so.3 => /usr/lib/libvorbisfile.so.3 (0xb7e00000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb7dd7000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0xb7dd1000)
        libwx_gtk-2.4.so => not found
        libjack.so.0 => not found
        libasound.so.2 => /usr/lib/libasound.so.2 (0xb7d0e000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7c27000)
        libm.so.6 => /lib/libm.so.6 (0xb7c05000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb7bf9000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7be4000)
        libc.so.6 => /lib/libc.so.6 (0xb7ae9000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7ae5000)
        librt.so.1 => /lib/librt.so.1 (0xb7ad2000)
        /lib/ld-linux.so.2 (0xb7f6e000)
audacity-1.2.6.pet
Description 
pet

 Download 
Filename  audacity-1.2.6.pet 
Filesize  863.07 KB 
Downloaded  362 Time(s) 

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Wally

Joined: 29 May 2010
Posts: 147
Location: Heaven, Dell X1:NO HDD, NO CD, NO FAN Pup 4.3.1 USB Boot............................ {RAP SUCKS!}

PostPosted: Sun 19 Sep 2010, 04:10    Post_subject:  

Thanks a lot!

what libs does it need? I'm going to try the same libs as for 1.3.9, that is all I have.

...I cant find wxgtk 2.4 - only later versions.
Back to top
View user's profile Send_private_message 
disciple

Joined: 20 May 2006
Posts: 6449
Location: Auckland, New Zealand

PostPosted: Sun 19 Sep 2010, 06:33    Post_subject:  

I presume it should work with a later wxwidgets compiled with wx2.4 compatibility (otherwise I can't see the point of the 2.4 compatibility option).
But it'll also need the other options set right - i.e. no unicode and 2.6 compatibility enabled or disabled to match whatever package that was compiled against... wxwidgets is a real pain.
If you're not up to building your own packages and you insist on using the old audacity the best approach might be to install wxwidgets and audacity from another distro.

_________________
DEATH TO SPREADSHEETS
- - -
Classic Puppy quotes
- - -
Beware the demented serfers!
Back to top
View user's profile Send_private_message 
Wally

Joined: 29 May 2010
Posts: 147
Location: Heaven, Dell X1:NO HDD, NO CD, NO FAN Pup 4.3.1 USB Boot............................ {RAP SUCKS!}

PostPosted: Sun 19 Sep 2010, 06:39    Post_subject:  

Ah, well

guess it's more trouble than it's worth.

I'll have to take your word for it that 1.3x is pretty stable.

Thanks, anyway, Disciple
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0527s ][ Queries: 12 (0.0033s) ][ GZIP on ]