Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 21:31
All times are UTC - 4
 Forum index » House Training » HOWTO ( Solutions )
How to Use the P910nd Print Server
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Author Message
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Mon 14 Apr 2014, 10:11    Post_subject: Free of Windows at last!
Sub_title: Printing works
 

I took the end to support for Windows XP on April 8 as a good reason to finally retire the Windows XP LAN that I installed twelve years ago.

I did a frugal install of Lucid 5.8.2.6 on the elderly server (Thinkpad R52) and everything worked almost out of the box - except printing.

After dancing the SAMBA and looking deeply into my CUPS for several hours, I found this thread, installed the pet, followed the easy directions on the box and scored instant success.

Thanks so much for your help!
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Tue 08 Jul 2014, 08:56    Post_subject:  

@rcrsn51 I have a brother printer attached to a puppy. It will print as a local printer via cups (you kindly made me a pet for the printer some time ago). I've set up its IP as static. If I try to print through p910nd I get nothing. I also get nothing when trying to print through the network from another linux pc.
I'd be grateful for any help or advice.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 08 Jul 2014, 09:37    Post_subject:  

Do you have a firewall running on either machine? To be absolutely sure, install Peasy Firewall Monitor.

Then describe step-by-step what you have done on each machine.

What Puppy is this?

On the server machine run the command: ps
Can you see the p910nd server running?
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Tue 08 Jul 2014, 12:38    Post_subject:  

Thanks for the reply. Downloaded and installed the firewall monitor on both machines, which reports that no firewall is installed on either. Running Lucid 5.2.8 on both PCs (haven't got round to the Windows machines yet). I just followed the steps as laid out at the beginning of this thread. After installing p910nd I ran p910nd-start to get the daemon going.
The PC with the Brother printer hangs and does nothing when I try to print a test page. The job appears in the list and can be cancelled. The 2nd PC seemed to install the printer OK as set out in this thread but the test page also just hangs and nothing goes through (nothing appears on PC1's job list although the job appears on PC2's list). I've set the access rights on PC1 to allow "anonymous" to print, which is how the owners appear in the job lists. I get the feeling that PC2 is treating it as a local printer?
I've also set the brother printer up as a separate local printer on PC1 and it prints the test page OK.

Edited_times_total
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 08 Jul 2014, 12:45    Post_subject:  

rcrsn51 wrote:
On the server machine run the command: ps
Can you see the p910nd server running?

This is important.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Tue 08 Jul 2014, 12:53    Post_subject:  

There seem to be 2 entries for p910nd on the server machine. Should I kill one?
_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 08 Jul 2014, 13:01    Post_subject:  

Reboot and run p910nd-start again.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Tue 08 Jul 2014, 13:32    Post_subject:  

There is one line from ps
Quote:

xxxxx root 00.00 p9100d -f /dev/usb/lp0 0

I tried to print a test page - with the same result as before.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 08 Jul 2014, 13:37    Post_subject:  

I tested it in Lupu 528 with an HP Deskjet and it worked fine. It may be that your Brother printer needs a more direct connection to the client.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Tue 08 Jul 2014, 13:45    Post_subject:  

OK. I'll restore Windows on PC1 and and use its network printing,
Thanks for your help.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Tue 08 Jul 2014, 13:53    Post_subject:  

Have you tried CUPS shared printing?
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Wed 09 Jul 2014, 02:05    Post_subject:  

Yes. That didn't work either. I'm sure it's just down to my inexperience. I will get this to work - eventually. Smile
UPDATE Hooray. I managed to print a test page through Lubuntu to Lubuntu; I chose a "Windows printer with samba", so at least the link and the samba bit works. I'll keep reading and experimenting.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Wed 09 Jul 2014, 05:54    Post_subject:  

Here is something to test. Start the p910nd server. On the client machine, run PeasyPort and scan the server for Port 9100.
Back to top
View user's profile Send_private_message 
wimpy


Joined: 22 Aug 2012
Posts: 302
Location: Essex, UK

PostPosted: Wed 09 Jul 2014, 06:54    Post_subject:  

PeasyPort found the server and the port, so I deleted the Cups 9100 printer and re-installed . It works fine.
I can't say how grateful I am for all your help. At last, I can get rid of Windows on these old machines.

_________________
Lucid ,Precise, Carolina, Shiba_inu, Lx_pup - all frugal
Back to top
View user's profile Send_private_message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9207
Location: Stratford, Ontario

PostPosted: Wed 09 Jul 2014, 07:21    Post_subject:  

Excellent. I was pretty sure that this would work with a Brother printer.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 3 of 3 Posts_count   Goto page: Previous 1, 2, 3
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » HOWTO ( Solutions )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0660s ][ Queries: 12 (0.0070s) ][ GZIP on ]