Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 02 Aug 2014, 03:13
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lupu-515 Beta New Version DEC 18
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 202 of 210 [3149 Posts]   Goto page: Previous 1, 2, 3, ..., 200, 201, 202, 203, 204, ..., 208, 209, 210 Next
Author Message
playdayz


Joined: 25 Apr 2008
Posts: 3788

PostPosted: Sun 19 Dec 2010, 18:55    Post subject:  

For some period of time the Puppy Package Manager has had adverse effects on localization--it often, at least, 'unsets' the locale. It does that internally in order to run faster. IMHO a large set of localization problems probably are due to this.

In Lupu-516pre I have made that not happen. After all, we cannot emphasize localization and have an important program that is incompatible with it. However, PPM will run more slowly, which may or may not be noticeable.

<Add: The speed penalty does not seem very bad at all--much less than I feared.


.

Last edited by playdayz on Mon 20 Dec 2010, 00:19; edited 1 time in total
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 19 Dec 2010, 18:59    Post subject:  

playdayz wrote:
Quote:
I thought this had been taken care of, but it's there again.
Code:
# fixmenus
Generating /root/.icewm/menu...
Generating /root/.jwmrc...
Generating /root/.fbpanel/default...
killall: blinky_tray: no process killed
killall: traytemp: no process killed
killall: vattery: no process killed

(process:31428): Gdk-WARNING **: locale not supported by C library

(process:31428): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

(process:31464): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

(process:31477): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Cannot read file: /root/.retrovolrc
Using defaults...

(process:31483): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.

(process:31490): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
Generating /root/.config/openbox/menu.xml...
Openbox-Message: Couldn't set locale from environment.


What does this mean as far as using the computer? Do you lose your locale when the menus are refreshed such as in adding a pet?

And what locale were you using please?
I always use the same locale, nl_BE@euro with any puppy/derivative.
Somewhere along the lucid 2.xx it was solved and I was happy with that and sorry I don't recall exactly in which one.

Warning message like this indicate something is not quite right.

I remember shinobar had made me copy something in a lucid and in the next release it was included.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 19 Dec 2010, 19:13    Post subject: 515 locale again.  

Sorry to 'hammer' on the same issue.
I had set my locale in the first run to nl_BE@euro as I always do.
Seeing the clock wasn't set at 24 hrs (in open box and as it was in earlier lucid's) I did run the clockset manager.
So my clock was at 24 hrs, but the tooltip was in uk or us.
In order to rectify, I had to set my locale again (yes nl_BE@euro)
And do a restart X. Then the tool tip was ok in Dutch.

I have the impression, that the latest lucid's and now lupu as less and less locale friendly.

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch
Back to top
View user's profile Send private message 
MinHundHettePerro


Joined: 05 Feb 2009
Posts: 847
Location: SE

PostPosted: Sun 19 Dec 2010, 19:22    Post subject:  

Hello Smile!

Been running a lot of the lucis and now lupu515 and have been mostly content with them Smile.

Now, I just tried to use the included Calculator, and forgive if I'm daft, but........

If i enter "1e4" and then hit enter (or the equal sign button) I get 10000, as expected of course.

Now enter 1/(1e4) and hit enter - evidently 0.0001 is shown for "fix" display and 1e-4 for "sci" display.

NOW, Enter 1e-4 and hit enter ............. Sad
The result shown is −1.281718172 "e - 4" i.e. Euler's number - 4. Sad. ( 1e(-4) is not even recognised )

Is it just me Shocked, but how would one enter any number to a negative power of ten in this calculator??? (Naturally, without taking the route of entering as the inverse of the power of ten, leaving the coefficient outside) Confused Confused Confused

Confused Confused/
MHHP

_________________
Celeron 2.8 GHz, 1 GB, i82845, many ptns, modes 12, 13
Dual Xeon 3.2 GHz, 1 GB, nvidia quadro nvs 285

Slackos & 214X, ... and Q6xx
Nämen, vaf.... ln -s /dev/null MHHP
Back to top
View user's profile Send private message 
acrocosm


Joined: 12 Sep 2010
Posts: 53

PostPosted: Sun 19 Dec 2010, 19:23    Post subject: unable to get nvidia drivers to work  

I haven't been able to install nvidia drivers for my quadro fx4000. I tried 260.x and 256.x, I even wiped the previous installations but no luck.

Details...
I started with a fresh HD install of 542, the drivers installed fine. Then upgraded to 515 they weren't working anymore so I tried removing them and reinstalling, rebooting between attempts.

Before anyone asks, yes, I did use rmmod nvidia (which BTW is misspelled as "rmmod mvidia" on the info dialog). I also tried searching for whatever had the word nvidia on the filename and removed that. Nothing. Then I wiped the installation and reinstalled. I did that 2 timed trying a diferent version each time (260.x first, 256.x after). Nothing '_'
----------

Other than that, on HD install I don't get the first run wizard. I do get it if I restart x tho. That's since 510, I don't know about earlied versions. Booting from usb works fine.

The first time I did a fresh install, after rebooting to see if i get the drivers working I noticed that my sound card wasn't set anymore and I had to run the wizard again and select a card.
Back to top
View user's profile Send private message Visit poster's website 
tubeguy


Joined: 28 Aug 2009
Posts: 1326
Location: Park Ridge IL USA

PostPosted: Sun 19 Dec 2010, 19:25    Post subject:  

five point twos
http://tubeguy.org/puppybg/blue.jpg 94k
http://tubeguy.org/puppybg/minimal.jpg 163k
http://tubeguy.org/puppybg/wave_rock.jpg 662k (lots of detail in this one)
Compress further to taste. Wink
blue.jpg
Description  This color jumped out at me from a Lexus ad I saw.
jpg

 Download 
Filename  blue.jpg 
Filesize  74.87 KB 
Downloaded  220 Time(s) 
minimal.jpg
Description 
jpg

 Download 
Filename  minimal.jpg 
Filesize  92.9 KB 
Downloaded  221 Time(s) 
wave_rock.jpg
Description  http://en.wikipedia.org/wiki/Wave_Rock
jpg

 Download 
Filename  wave_rock.jpg 
Filesize  175.75 KB 
Downloaded  238 Time(s) 

_________________
Toshiba M115-S1061: PupServer |HP/Compaq D330ST: Dpup 486
Back to top
View user's profile Send private message Visit poster's website 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Sun 19 Dec 2010, 19:29    Post subject:  

Latest frugal install of Lupu-511 on another old P3. As mentioned in an earlier post, had an installer error,didn't copy the files to the hdd correctly so I copied them manually.
Everything was working on initial boot.


VIDEO REPORT: Lucid Puppy, version 515

Chip description:
Intel Corporation 82810 GMCH (Graphics Memory Controller Hub)
Intel Corporation 82810 (CGC) Chipset Graphics Controller

Driver used by Xorg:


Video mode used by Xorg:
Resolution: Depth:

...the above also recorded in /tmp/report-video
#
# glxgears
829 frames in 5.0 seconds
894 frames in 5.0 seconds
899 frames in 5.0 seconds
920 frames in 5.0 seconds
900 frames in 5.0 seconds
1398 frames in 5.0 seconds
1255 frames in 5.0 seconds
1485 frames in 5.0 seconds


-Computer-
Processor : Celeron (Coppermine)
Memory : 254MB (115MB used)
Operating System : Puppy Linux 0.51
User Name : root (root)
Date/Time : Sun 19 Dec 2010 05:25:09 PM CST
-Display-
Resolution : 1024x768 pixels
OpenGL Renderer : Mesa DRI i810 20050821 x86/MMX/SSE
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : ICH - Intel 82801AA-ICH
Back to top
View user's profile Send private message 
smil99

Joined: 18 Aug 2007
Posts: 174

PostPosted: Sun 19 Dec 2010, 20:01    Post subject: compiz + tde and XFCE  

einar wrote:
Quote:
... love puppy and i have been playing with it since 232. the only problem i got is when i use compiz. it has been noted before by lobster i think. my windows are stuck / no wobble. there is not an "top bar" with x and minimize etz, ...


Emerald windows decorations can be problematic sometimes.
Try this:

Locate .xinitrc in /root (it is a hidden file) and replace:
"emerald --replace" (without quotes)
with:
"gtk-window-decorator --replace &" (without quotes)
at the "start compiz" section:

It should look like this finally:

#start compiz
if [[ "$CURRENTWM" != "jwm" && "$CURRENTWM" != "icewm" && "$CURRENTWM" != "openbox" && "$CURRENTWM" != "startfluxbox" ]];then
if [[ `which compiz` != "" ]];then LIBGL_ALWAYS_INDIRECT=1 compiz --replace --indirect-rendering --sm-disable ccp gtk-window-decorator --replace &
sleep 3
fi
fi

instead of:
#start compiz
if [[ "$CURRENTWM" != "jwm" && "$CURRENTWM" != "icewm" && "$CURRENTWM" != "openbox" && "$CURRENTWM" != "startfluxbox" ]];then
if [[ `which compiz` != "" ]];then LIBGL_ALWAYS_INDIRECT=1 compiz --replace --indirect-rendering --sm-disable ccp emerald --replace &
sleep 3
fi
fi

Hope this helps.

Cheers.
Back to top
View user's profile Send private message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Sun 19 Dec 2010, 20:29    Post subject:  

Quote:
five point twos
http://tubeguy.org/puppybg/blue.jpg 94k

liked that
Started optimising and got the enclosed which should be neutral and unobtrusive, display even black text, use the logo and version number and only 19k
d1.jpg
Description 
jpg

 Download 
Filename  d1.jpg 
Filesize  18.91 KB 
Downloaded  248 Time(s) 

_________________
Puppy WIKI
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Sun 19 Dec 2010, 20:40    Post subject: yaf-splash  

Frugal install on USB with savfile.
Press 'Save' icon on the desktop.
Yelow splash pops up but never disappears unless you click the splash.

Remove /usr/X11R7/bin/yaf-splash. It can not anyway display UTF-8 characters.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Sun 19 Dec 2010, 20:48    Post subject: Grub4dosconfig help file  

@playdayz
I realized Grub4dosconfig help file missing in Lupu-515.
There should be /usr/share/doc/help/C/grub4dosconfig.html.

Well... /usr/share/doc/ is too much shaved?

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3401
Location: West Lothian, Scotland, UK

PostPosted: Sun 19 Dec 2010, 20:49    Post subject: Re: yaf-splash  

shinobar wrote:
Remove /usr/X11R7/bin/yaf-splash. It can not anyway display UTF-8 characters.

Is this an instruction to users, or a suggestion to developers?
Are we users to do this?
Back to top
View user's profile Send private message 
ICPUG

Joined: 24 Jul 2005
Posts: 1289
Location: UK

PostPosted: Sun 19 Dec 2010, 21:25    Post subject:  

I don't think renaming grub4dos to grub is a good idea.

To the knowledgeable ones grub implies grub legacy and would cause confusion. Indeed, before grub2, grub legacy WAS grub.

I am not sure we should rename grub4dos at all. Its creator called it grub4dos and perhaps we should respect that - how would you like it if someone packaged Lucid Puppy and called it GooglePup for instance!

If we must rename it, then puppygrub or grub4pup is perhaps an approach but somewhere it must be clear that grub4pup is grub4dos so that anyone who has problems or needs further info knows what to investigate. If its named grub they will be sent on a false trail investigating grub legacy.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Sun 19 Dec 2010, 21:42    Post subject: Re: 515 locale again
Subject description: @euro
 

Béèm wrote:
The era started purple with 246 and continues to be purple.
But I start to turn red as I have again an issue with locales.
I thought this had been taken care of, but it's there again.
Code:
# fixmenus
Generating /root/.icewm/menu...
Generating /root/.jwmrc...
Generating /root/.fbpanel/default...
killall: blinky_tray: no process killed
killall: traytemp: no process killed
killall: vattery: no process killed

(process:31428): Gdk-WARNING **: locale not supported by C library

(process:31428): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.

(process:31464): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.

(process:31477): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
Cannot read file: /root/.retrovolrc
Using defaults...

(process:31483): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.

(process:31490): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
Generating /root/.config/openbox/menu.xml...
Openbox-Message: Couldn't set locale from environment.
#
looks there is regression. Crying or Very sad

Confirmed.
It is an issue of the firstrun.
If you select nl_BE@euro, the firstrun('Personalize Settings' or 'Countrywizard') offers UTF-8 as the default, but the nl_BE@euro.UTF-8 is not supported by libc nor Xlib.
Allowed locales:
  • nl_BE
  • nl_BE@euro
  • nl_BE.UTF-8

Please tick off the 'UTF-8' checkbox if you want nl_BE@euro.
Though i recommend nl_BE.UTF-8.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
shinobar


Joined: 28 May 2009
Posts: 2607
Location: Japan

PostPosted: Sun 19 Dec 2010, 21:47    Post subject: Re: yaf-splash  

Sylvander wrote:
shinobar wrote:
Remove /usr/X11R7/bin/yaf-splash. It can not anyway display UTF-8 characters.

Is this an instruction to users, or a suggestion to developers?
Are we users to do this?

I intended for playdayz to do so, but also for the testers try it and see side effects.

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 202 of 210 [3149 Posts]   Goto page: Previous 1, 2, 3, ..., 200, 201, 202, 203, 204, ..., 208, 209, 210 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1508s ][ Queries: 12 (0.0429s) ][ GZIP on ]