Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 03:34
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
SABnzbdv 0.5.4 - Open Source Binary Newsreader
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Mon 11 Oct 2010, 08:55    Post_subject:  SABnzbdv 0.5.4 - Open Source Binary Newsreader
Sub_title: For Lucid Puppy
 

The source is available here:

http://sourceforge.net/projects/sabnzbdplus/files/sabnzbdplus/sabnzbd-0.5.4/SABnzbd-0.5.4-src.tar.gz/download

I have attempted to compile this but have failed miserably each time, so was hoping someone else could help me out compiling this to use with Puppy Linux.

Additional info:

INSTALL with only sources
-------------------------------------------------------------------------------

You need to have Python installed and some modules.

Unix/Linux/OSX
Python-2.4.4 http://www.python.org
OR
Python-2.5.4 http://www.python.org

Windows
Python-2.5.latest http://www.activestate.com

Essential modules
cheetah-2.0.1+ http://www.cheetahtemplate.org/
yenc module >= 0.3 http://sabnzbd.sourceforge.net/yenc-0.3.tar.gz
http://sabnzbd.sourceforge.net/yenc-0.3-w32fixed.zip (Win32-only)
par2cmdline >= 0.4 http://parchive.sourceforge.net/
http://chuchusoft.com/par2_tbb/index.html (multi-core)

Essential modules for python 2.4 ONLY
pysqlite3 >= 2.3.4 http://pysqlite.org (python-pysqlite2)

Optional modules
unrar >= 3.90+ http://www.rarlab.com/rar_add.htm
unrar < 3.80 Reduced funtionality
unzip >= 5.52 http://www.info-zip.org/

Optional modules Windows
pyopenssl >= 0.10 http://pypi.python.org/pypi/pyOpenSSL
(Binaries, including the OpenSSL libraries)

Optional modules Unix/Linux/OSX
pyopenssl >= 0.7 http://pypi.python.org/pypi/pyOpenSSL
openssl => v0.9.8g+ http://www.openssl.org/
Make sure the OpenSSL libraries match with PyOpenSSL

Embedded modules (only use the included version)
CherryPy-3.2 rev2138 with patches http://www.cherrypy.org


Unpack the ZIP-file containing the SABnzbd sources to any folder of your liking.
Start the program from the commandline:
python SABnzbd.py
Within 5-10 seconds your web browser will start and show the user interface.
Use the "Help" button in the web-interface to be directed to the Help Wiki.
Back to top
View user's profile Send_private_message 
p310don

Joined: 19 May 2009
Posts: 720
Location: Brisbane, Australia

PostPosted: Sun 09 Jan 2011, 08:27    Post_subject:  

I got it to work, have you got it going as yet?
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0434s ][ Queries: 11 (0.0040s) ][ GZIP on ]