Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 01 Sep 2014, 04:24
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Printers
Printer stopped working - solved
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [9 Posts]  
Author Message
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Wed 13 Oct 2010, 11:19    Post subject:  Printer stopped working - solved  

Geany - print command doesn't bring up the dialog box like it used to.

I checked menu/system/cups-manage-printing.
It says theres a job pending since yesterday
When I click on 'cancel job' i get an error message -
client-error-forbidden
I guess this means i don't have permission???

Luckily I was able to print the file using the Windoz ME system so the pc-printer connection through the router is ok

No clue where to go from here -- any help much appreciated
Is there a troubleshooting guide?
I much prefer my Puppy than having to resort to the Windows system
Thnks

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN


Last edited by canbyte on Thu 14 Oct 2010, 01:21; edited 1 time in total
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Wed 13 Oct 2010, 11:33    Post subject:  

Which version of CUPS are you using?

1. Stop CUPS with
Code:
/etc/init.d/cups stop

2. Kill any old stuff with
Code:
rm -rf /var/spool/cups
rm -rf /var/cache/cups

3. Restart CUPS with
Code:
/etc/init.d/cups start
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Wed 13 Oct 2010, 11:54    Post subject:  

Hi rcrsn51, thanks for reply
I tried entering the code into the rxvt which seemed to go ok
but when i brought up the menu/system/cups print manager/manage jobs, it still showed the same job pending. Maybe i should restart?
I'll try that now.

The error message page noted that cups is v1.1.23
----
edited to add that restart didn't help, cups still shows the old pending job. Since the commands appeared to work, it seems rxvt doesn't care where it is opened. Hopefully, there is something else to try.

---- oooh wait. Filer found a file called d00004-001 in /var/spool/cups which turned out to be the pending job. I deleted the file. There was also a file (gear icon) called C00004 and a folder called tmp in tthis directory.

Alas, deleting this has not worked. Pending job still showing. Is there a way to get permission to use the cancel-job button??? Thnks.

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Wed 13 Oct 2010, 14:08    Post subject:  

Try
Code:
lprm -

Don't miss the "dash" character on the end.
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Wed 13 Oct 2010, 16:17    Post subject:  

hi rcrsn51. Thanks again - your command successfully removed the print job showing in the cups manager. Smile
Alas, geany still does not show any print dialog box and leafpad still shows status: "print file sent, waiting for printer to finish" in the print dialog box. I tried sending a print job anyway. No luck. I restarted puppy and the printer. Leafpad still shows above message. Then I tried all your suggested commands again. I tried changing the leafpad print job to "urgent" which gave the error "too many failed attempts". Abiword shows printer state as "paused", Again, I'm snookered!

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Wed 13 Oct 2010, 16:22    Post subject:  

What happens when you try to print a test page from CUPS?

My next step would be to uninstall and reinstall the printer.
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Wed 13 Oct 2010, 18:55    Post subject:  

hi rcrsn51. Trying to send a test print from cups resulted in an error message - "client-error-request-value-too-long". Presumably because of getting combined with original command???

Installing the printer the first ttime was a months-long ordeal, compiling and all sorts of stuff i've forgotten how to do. I'd be too nervous to uninstall. I may have time this weekend to go back to an earlier pup_save file which hopefully amounts to the same thing. Sometime after our local elections, I may try to upgrade to 5.1, including the dreaded printer install. Too bad i got an Oki but it seemed like a bargain!

Thanks again.

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9061
Location: Stratford, Ontario

PostPosted: Wed 13 Oct 2010, 19:49    Post subject:  

You don't need to reinstall the driver - just the printer.
Back to top
View user's profile Send private message 
canbyte


Joined: 10 Jan 2009
Posts: 266
Location: Hamilton, Canada

PostPosted: Thu 14 Oct 2010, 00:02    Post subject:  

I guess i blew it.

I figured you meant I should let cups delete the printer and reinstall it. Naturally it was happy to delete the printer. I clicked on add-printer.
I filled in the name, location, description fields but on pressing enter got the following error message

Request Entity Too Large
The request is too large for this server to process.HTTP/1.1 413 Request Entity Too Large Date: Wed, 13 Oct 2010 15:56:50 GMT Server: CUPS/1.1 Content-Language: en_US Upgrade: TLS/1.0,HTTP/1.1 Connection: close Content-Type: text/html Content-Length: 168
Request Entity Too Large
The request is too large for this server to process.
---------
edit to update -- restarting puppy got rid of the error message

after some experimenting, the following worked to install the printer

brought up cups printer manager/manage printer/ install new printer

filled in name (oki3400), location (remote), description(sDesk)
next q - device:
select 1st choice app socke, hp direct
next question - Device URI: prompts for socket info. Answer
socket://192.168.0.4:9100
next question - make: oki
next question -- model oki c3400
continue button. Installation successful

Printed test page

Also found that if geany is not printing - it won't print a file that hasn't been saved, so just save it first.

Whew! Solved, and now I have a record of what to do next time.
Thanks for all your patient help rcrsn51 Very Happy

_________________
1. Dell Dimension E521, AMD Athln 64, 2 GHz 1.93GB ram,
Puppy 533 on CD, accesses flash drive only,
FFox Nightly12.0
2. Compaq P3 733Hz 375RAM
Printer: Oki C3400 > LAN

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [9 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Printers
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0798s ][ Queries: 11 (0.0242s) ][ GZIP on ]