Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Sep 2014, 18:00
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Zim.pet request
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [2 Posts]  
Author Message
zerobytes


Joined: 23 Oct 2010
Posts: 2

PostPosted: Sat 23 Oct 2010, 02:50    Post subject:  Zim.pet request  

Any chance someone could upload a Zim pet? My Puppy and I would be much obliged. Thanks!

http://zim-wiki.org/downloads/zim-0.48.tar.gz

-zb
Back to top
View user's profile Send private message 
moB

Joined: 19 Oct 2009
Posts: 116
Location: Coastal

PostPosted: Sat 04 Dec 2010, 10:31    Post subject:  

The application requires files not found on your Puppy. That's one
reason why no replies.

You will have to install some files--gtk+ 2.6, for example.

Puppy has the gimp tool kit v2.0 (ie gtk2.0) and others, but that still
leaves a lot to do. One dreads entering dependency hell, you know.

deps:

    * gtk+ >= 2.6
    * python >= 2.5
    * python-gtk
    * python-gobject
    * python-simplejson (for python < 2.6)
    * python-xdg (optional, but recommended)
    * xdg-utils (optional, but recommended)


On Lucid Puppy "the following packages
should be installed:"


    * python
    * libgtk2.0-0
    * xdg-utils
    * python-gtk2
    * python-xdg



http://zim-wiki.org/install.html


Check out the dependencies above on your Puppy (you don't say
which version, so I assume Lucid).

Code:


# find / -name xdg



For example the above will look for the xdg-utils, by listing all files
on your box with xdg in their name.

Try to make your request more clear--simpler to see.

Find & list all the missing dependencies (or even most) and you'll be
better served by those willing to make a package for you.

As it is that's a lot of work by only one compiler/packager for only one
user.

Hope this helps Smile

moB

Quote:


"The ribs and terrors in the whale,
Arched over me a dismal gloom,
While all God's sun-lit waves rolled by,
And lift me deepening down to doom."



--Melville, Moby-Dick
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [2 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » REQUESTS
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0415s ][ Queries: 11 (0.0034s) ][ GZIP on ]