Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 26 Nov 2014, 05:00
All times are UTC - 4
 Forum index » Off-Topic Area » Programming
first .pet attempt
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
morgonzola


Joined: 21 Apr 2010
Posts: 160
Location: Los Angeles, CA

PostPosted: Tue 26 Oct 2010, 15:22    Post_subject:  first .pet attempt
Sub_title: problems in "make" part
 

hey so this is my first attempt at compiling from source and i almost got it i think....

i wanted to get lxpanel so i could use somehting like lxde in pupeee (because pupeee comes with OB and lxde is pretty much ob + lxpanel) and so i got the source and all that fun stuff

so i put it into a directory and ran ./configure
that worked

then i did make

it was working until it said
Code:
launchbar.c:35:24: error: menu-cache.h: No such file or directory...........

and then it went downhill from there and started saying errors about something to do with recursive error. ( i would post the whole thing its just really long and i doubt you want to see all that)

is there some sort of prefix im suposed to use? im doing this on a eee pc (probably not the best choice) running pupeee
Back to top
View user's profile Send_private_message 
morgonzola


Joined: 21 Apr 2010
Posts: 160
Location: Los Angeles, CA

PostPosted: Tue 26 Oct 2010, 15:24    Post_subject:  

sorry it was just a case of RTFM Embarassed

ill have a pet up soon i hope
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Thu 28 Oct 2010, 13:47    Post_subject:  

Quote:
menu-cache.h


http://packages.debian.org/search?suite=lenny&section=all&arch=any&searchon=contents&keywords=%2Fmenu-cache.h

guess this file is missing in the .orig.tar.gz

much luck hunting for it !

header files usually are at /usr/include & /usr/X11R7/include
Back to top
View user's profile Send_private_message Visit_website 
jyore


Joined: 06 Nov 2010
Posts: 43

PostPosted: Tue 16 Nov 2010, 15:12    Post_subject:  

You are missing a dependency...

To fix it, it seems that you will need the menu-cache library...this library is dependent on glib2 and package-config, so please verify you have those...I believe both are part of the devx sfs file, so you should be ok...

You can download menu-cache from http://downloads.sourceforge.net/sourceforge/lxde/menu-cache-0.2.5.tar.gz

You need to compile and install the menu-cache library and then try your other install again.

Keep in mind that if you are making a pet, it probably won't have all the dependencies that you installed separately. Therefore you need to create a pet for each, and/or package all the installs as a single pet. See the pet making 101 guide for reference.

Hope this helps
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Off-Topic Area » Programming
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0621s ][ Queries: 11 (0.0202s) ][ GZIP on ]