Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 08:54
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 0.9.4 (094) feedback
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 9 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Author Message
ttuuxxx


Joined: 05 May 2007
Posts: 10827
Location: Ontario Canada,Sydney Australia

PostPosted: Thu 04 Nov 2010, 23:05    Post subject:  

Shep wrote:
[
It does "just work" now, but it didn't until I'd installed those 2 usb-modemswitch pets that ttuuxxx pointed out. (I'm just checking in case you believe they were not necessary when they were.) In a pristine Wary on its first run I deliberately left the wvdial APN box blank to see what would happen, and it still connected okay to the CJ network.. Shocked Shocked It's a voda modem that I set up with a Crazy Johns profile in XP. So am I correct in inferring that a blank APN causes it to default to the most recent profile in the modem?

Wow glad that 32kb total extra was enough to fix your issue, its kind of cool that so many other modems can use those 2 small pets also. Smile
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 05 Nov 2010, 08:57    Post subject:  

BarryK wrote:
Shep wrote:
In Wary, what is the CLI mimencode utility known as? Or what is the nearest base64 encoder?


I don't think we have one. We do have 'metamail', which if memory serves me correctly can read base64 encoded mail attachments (?)


Oh, I just remembered, had a mental block before. Puppy has 'uuencode' and 'uudecode', Busybox applets.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
glenco

Joined: 14 May 2010
Posts: 38
Location: Milwaukee

PostPosted: Fri 05 Nov 2010, 11:21    Post subject:  

No luck with my Pctel according to XP & W2K or ttySL0 according to my working puppy 4.21 full install.
I did a full install of 094 to my HD and installed the new –4 pet and still no modem.
Crying or Very sad
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Fri 05 Nov 2010, 13:12    Post subject:  

glenco,
Did you also do a CHOOSE > ERASE in pupdial after installing "-4"? This is necessary to activate the fix for the PcTels. Then reboot to see the effect. Do this even if no modem is shown as detected.
Richard
Back to top
View user's profile Send private message 
glenco

Joined: 14 May 2010
Posts: 38
Location: Milwaukee

PostPosted: Fri 05 Nov 2010, 14:49    Post subject:  

rerwin wrote:
glenco,
Did you also do a CHOOSE > ERASE in pupdial after installing "-4"? This is necessary to activate the fix for the PcTels. Then reboot to see the effect. Do this even if no modem is shown as detected.
Richard

Well rerwin
I have good news and I have bad news. LOL
The good news is probe worked on yet another fresh full HD install following your post to a tee.
The bad news is listed below.
I also attached a new diag I created after the errors.
Code:

--> WvDial: Internet dialer version 1.53
--> Cannot open /dev/ttySL0: Device or resource busy
--> Cannot open /dev/ttySL0: Device or resource busy
--> Cannot open /dev/ttySL0: Device or resource busy

------------------------------------------------------

Welcome to PupDial, originally written by Barry Kauler and enhanced by Richard Erwin for Puppy Linux.

There is a configuration file, /etc/wvdial.conf, that is read by
PupDial, and changes made to any of the above boxes will be saved
to wvdial.conf when you click the 'Exit' or 'Connect' buttons.
Note, you can also manually edit wvdial.conf with a text editor.

Some computers have two modems, perhaps one on the motherboard,
and Puppy may have detected the wrong one. In that case, click the
'probe' button. If it is still wrong, manually edit wvdial.conf.


--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATX3DT9083735
--> Waiting for carrier.
ATX3DT9083735
NO CARRIER
ERROR
--> No Carrier!  Trying again.
--> Sending: ATX3DT9083735
--> Waiting for carrier.
ATX3DT9083735
NO CARRIER
ERROR
--> No Carrier!  Trying again.
--> Sending: ATX3DT9083735
--> Waiting for carrier.
ATX3DT9083735
NO CARRIER
ERROR
--> No Carrier!  Trying again.
--> Sending: ATX3DT9083735
--> Waiting for carrier.
ATX3DT9083735
NO CARRIER
ERROR
--> No Carrier!  Trying again.
--> Sending: ATX3DT9083735
--> Waiting for carrier.
ATX3DT9083735
NO CARRIER
pmodemdiag-20101105.tar.gz
Description 
gz

 Download 
Filename  pmodemdiag-20101105.tar.gz 
Filesize  22.65 KB 
Downloaded  311 Time(s) 
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Fri 05 Nov 2010, 19:49    Post subject: Wary Puppy 0.9.4 (094) feedback
Subject description: ati pet
 

My Radeon hd3200 9610 is supported by the pet that you made but
although I could get to the desktop there were problems with it.


# fglrxinfo
fglrxinfo: error while loading shared libraries: libatiuki.so.1:
cannot open shared object file: No such file or directory
# report-video
VIDEO REPORT: Wary Puppy, version 094

Chip description:
oem: ATI ATOMBIOS
product: RS780 01.00

Driver used by Xorg:
radeon

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
The ati_fglrx-10.10-k2.6.31.14-w5.pet was installed when the above
messages happened.
After installing the pet and rebooting an ATI X video settings option
showed up in the setup menu but clicking on it did nothing.
The games on the hard disk that need hardware acceleration don't start.

I exited to the prompt and a message "out of range" came up on the
screen and I had to reboot.

*******************************************************************************

I already had the kernel source sfs and the devx sfs installed and I
had downloaded the ati-driver-installer-10-10-x86.x86_64.run file so I
rebooted with puppy "pfix=nox" and when it came to the prompt I
installed the commercial driver and entered "aticonfig" and then "xwin"
to get back to the desktop.
The games on the hard disk that need accelerated graphics work now.
I can also exit to the prompt and go back to the desktop with xwin now.

So it's no go with the pet on this pc, I have 2 others in the hd 5000
series but they aren't in the list of supported cards for the pet but
installing the ati-driver-installer-10-10-x86.x86_64.run file works on
them too.
# report-video
VIDEO REPORT: Wary Puppy, version 094

Chip description:
oem: ATI ATOMBIOS
product: RS780 01.00

Driver used by Xorg:
#card0driver

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
The above shows up in report-video after the commercial driver is installed.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 05 Nov 2010, 20:13    Post subject: Re: Wary Puppy 0.9.4 (094) feedback
Subject description: ati pet
 

Billtoo wrote:
# fglrxinfo
fglrxinfo: error while loading shared libraries: libatiuki.so.1:
cannot open shared object file: No such file or directory


Ah, a symlink is missing. Do this after installing the PET:

# ln -s libatiuki.so.1.0 /usr/lib/libatiuki.so.1

I will fix this in the PET pkg.

Thanks for testing this.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Fri 05 Nov 2010, 20:29    Post subject:  

Billtoo,
It looks like you need to do these too:

# cd /usr/X11R7/lib
# ln -s libAMDXvBA.so.1.0 libAMDXvBA.so.1
# ln -s libfglrx_dm.so.1.0 libfglrx_dm.so.1
# ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1
# ln -s libGL.so.1.2 libGL.so.1
# ln -s libXvBAW.so.1.0 libXvBAW.so.1

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Fri 05 Nov 2010, 21:53    Post subject:  

BarryK wrote:
Billtoo,
It looks like you need to do these too:

# cd /usr/X11R7/lib
# ln -s libAMDXvBA.so.1.0 libAMDXvBA.so.1
# ln -s libfglrx_dm.so.1.0 libfglrx_dm.so.1
# ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1
# ln -s libGL.so.1.2 libGL.so.1
# ln -s libXvBAW.so.1.0 libXvBAW.so.1


# ln -s libatiuki.so.1.0 /usr/lib/libatiuki.so.1
# cd /usr/X11R7/lib
# ln -s libAMDXvBA.so.1.0 libAMDXvBA.so.1
# ln -s libfglrx_dm.so.1.0 libfglrx_dm.so.1
# ln -s libfglrx_gamma.so.1.0 libfglrx_gamma.so.1
# ln -s libGL.so.1.2 libGL.so.1
ln: creating symbolic link `libGL.so.1': File exists
# ln -s libXvBAW.so.1.0 libXvBAW.so.1
#
#
# report-video
VIDEO REPORT: Wary Puppy, version 094

Chip description:
oem: ATI ATOMBIOS
product: PARK 01.00

Driver used by Xorg:
vesa

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
Will reboot now:
# report-video
VIDEO REPORT: Wary Puppy, version 094

Chip description:
oem: ATI ATOMBIOS
product: PARK 01.00

Driver used by Xorg:
vesa

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
I tried exiting to the prompt and entering "aticonfig --initial" and
then "xwin" but x wouldn't start.
The only way I could get back to the desktop was with xvesa.

I saw that my laptop was on the revised list so this is the result of trying to install the pet on it.

no success yet.
Back to top
View user's profile Send private message 
rerwin


Joined: 24 Aug 2005
Posts: 1529
Location: Maine, USA

PostPosted: Sat 06 Nov 2010, 00:40    Post subject: Newest DGC and HCF modem drivers available  

I have added the latest DGC (USB) and HCF modem drivers to the modem update package 4 posted here:
http://www.murga-linux.com/puppy/viewtopic.php?p=461900#461900
More details there.

Since I do not have an HCF modem for testing, please try the new driver if you have such a modem (other that the riptide combos, which are not supported). Thanks.
Richard
Back to top
View user's profile Send private message 
Shep

Joined: 08 Nov 2008
Posts: 851
Location: GIRT-BY-SEA

PostPosted: Sat 06 Nov 2010, 00:43    Post subject:  

BarryK wrote:
BarryK wrote:
Shep wrote:
In Wary, what is the CLI mimencode utility known as? Or what is the nearest base64 encoder?


I don't think we have one. We do have 'metamail', which if memory serves me correctly can read base64 encoded mail attachments (?)


Oh, I just remembered, had a mental block before. Puppy has 'uuencode' and 'uudecode', Busybox applets.

Ah, I'd never have expected to find base64 incorporated into uuencode. Surprised Thanks for pointing that out.

In the meantime, I tried copying the minencode binary from another over to Wary and found it works okay.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Sat 06 Nov 2010, 06:56    Post subject: Wary Puppy 0.9.4 (094) feedback
Subject description: ati pet
 

I started with a fresh install of 094 on a 4gb flash drive and on
first boot I just setup the network etc. and then rebooted to create
the save file.
On the second bootup I downloaded the new ati pet and installed it,
then rebooted.
Now there was a new entry in the setup menu but clicking on that gave
an error, see attached file errorscrn.jpg
I exited to the prompt and entered "aticonfig --initial" and then xwin
to restart x.
# report-video
VIDEO REPORT: Wary Puppy, version 094

Chip description:
oem: ATI ATOMBIOS
product: REDWOOD 01.00

Driver used by Xorg:
#card0driver

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
# Clicking on the new entry in the setup menu doesn't do anything
*but* clicking on one of the game files on the hard drive that
requires accelerated graphics works so the pet is working but needs
the extra step of "aticonfig --initial" at the command prompt then
xwin.
This is on my newest desktop with an ati radeonhd 5570 graphics card.

Edit:
The same method works on my laptop which has ATI Mobility Radeon
HD5470 graphics.

# report-video
VIDEO REPORT: Wary Puppy, version 094

Chip description:
oem: ATI ATOMBIOS
product: PARK 01.00

Driver used by Xorg:
#card0driver

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
Thanks for the pet Smile
errorscrn.jpg
Description 
jpg

 Download 
Filename  errorscrn.jpg 
Filesize  54.67 KB 
Downloaded  355 Time(s) 

Last edited by Billtoo on Sat 06 Nov 2010, 14:20; edited 1 time in total
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Sat 06 Nov 2010, 08:23    Post subject:  

Suggestion for pup_event_frontend_d :

lines ~779 - 786 adding break to prevent from becomming zombie :
Code:
  probe_floppy_func $ONEFLOPPY
 done

break
done #2 second loop.


###END###

added the break command.

It might be fixed at wary094 but since booting a full install and also zenpup that seems to be builded with the actual wary woof which seems not beeing able to mount its devx I am not running it.
I am posting it here because I couldn't find the appropriate thread for this.
Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3345
Location: Ontario

PostPosted: Sat 06 Nov 2010, 12:12    Post subject: new mtpaint source is available  

Quote:
don570,
As you are in contact with Dmitry, would you mind asking him if he can post the source code, or at least a patch for 3.34.56?

I would like to compile it in Wary (so it won't have that libtiff problem).
And it will be in the next release of Wary. I am particularly interested in this as I too will soon have a input tablet to play with!



On Friday Dmitry posted a new source at git
https://github.com/wjaguar/mtPaint

He also sent me an email explaining what is new...

Quote:

> Another odd thing I noticed, when I opened the folder that mtpaint was
> stored
> in and launched the terminal, then typed ./mtpaint the pressure wouldn't
> work. See attached image. I checked this several times so it is not an
> accident.

Good that you noticed this. As it happens, luci 235 (and, it seems,
234 as well) has "GDK_NATIVE_WINDOWS=true" set in its terminal's
environment for some reason.
So I made mtPaint 3.34.57 (compiled version attached to this message)
not just leave the variable alone, but actually unset it.


I will be testing it over the weekend and you can do the same.
You'll have a lot of fun with your tablet. I suggest trying 'mypaint'
which requires Ubuntu Linux. It has incredible effects Surprised
http://mypaint.intilinux.com/

Best Regards

_________________________________________________________
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10827
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 06 Nov 2010, 13:06    Post subject:  

Hi guys

I went to play a small screen sized movie on mplayer and it didn't expand the movie size it stayed little in the middle of the screen, lol so it was basically too small to view, next I tried playing a mp4 video and it had sound but no picture, ggrrrrrrrrrrrrrrrrr.
So I decided to compile Gxine, libxine, but one thing I always hated about gxine is the Ugly logo on the player, so I was on a hunt to change this, what a pain in the buttttttt, lol
First the background on the video player is a actually a movie file, mpv. and gxine has a script to make a new video background but puppy doesn't have the software installed by default, So my next step was to figure out what was needed, First it needed Imagemagic and second it needed mjpegtools and mjpegtools needed quicktime libs, So after hours of messing around, the script wouldn't build the video, I made a nice background by using gimp and it was the right size so I looked at the script and basically typed in a terminal png2yuv -n 1 -I p -f 25 -j tmp.png |mpeg2enc -n p -f 3 -a 2 -q 4 -b 10000 -o logo.mpv
and boom it made the movie:) heck I didn't even need imagemagic because the background I made was the right size already .
to make a long story short, below is a new gxine package and you need xinelibs also. I also changed a few of the icons like the volume icon. It plays mp4's and small movies expand on it.
Plus I have the sources also listed with the change background already to be compiled on other puppy versions.
ttuuxxx

Gxine (both files needed)
http://www.smokey01.com/ttuuxxx/Wary/Software/gxine-0.5.905-i386.pet
http://www.smokey01.com/ttuuxxx/Wary/Software/xine-lib-1.1.19-i386.pet

Gxine-updated sources
http://www.smokey01.com/ttuuxxx/Wary/Software/gxine-0.5.905-src.tar.gz


Image Magic with 25MB of docs, lol

http://www.smokey01.com/ttuuxxx/Wary/Software/ImageMagick-6.6.2-6-i386.pet

mjpegtools needs both pets to fully run
http://www.smokey01.com/ttuuxxx/Wary/Software/mjpegtools-1.9.0-i386.pet
http://www.smokey01.com/ttuuxxx/Wary/Software/libquicktime-1.1.5-i386.pet

also the quicktime libs are cool you can play movies via the terminal, Like Quicktime movies.
open a terminal in the movie location and type lqtplay moviename.mp4

enjoy
ttuuxxx
gxine.jpg
 Description   
 Filesize   41.79 KB
 Viewed   1159 Time(s)

gxine.jpg


_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 9 of 10 [143 Posts]   Goto page: Previous 1, 2, 3, ..., 7, 8, 9, 10 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1310s ][ Queries: 12 (0.0147s) ][ GZIP on ]