Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 20 Dec 2014, 09:10
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
XMMS not installing right???
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [6 Posts]  
Author Message
timbrown

Joined: 16 Nov 2010
Posts: 4

PostPosted: Tue 16 Nov 2010, 15:19    Post subject:  XMMS not installing right???
Subject description: Ultimately trying to get Linex USB transmitter working...
 

Hello! i'm new to Puppy and really liking it. I found out about this OS while searching for (PCLOS) linux drivers for my Linex USB transmitter.

I've tried to get this going, per the instructions here:
http://www.murga-linux.com/puppy/viewtopic.php?p=67085&sid=d82af07a4e106605bb5ff1c70ce5d91f

...but installing xmms isn't panning out.

I installed the dotpuphandler first, then "puppybasic" per the package handler. I then had it install xmms.

When I click on XMMS, nothing happens.

When I type xmms at the console, I get the following:
Error while loading shared libraries: libgtk-1.2.so.0: cannot open shared object file: no such file or directory.

Not sure what to do from here. Can anyone please help? I'd really like to get this transmitter working!
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Tue 16 Nov 2010, 15:45    Post subject:  

XMMS requires GTK 1 to be installed, I believe, which most recent Puppy versions don't have (they have GTK 2). There should also be at least one or more .pet/.pup installers for GTK 1 somewhere on the forum; use this search page to search the forum for them.
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
timbrown

Joined: 16 Nov 2010
Posts: 4

PostPosted: Tue 16 Nov 2010, 16:04    Post subject:  

thank you! I found a .pup file, but it failed to install. Something about a file missing...

However I did find a tar file. I'll give it a look and do some searching on how to install this. It has been a few years.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Tue 16 Nov 2010, 16:39    Post subject:  

Weird. The search page I linked to isn't working for me, today, for some reason. Shocked

I found a .pet for GTK 1.2 on the forum with a normal Google search: http://www.murga-linux.com/puppy/viewtopic.php?p=438861#438861. Maybe that one will work.

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
timbrown

Joined: 16 Nov 2010
Posts: 4

PostPosted: Tue 16 Nov 2010, 16:48    Post subject:  

THANK YOU! xmms is now properly installed.

I did a "modprobe snd-usb-audio" and it is reporting that modprobe.conf is deprecated. Something else to work on....

Thanks again!
Back to top
View user's profile Send private message 
timbrown

Joined: 16 Nov 2010
Posts: 4

PostPosted: Tue 16 Nov 2010, 19:11    Post subject:  

Great! it's working...after a fashion! much further along than with any other distro to date.

Two issues yet, which I'll look into, one of which has to do with getting a pls file stream to work in xmms. This was easy in PCLINUXOS but must need to change a setting here...

the other has to do with getting the volume control back on my task bar...it disappeared for some reason!

Again, thanks....!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [6 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0452s ][ Queries: 11 (0.0031s) ][ GZIP on ]