Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 21 Sep 2014, 00:30
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
How to install vpnc? (Puppy 4.3)
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [8 Posts]  
Author Message
DaDrivel

Joined: 02 Oct 2010
Posts: 8

PostPosted: Wed 01 Dec 2010, 07:04    Post subject:  How to install vpnc? (Puppy 4.3)  

Hi everyone,

I recently tried to install the vpnc client from the sourcecode (http://www.unix-ag.uni-kl.de/%7Emassar/vpnc/) on my Puppy 4.3 Cielo (hard installation).
First of all I installed the dev_xxx.sfs for the gcc. After that, the installation aborted with an error, that libgcrypt and libgpg-error libraries are missing, so I installed them (from sourcecode). Still, after that, the installation aborted with the error
Code:
error while loading shared libraries: ligcrypt.so.11 cannot open shared object

After a small research, I found this thread here . So i copied these files into my /usr/lib and retried the installation.
Again.. aborted with
Code:
./makeman.pl
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = (unset),
    LC_ALL = (unset),
    LANG = "de_DE.utf8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
sed -e 's,@''PREFIX''@,/usr/local,g' vpnc-script.in > vpnc-script && chmod 755 vpnc-script

I cant understand what the problem is here.
Maybe you have an idea or already got the vpnc (or other vpnc clients) working on Puppy.

I hope, you can help me,

Cheers,
DaDrivel
Back to top
View user's profile Send private message 
DaDrivel

Joined: 02 Oct 2010
Posts: 8

PostPosted: Wed 15 Dec 2010, 06:17    Post subject:  

Nobody's got an idea?
Or did I ask my question too ambiguous?
Maybe anyone already installed another IPSec vpn client (but... is there another one than vpnc or Cisco...?)

I hope you can help me,

Greetings,
DaDrivel
Back to top
View user's profile Send private message 
Master_wrong

Joined: 19 Mar 2008
Posts: 456

PostPosted: Wed 15 Dec 2010, 07:09    Post subject:  

http://www.murga-linux.com/puppy/viewtopic.php?t=21294


please check above

_________________
Cluster-Pup v.2-Puppy Beowulf Cluster
http://www.murga-linux.com/puppy/viewtopic.php?p=499199#499199
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5259
Location: Australia

PostPosted: Wed 15 Dec 2010, 07:38    Post subject:  

DaDrivel wrote:
Code:
perl: warning: Falling back to the standard locale ("C").
sed -e 's,@''PREFIX''@,/usr/local,g' vpnc-script.in > vpnc-script && chmod 755 vpnc-script

Those error messages don't look serious.
Just go ahead and do -
Code:
make install
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5259
Location: Australia

PostPosted: Sat 18 Dec 2010, 01:05    Post subject:  

vpnc dotpet package now available for Puppy 5.1/5.2 here
http://www.murga-linux.com/puppy/viewtopic.php?t=63121
Back to top
View user's profile Send private message 
DaDrivel

Joined: 02 Oct 2010
Posts: 8

PostPosted: Wed 19 Jan 2011, 06:13    Post subject:  

Thanks for your replies.
Im sorry for my late response, but i had issues, getting my WLAN card working on Lupu 5.1/2 now... I had those b43, ssb issues with my Puppy 4.3 before and solved them with installing the kernel module wl and blacklisting the ssb module.
My problem now is, that this wl module just exists for Puppy 4.3. Can I also use it for 5.1/2 or are there other compilations of that module for 5.1/2. Or is it enough to blacklist ssb, cause I think I once heard, the wl module is automatically installed on Lupu.

I know this is a bit of offtopic here, but your solutions refer to 5.1/2, so I tried to install Lupu; without succeeding in configuring my WLAN correcty, so far.

I hope you can help me again
Thanks,

DaDrivel

P.S: make install also fails.
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5259
Location: Australia

PostPosted: Wed 19 Jan 2011, 07:32    Post subject:  

The prorietary Linux Broadcom wl driver compatible with Puppy 5.1/5.2 was contributed by forum member piratesmack -
http://murga-linux.com/puppy/viewtopic.php?p=421596#421596

DaDrivel wrote:
make install also fails.

Just use the vpnc dotpet I provided.
Back to top
View user's profile Send private message 
DaDrivel

Joined: 02 Oct 2010
Posts: 8

PostPosted: Sat 22 Jan 2011, 21:12    Post subject:  

Thanks for your answer again Smile

I used the wl driver, provided by piratesmack, which only worked on Lupu 5.1, not on 5.2 for me. Well, maybe it was my fault, Im not sure, but Im also happy with 5.1 Smile
After that, I installed your vpcn.pet which worked fine without any problems Smile

Thank you very much for helping!

Your,

DaDrivel
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [8 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Network
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0590s ][ Queries: 11 (0.0066s) ][ GZIP on ]