Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 29 Jul 2014, 04:52
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
VirtualBox for many Puppies
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 13 [188 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 11, 12, 13 Next
Author Message
gcmartin

Joined: 14 Oct 2005
Posts: 4111
Location: Earth

PostPosted: Mon 26 Dec 2011, 17:17    Post subject:  

Quote:
Actually, an ISO like that might not be a bad idea, but I'd be clueless where to begin. I've never built or trimmed a Puppy before, but I'd think a somewhat cut-down Puplet would be ideal, to give the VM some more breathing room on whatever hardware gets used. In any case, that would be a bit beyond my scope.
JamesBond and TaZoC (I believe) are regular users of your VB. They possess skill that us motals may not posses at this time. Might be worth a PM asking for advice or assistance.

Their may be other, too, who have the skills and are users, such as Pemasu or others.

Reason that I mentioned 64bit is that most/all 64bit PCs I have ever worked with started at 1GB+ RAM. Also, I believe a 64bit platform would adequately run 32 and 64 bit OSs that might be booted a virtual machine.

Hope this helps

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Wed 28 Dec 2011, 10:36    Post subject: virtualbox-4.1.8.sfs  

UPDATE:
virtualbox-4.1.8.sfs for Puppy 4.3.1 and most of Puppies 5.x.
as for Slacko, use virtualbox-4.1.6-slacko.sfs.
http://www.murga-linux.com/puppy/viewtopic.php?p=481055#481055

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Thu 29 Dec 2011, 19:17    Post subject:  

Updated to version 4.1.8. shinobar's post with SFS options remains linked in the first post.

I've made available an alternate sort of package this time around. Basically, while the old, all-in-one packages, with both the drivers and the rest of the VBox binaries) are still available for download, the newer type of packages are broken up a bit.

A single VBox base package, suitable for all Puppies, is available, and a drivers package is available for each specific Puppy. You install the base package and your specific drivers package, and go!

It's all explained in the packages guide, linked to in the first post. Let me know what you think! Any suggestions, or reports of any difficulties this new arrangement may create should be posted in this thread, or sent to me in a PM.

Regards!

Last edited by TheAsterisk! on Sat 31 Dec 2011, 09:08; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Sat 31 Dec 2011, 09:08    Post subject:  

Added a package for the PAE kernel (2.6.39.4) version of Slacko.

No VirtualBox version change.
Back to top
View user's profile Send private message Visit poster's website 
gcmartin

Joined: 14 Oct 2005
Posts: 4111
Location: Earth

PostPosted: Sat 07 Jan 2012, 15:03    Post subject: More than 3GB should use this  

TheAsterisk! wrote:
Added a package for the PAE kernel (2.6.39.4) version of Slacko.

No VirtualBox version change.
This is a very forward-thinking addition for the 32bit PCs PAE is not only fast, but also supports all RAM that can be thrown at it.

Thanks

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
tatamata

Joined: 02 May 2010
Posts: 63

PostPosted: Tue 10 Jan 2012, 10:30    Post subject:  

Hello.
I have installed VirtualBox 4.1.8 in SnowPuppy020. When I start ReactOS in it, I get error: "Kernel driver not installedd (rc=-1908). The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdriver. Please reinstall the kernel module by executing '/etc/init.d/vboxdrv setup' ".
When i execute /etc/init.d/vboxdrv setup, it fails, even if I load kernel_src-2.6.38.4-lupe20.sfs.

Do you have an idea?

Thanks.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 10 Jan 2012, 16:08    Post subject:  

I posted to the pm the correct kernel source sfs link. It is now found from snow puppy-020 first page.
Back to top
View user's profile Send private message 
tatamata

Joined: 02 May 2010
Posts: 63

PostPosted: Tue 10 Jan 2012, 16:21    Post subject:  

Yes, pemasu, thank you, the kernel source you gave me link, solved the problem:
http://www.smokey01.com/pemasu/Kernel_sources/kernel_src-2.6.35.7-patched-lupe5.sfs
Back to top
View user's profile Send private message 
ralph1bart

Joined: 09 Dec 2011
Posts: 1

PostPosted: Tue 10 Jan 2012, 16:58    Post subject: Thanks!  

Upgraded 414 to 418 without a hitch. Desktop Icon didn't even need an update. Realized this is where I got the 414.
Thanks for the work on these pets and the info on what goes with what. And the audio info... i knew something was wrong but didn't know it was the usr or the app.
Regards,
Ralph.
Back to top
View user's profile Send private message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Wed 25 Jan 2012, 22:51    Post subject:  

I've just upgraded my guest Puppy VM to Slacko 531, from Puppy 431. Guest additions (on VBox 4.1.8 ) work- mostly. To resize the display, I have to resize the VM window, then restart X on the guest, but it will then adjust itself just as it should.

I'll see if I can't make a dot-pet of the guest additions. If it works well, I might make guest additions for other Puppy versions, too.

See you all in a bit...

EDIT: Well, X is falling apart on the VM a little more each time I boot it. Strike that idea. I'll try a few other things, but- as usual- no guarantees. Confused
Back to top
View user's profile Send private message Visit poster's website 
michaellowe


Joined: 17 Dec 2011
Posts: 12
Location: The Garden

PostPosted: Mon 06 Feb 2012, 18:10    Post subject: Win XP Pro Black Ed install issue in Virtual box 4.0.0  

Hello, this has been a source of much frustration.
I want to be able to run Win XP Pro in Virtual Box 4.0.0 as I have this loaded as an sfs on the fly in Puppy 5.2.5 which as I understand is supposed to help relieve the memory a little?
Everything went smoothly up until the installation of the win xp pro.
in the VM please find attached a .png file: a screen shot of the message I get, something to do with can't access and lock memory? Have you come across this before? i have also attached a log file of the installation if it may help shed some light into the probem I am faced with. please pay particular attention to line 702 through to line 715 in the log file: vbox.zip which sums up what was going on at the time of the error message
I have the kernelsource sfs and the lupu_devx525.sfs required for my version of puppy loaded as instructed in the vbox usermanual so I can't see why i am getting this error message, what am I missing?Just checked the VBox log and the host ram is 487mb ram available is 232mb
Please help
Kind Regards
M
VBox.zip
Description 
zip

 Download 
Filename  VBox.zip 
Filesize  61.64 KB 
Downloaded  340 Time(s) 
error loading win xp pro in vbox.png
Description 
png

 Download 
Filename  error loading win xp pro in vbox.png 
Filesize  379.24 KB 
Downloaded  337 Time(s) 
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2598
Location: Japan

PostPosted: Mon 06 Feb 2012, 22:20    Post subject: Re: Win XP Pro Black Ed install issue in Virtual box 4.0.0  

michaellowe wrote:
Everything went smoothly up until the installation of the win xp pro.
in the VM please find attached a .png file: a screen shot of the message I get, something to do with can't access and lock memory?

You can change 'Default Machine Folder' to /mnt/home/VirtualBox or somewhere.
The setting is at VirtualBox menubar, File>>Preferences>>General.

See also:
http://www.murga-linux.com/puppy/viewtopic.php?t=62110

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
sebus

Joined: 20 Jan 2012
Posts: 62

PostPosted: Wed 08 Feb 2012, 15:18    Post subject:  

TheAsterisk!, not that I complain, but you are not interested in x64?

sebus
Back to top
View user's profile Send private message 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 10 Feb 2012, 21:01    Post subject:  

sebus wrote:
TheAsterisk!, not that I complain, but you are not interested in x64?

sebus

Oh, I am interested in 64-bit, but in a way that doesn't much help, as I have no access to any 64-bit machines on which to create the necessary packages! Embarassed Alas, I've yet to receive a 64-bit monster for Curbside Christmas!

That being said...

I've been in forum-based correspondence with TaZoC, who makes the puplet "Lighthouse Pup," which I believe is 64-bit, and apparently he's developed some sort of scheme in LHP whereby users can slickly download and install the latest VirtualBox release from Oracle's site, with prepared scripts handling the messy details. If I can figure out what's going on in that, once I have a chance to dissect it (TaZoC hasn't sent me the scripts yet, as far as I know), I'll see what I can do about putting a solution up in this thread.

The issue, of course, would be that I can't test it, so we'll see what happens as it comes up. Keep your fingers crossed, though!
Back to top
View user's profile Send private message Visit poster's website 
TheAsterisk!


Joined: 10 Feb 2009
Posts: 403
Location: SE Wisconsin, US

PostPosted: Fri 10 Feb 2012, 21:11    Post subject:  

I'm going to be eliminating some of the redundant VirtualBox packages tonight and tomorrow. All the version 4.1.8 and 3.x.x packages will be left alone, as will the dot-pets that compile their drivers upon installation, but the other ones are subject to my discretion, and may be cut out if the same Puppy has a newer package available.

As always, if you need an older package for some reason, let me know within the next few weeks. I'll keep some local copies around for at least a little while, just in case.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 6 of 13 [188 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, ..., 11, 12, 13 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Virtualization
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0863s ][ Queries: 12 (0.0058s) ][ GZIP on ]