Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Oct 2014, 07:23
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 5.0-final feedback
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 8 of 21 [308 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 19, 20, 21 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Wed 05 Jan 2011, 05:01    Post subject: Re: Replace kernel in Wary 5.0 for wifi support?  

amc wrote:
Since the wifi in Puppy 5.15 Beta works on my old Vaio laptop (see post above), but the wifi in Wary 5.0 does not "associate" using this laptop, I decided to try to switch the kernel in Wary 5.0 like in this post (http://www.murga-linux.com/puppy/viewtopic.php?t=60180). I was able to switch the kernels and get Wary 5.0 to boot with the 5.15 Beta kernel, but now I don't see any of the wifi drivers in the Network Manager!

Is there some other stuff (besides that detailed in the "How To" post) that I should move from 5.15 into Wary to make this work? I am not sure about what all the wifi dependencies are from one Puppy to the next.

Thanks,
-Aaron


Hi Aaron

A quick first question - if lupu works for you, why do you need to get wary working as well? Is there some feature of wary that is missing in lupu that you want?

Next can you say what your wifi setup consists of and what the exact errors you are seeing on wary?

Have you tried going through the manual steps in http://murga-linux.com/puppy/viewtopic.php?t=22469 to setup the wifi on wary? This would give clues as to where the problem lies.

When you swapped kernels did you replace the /lib/network folder as described in the later posts in the topic?

This may not be the ideal thread for this discussion as it is meant to be to report bugs in wary..... if you move it elsewhere please let us know.

Cheers
Peter
Back to top
View user's profile Send private message Visit poster's website 
chrome307


Joined: 15 Jan 2009
Posts: 713

PostPosted: Wed 05 Jan 2011, 07:54    Post subject:  

Similar problem with detecting audio card on a different PC:



However on a positive note did managed to get my i810 gfx working only after I looked for the additional package available in the reps for this card.

xf86-video-i810-2.1.1-w5.pet

Finally could not get to use my ATi gfx card, even though I tried all the additonal pets available in the rep for this brand Sad

Back to top
View user's profile Send private message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Wed 05 Jan 2011, 19:51    Post subject:  

win (Super/Hyper/Meta) hotkeys don't work. They did in "4.3.*". To enable the win key. Set the keyboard model to "pc104". The hotkeys were set using JWM. If I use XBindkeys, I can the have win hotkeys.
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send private message Visit poster's website 
amc

Joined: 31 Dec 2010
Posts: 6

PostPosted: Wed 05 Jan 2011, 23:18    Post subject: Re: Replace kernel in Wary 5.0 for wifi support?  

Hi Peter:

The reason that I wanted to try Wary is the Lupu runs kind of slow on the Vaio. I thought that Wary, since it is intended for older machines, might be a little snappier. In fact it is snapper, but it is not a fair comparison since the wifi stack is not running under Wary and it is under Lupu.

I did move the /lib/network folder as described in the thread.

You're right, this may not be the best place in the forum to discuss this. I'm new here and I was not sure what the community considers a "bug". To me, the wifi working with one recent version of puppy and not another, across multiple machines, seems like a bug. Perhaps the network stack in Wary is not intended to handle the particulars of my wifi network (hidden ESSID, WPA-TKIP). I wanted to swap the kernels mostly as a test. For what it is worth. I have tried both a USB and a PCMCIA wifi adapter with the Viao, and well as the build-in wifi on another laptop running Wary, and none of them connect to my network. So the indications are that this is not a hardware/driver problem, but something more general in the network stack.

I have not gone through the manual configuration steps. Thanks for the link, that is the next thing to try. I'll start another topic under bugs when I find something.

Thanks for the help,
-Aaron
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 9203
Location: Stratford, Ontario

PostPosted: Thu 06 Jan 2011, 00:39    Post subject: Re: Replace kernel in Wary 5.0 for wifi support?  

amc wrote:
The reason that I wanted to try Wary is the Lupu runs kind of slow on the Vaio. I thought that Wary, since it is intended for older machines, might be a little snappier. In fact it is snapper, but it is not a fair comparison since the wifi stack is not running under Wary and it is under Lupu.

Try Quirky 1.3. It is light-weight like Wary, but has a newer kernel. Do NOT get Quirky 1.4!
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1047
Location: the australian mallee

PostPosted: Thu 06 Jan 2011, 01:27    Post subject:  

chrome307 wrote:

Finally could not get to use my ATi gfx card, even though I tried all the additonal pets available in the rep for this brand Sad


did you try the xorg-high-lucid pet?

try adding it and doing this:

installing the xorg-high pet, dropping out of the x server (menu>shutdown>exit to prompt) and then typing "xorgwizard" and following the prompts >probe>set screen size (accept defaults or change to screensize wanted) and complete the setup back to a #, then type xwin. I am now set up correctly.

It fixed my radeon problem (would only allow xvesa), good glxgears too now.

regards
scsijon
Back to top
View user's profile Send private message Visit poster's website 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Thu 06 Jan 2011, 01:56    Post subject: Re: Replace kernel in Wary 5.0 for wifi support?  

rcrsn51 wrote:
amc wrote:
The reason that I wanted to try Wary is the Lupu runs kind of slow on the Vaio. I thought that Wary, since it is intended for older machines, might be a little snappier. In fact it is snapper, but it is not a fair comparison since the wifi stack is not running under Wary and it is under Lupu.

Try Quirky 1.3. It is light-weight like Wary, but has a newer kernel. Do NOT get Quirky 1.4!


x2

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Thu 06 Jan 2011, 14:15    Post subject: Wary Puppy 5.0-final feedback  

I made a pet of Ltris, a falling blocks game.
Compiled and tested in Wary 5.0
ltris-1.0.15-i486.pet
Description 
pet

 Download 
Filename  ltris-1.0.15-i486.pet 
Filesize  475.44 KB 
Downloaded  371 Time(s) 

Last edited by Billtoo on Thu 06 Jan 2011, 21:05; edited 1 time in total
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 2127
Location: Ontario Canada

PostPosted: Thu 06 Jan 2011, 14:16    Post subject: Wary Puppy 5.0-final feedback  

There seems to be a problem uploading anything to the forum.

It's working again,thankyou John.

Last edited by Billtoo on Thu 06 Jan 2011, 21:30; edited 1 time in total
Back to top
View user's profile Send private message 
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Thu 06 Jan 2011, 17:35    Post subject: Want to run on old PC
Subject description: Need a kernel with hda, not sda
 

Detailed description of the problem is here: http://www.murga-linux.com/puppy/viewtopic.php?t=62131
Last Wary that I can run OK on that PC is Wary-0.3. It has hda-kernel. I want to run Puppy-5.0 on that. It has sda-kernel. Is it possible to make hda-kernel for Wary-5.0?
PuppyRus-2.0 retro has such kernel (same version but with hda). But it is unstable and I like Wary more.
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10827
Location: Ontario Canada,Sydney Australia

PostPosted: Fri 07 Jan 2011, 07:08    Post subject:  

Hi Barry I compiled The latest Scribus, Its very large due to the plugins, I used a static QT 4 I compiled on 2.14X, Kind of cool that it works on Wary. The pet scribus-1.3.9-i386.pet is 213MB, lol 492MB expanded and that's after its been stripped, did you want the pet, I could upload it. If not I understand its kind or really big.
I also compiled a few other static qt apps that are pretty good.
I'll upload those later.
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
broomdodger


Joined: 09 May 2008
Posts: 269
Location: Santa Cruz, CA

PostPosted: Fri 07 Jan 2011, 14:40    Post subject: Re: Replace kernel in Wary 5.0 for wifi support?  

rcrsn51 wrote:
Try Quirky 1.3. It is light-weight like Wary, but has a newer kernel. Do NOT get Quirky 1.4!
Please explain the "Do NOT get Quirky 1.4".
-Bill
Back to top
View user's profile Send private message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Fri 07 Jan 2011, 14:53    Post subject: Re: Replace kernel in Wary 5.0 for wifi support?  

broomdodger wrote:
rcrsn51 wrote:
Try Quirky 1.3. It is light-weight like Wary, but has a newer kernel. Do NOT get Quirky 1.4!
Please explain the "Do NOT get Quirky 1.4".
-Bill


Quirky 1.3 is (was) cutting edge. Quirky 1.4 is basically Wary with a fancy name. Personally, I dont believe it deserves a Quirky name! BUT. There are plans for a new cutting edge Quirky Smile

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sat 08 Jan 2011, 04:45    Post subject:  

ttuuxxx wrote:
Hi Barry I compiled The latest Scribus, Its very large due to the plugins, I used a static QT 4 I compiled on 2.14X, Kind of cool that it works on Wary. The pet scribus-1.3.9-i386.pet is 213MB, lol 492MB expanded and that's after its been stripped, did you want the pet, I could upload it. If not I understand its kind or really big.
I also compiled a few other static qt apps that are pretty good.
I'll upload those later.
ttuuxxx


Oh man, that is big! I would not want it as a PET, but it might be ok as an SFS.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
ttuuxxx


Joined: 05 May 2007
Posts: 10827
Location: Ontario Canada,Sydney Australia

PostPosted: Sat 08 Jan 2011, 12:19    Post subject:  

Here's 2 static qt apps, I'll post more tomorrow Smile
one is called scythiaFTP, its basically a cute and simple ftp client.
http://www.smokey01.com/ttuuxxx/Wary/Software/scythiaFTP_0.9.3-2-i386.pet <--application
http://www.smokey01.com/ttuuxxx/Wary/Software/scythiaFTP_0.9.3_DOC-2-i386.pet <--docs

next is smplayer, smplayer is gui for Mplayer, so you need to have mplayer installed for this to work. This Gui is probably the best gui of all media players, its layout is nice and clean and has buttons for things like subtitles etc. Fullscreen works on jwm, if you stop the movie, set it fullscreen and then start the movie.

http://www.smokey01.com/ttuuxxx/Wary/Software/smplayer-0.6.8-i386.pet <--application
http://www.smokey01.com/ttuuxxx/Wary/Software/smplayer_DOC-0.6.8-i386.pet <--doc's
scythiaftp.jpg
 Description   
 Filesize   57.79 KB
 Viewed   1699 Time(s)

scythiaftp.jpg

smplayer.jpg
 Description   
 Filesize   35.63 KB
 Viewed   1678 Time(s)

smplayer.jpg


_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 8 of 21 [308 Posts]   Goto page: Previous 1, 2, 3, ..., 6, 7, 8, 9, 10, ..., 19, 20, 21 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1280s ][ Queries: 12 (0.0347s) ][ GZIP on ]