Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 23 Nov 2014, 08:43
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Lucid Puppy 5.2 feedback and bug reports
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 22 [317 Posts]   Goto page: 1, 2, 3, ..., 20, 21, 22 Next
Author Message
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Fri 07 Jan 2011, 08:12    Post subject:  Lucid Puppy 5.2 feedback and bug reports
Subject description: Official releaese of lupu-520
 

Lucid Puppy 5.2

Release announcement:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/puppy-5.2/release-Lucid-520.htm

Download:

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/puppy-5.2/lupu-520.iso

___________________________________

Before reporting any bugs there is a help page at Lupu News

http://www.diddywahdiddy.net/LupuNews/index4.html

The information there may help you overcome your problem

____________________________________

Fixes:


jfs fix (also perhaps if you have missing drivers that were present in 5.1x) http://www.murga-linux.com/puppy/viewtopic.php?p=485759#485759

Unetbootin (their bug, not ours) http://www.murga-linux.com/puppy/viewtopic.php?p=483946#483946

Quickpet bugfix http://www.murga-linux.com/puppy/viewtopic.php?p=487193#487193

_____________________________________

Please report any bugs and fixes or other feedback and suggestions here.

_____________________________________________________________

Announcing Here First: Instant Update 001 for Lucid 5.2

http://distro.ibiblio.org/pub/linux/distributions/puppylinux/pet-packages-lucid/Update_Lucid52-001.pet

This is *not* a crucial bug-fix update because we simply have not found enough bugs to justify that. However it does contain a few nice enhancements.

=> PupControl 1.3 by radky starts with the Setup Icon on the desktop

=> Desksetup Icon Templates by 01micko to make it easy to adjust icon placement on Desktop

_________________
Woof Mailing List | keep the faith Cool |

Last edited by 01micko on Tue 08 Feb 2011, 18:08; edited 5 times in total
Back to top
View user's profile Send private message Visit poster's website 
tronkel


Joined: 30 Sep 2005
Posts: 1104
Location: Vienna Austria

PostPosted: Fri 07 Jan 2011, 10:27    Post subject:  

Wow! - great job Micko. Must be one of the best Linuces to date - Puppy or otherwise.

I installed the Codeblocks Programmers' IDE together with the Fluid-FLTK GUI builder from the Lucid repos (via the PPM) after installing the devx for 520. There was one libpython shared library missing (for the gdb debugger tool) that I installed from the PPM also.

This worked first time - something that I couldn't do with either Debian or Linux Mint Debian. So all set up now to do some useful FLTK programming for Puppy 520.

I also installed Compiz Fusion and the XFCE4 desktop packages. Had some initial problems with losing the XFCE window decorations, but finally got them back by replacing "emerald --replace &" with "gtk-window-decorator --replace &" in /root/.xinitrc. Also did this in the Compiz Setting Manager - in the Window Decoration configuration dialogue.

The Emerald settings manager bombs out on my system, so the XFCE compiz packages need a look at at some point. Research on the net shows that the Emerald packages for Ubuntu/Debian appear to be bugged. If they do come up with repaired code, this would be the time to sort out the XFCE Compiz stuff in the Lucid 520 repo. At least it works at the moment though - albeit with some fiddling around.

In all, the desktop complete with wBAR and Compiz running in XFCE looks terrific. Someone ought to do a fat puplet with that stuff included out-of-the-box.
puppy520-desktop.jpg
Description 
jpg

 Download 
Filename  puppy520-desktop.jpg 
Filesize  73 KB 
Downloaded  1520 Time(s) 

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
emil

Joined: 10 Nov 2009
Posts: 618
Location: Austria

PostPosted: Fri 07 Jan 2011, 11:02    Post subject: terrific  

Hi tronkel,
would be terrific if someone would be you! Wink
You have the work already done Very Happy
emil
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Fri 07 Jan 2011, 11:33    Post subject:  

Quote:
the XFCE compiz packages need a look at at some point.

Hey tronkel, IN PPM, there is one item that has compiz and xfce together. That is newer. Did you use that or the two separate listings? Thanks.
Back to top
View user's profile Send private message 
tronkel


Joined: 30 Sep 2005
Posts: 1104
Location: Vienna Austria

PostPosted: Fri 07 Jan 2011, 11:40    Post subject:  

@emil. Gruessi!

I have already made a remastered ISO snapshot of this system that includes XFCE4 Compiz and Codeblocks. The ISO is 748MB so needs a DVD. Also, I'm not entirely happy with the way that the live DVD ISO handles Compiz at the moment.

But yes, you're right. I ought to sort this out. Let's see if there's a demand first of all and then I'll have another shot at it. This really ought be built using the Woof build system rather than a simple re-master in any case.

Alles gute

tronkel

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
tronkel


Joined: 30 Sep 2005
Posts: 1104
Location: Vienna Austria

PostPosted: Fri 07 Jan 2011, 11:45    Post subject:  

Playdayz wrote:

Quote:
Hey tronkel, IN PPM, there is one item that has compiz and xfce together. That is newer. Did you use that or the two separate listings? Thanks.


Aha! lol that's a point! I installed both of them - silly me!. I'll have a play around with a pristine frugal pupsave and see if that improves the way Compiz/XFCE4 behaves.

_________________
Life is too short to spend it in front of a computer
Back to top
View user's profile Send private message Visit poster's website AIM Address 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Fri 07 Jan 2011, 11:54    Post subject:  

Odd really. The Fn brightness up/down keys dont work as they should. Adjustments dont happen until after re-starting X, so, adjust brightness down, nothing happens, re-start X and the screen is dimmer, and vise versa.
This happens sometimes with various versions of Puppy. Just now, Spup works as expected.
Small thing that would probably take forever to find...............

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 4436
Location: Earth

PostPosted: Fri 07 Jan 2011, 14:37    Post subject: Firefox beta on PUP5.2  

some 3D sites aren't rendering as expected. Seems that sites are NOT recognizing Firefox properly. Is this a PUP5.2 problem?

for example, try this:

Hope this helps

_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
duke93535


Joined: 05 May 2005
Posts: 194
Location: California , High Desert

PostPosted: Sat 08 Jan 2011, 01:58    Post subject:  

First the menus do not work correctly in Lucid 5.2, but do in the latest Wary and Quirky. Adjusting the number of items to be shown in a submenu has no effect in /etc/xdg/menus/puppy-filesystem.menu, for example.

Second it doesn’t see my 6 core processor as Wary and Quirky’s latest do. Quirky’s 1.4 kernel is older than Lucid 5.2, what is up. Are they better or differently compiled?

Thanks duke
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5373
Location: Charleston S.C. USA

PostPosted: Sat 08 Jan 2011, 02:35    Post subject: Re: Firefox beta on PUP5.2  

gcmartin wrote:
some 3D sites aren't rendering as expected. Seems that sites are NOT recognizing Firefox properly. Is this a PUP5.2 problem?

for example, try this:

Hope this helps

This info may help;
http://www.khronos.org/webgl/wiki/Implementations/Firefox
Back to top
View user's profile Send private message 
swiatmar


Joined: 09 Aug 2008
Posts: 241
Location: Danube, AT

PostPosted: Sat 08 Jan 2011, 09:12    Post subject:  

Okey

Here are my problems Smile :

1) Unable to remasterCD. I've made it many times before with other puppies so I am not doing anything else here. The problem is :
Lucid build a Lucid.sfs in size about 23 mb !!!! So there is missing something I gues. I am also:
2) unable to burn it directly to CD. My burner can read DVDs and CDs erase them etc. but can't burn remaster puppy

The only thing I have changed was adding xfce package from 01micko and hotpup to managed the drive icons on desktop
There is much stuff not working in xfce with lucid puppy 5.2 Sad
After adding hotpup(the only way to get devices on the desktop), there is a problem with drives unmounting and especially the CD/DVD drive Sad

Last edited by swiatmar on Sat 08 Jan 2011, 19:18; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
smiley

Joined: 08 Jan 2011
Posts: 10
Location: Slovenia

PostPosted: Sat 08 Jan 2011, 11:41    Post subject: Gparted problems  

Hi I am new here and what I have tried I love Puppy Linux, it is the best for me.

I have installed 5.1.1 and now upgraded to 5.2, but when I try to run GParted it fails to run, from the terminal it outputs the following:
Code:
glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: basic_string::_S_create

aborting...
/usr/sbin/gparted_shell: line65: 7696 Aborted            gparted /dev/${THEDRIVE}


In 5.1.1 GParted is running OK.
The disk has some NTFS, HPFS, ext3, jfs partitions and a os2 boot manager

Update: I have found that it is a known bug in GParted(check version 0.7.0?? where to get it?)
https://bugs.launchpad.net/ubuntu/+source/gparted/+bug/617885

PS: Is there an easy way to copy-paste from urxvt terminal?[/url]
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sat 08 Jan 2011, 20:38    Post subject:  

Quote:
I have installed 5.1.1 and now upgraded to 5.2, but when I try to run GParted it fails to run, from the terminal it outputs the following:
Code:
glibmm-ERROR **:
unhandled exception (type std::exception) in signal handler:
what: basic_string::_S_create

aborting...
/usr/sbin/gparted_shell: line65: 7696 Aborted gparted /dev/${THEDRIVE}


In 5.1.1 GParted is running OK.
The disk has some NTFS, HPFS, ext3, jfs partitions and a os2 boot manager

I think this gparted should run--the newer one in Lucid 5.2 does not like some cpu's.
gparted.511.pet
Description 
pet

 Download 
Filename  gparted.511.pet 
Filesize  335.37 KB 
Downloaded  854 Time(s) 
Back to top
View user's profile Send private message 
playdayz


Joined: 25 Apr 2008
Posts: 3789

PostPosted: Sat 08 Jan 2011, 20:46    Post subject:  

Quote:
Second it doesn’t see my 6 core processor

What does it see? What do you see with htop (Menu -> System status -> htop) (how many cores?)
Back to top
View user's profile Send private message 
qmnaeem

Joined: 08 Jan 2011
Posts: 6
Location: Pakistan

PostPosted: Sat 08 Jan 2011, 23:42    Post subject: Lucid Puppy 5.2 didn't boot
Subject description: Booting problem
 

Hello, I'm regular user of Puppy. It's my 1st message in the form and hope a solution for my problem.
I downloaded the new version of Lucid Puppy 5.20 and burn it to pen drive but the puppy didn't boot and displayed the following message:
Quote:
loading devices drivers needed to access disk drivers ...... done
searching for puppy files in computer disk drivers.......... pausing
searching deeper, sub-folders in partitions .............. pausing
Boot partition not found. Dropping out to initial-ramdisk consol........
/bin/sh; can't access tty; job control turned off.
Solution? Please reply soon.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 1 of 22 [317 Posts]   Goto page: 1, 2, 3, ..., 20, 21, 22 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0995s ][ Queries: 12 (0.0078s) ][ GZIP on ]