Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 24 Nov 2017, 11:27
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Not booting up
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [3 Posts]  
Author Message
mattdowner

Joined: 06 Jul 2010
Posts: 7
Location: New Zealand

PostPosted: Sun 09 Jan 2011, 00:05    Post subject:  Not booting up
Subject description: Puppy Linux will not boot up
 

I had turned on my box and it booted into Puppy ok and started the game of my choice through a little script that runs on startup. Once it was in the game, I decided to turn it off so I could plug in some speakers and USB stuff. Turned her back on and got a boot loop and it will not startup X... Talks about some stale files... I ran a HDD sector regenerator test but no bad sectors were found. I transferred the HDD to another box and the same issue. Any ideas? I'll try get a screen capture...
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 11729
Location: Stratford, Ontario

PostPosted: Sun 09 Jan 2011, 00:11    Post subject:  

"Stale file handles" occur when the Puppy file system gets corrupted due to an improper shutdown.

Boot off the Live CD using the "puppy pfix=ram" option.

Open a terminal window and type the command
Code:
e2fsck -p /dev/sdaX

where X is your Puppy partition.

If you have a frugal install, you need to do the same to your pupsave file.

Mount the puppy partition and locate your pupsave file. Use the command
Code:
e2fsck -p xxxsave.2fs
Back to top
View user's profile Send private message 
mattdowner

Joined: 06 Jul 2010
Posts: 7
Location: New Zealand

PostPosted: Sun 09 Jan 2011, 00:56    Post subject:  

Ok, sounds like a good idea, thanks. I'll dig up my disc or download it again and let you know how it goes.

UPDATE: I couldn't get my CD drive to work so it looks like this will have to wait a bit... Sad It's on some old hardware...
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [3 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0296s ][ Queries: 11 (0.0061s) ][ GZIP on ]