Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 Jul 2014, 07:30
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Audio
Wary 500: No sound on HP Pavilion s7220n Slimline PC
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [13 Posts]  
Author Message
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Wed 26 Jan 2011, 16:52    Post subject:  Wary 500: No sound on HP Pavilion s7220n Slimline PC
Subject description: ALSA detects nothing...
 

I frugally installed Wary 500 to my HP's HDD. Neither on the LiveCD nor on the install version can I get ALSA to locate my audio hardware. So, no sound. It's Intel HD Audio, and IIRC it's built into the mainboard southbridge (Intel ICH8somethingorother, I *think*) but I can't remember the command to go back and look again.

This makes me sad Crying or Very sad

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
blazej

Joined: 04 Dec 2010
Posts: 3

PostPosted: Wed 26 Jan 2011, 18:01    Post subject:  

I have that problem on a Thinkpad T42. ALSA does not recognize the soundcard, however, sound works!! Just try to play audio or go to a web site with video and sound. sound then works for me out of the box. It would be better, if ALSA worked, but that seems to be a bug.
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Wed 26 Jan 2011, 18:36    Post subject:  

blazej, I'm afraid you are luckier than I am. I cannot get sound out of this system.
_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Thu 27 Jan 2011, 20:14    Post subject:  

Still no sound Crying or Very sad
_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 27 Jan 2011, 21:03    Post subject:  

starhawk wrote:
Still no sound Crying or Very sad


To see alsamixer;

Type alsamixer in console,

To run alsa;

Type alsaconf in console.

Alsamixer is synched to retrovolmixer.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Thu 27 Jan 2011, 21:11    Post subject:  

Oh bother... cleanup in Aisle 3...

Code:

#alsaconf
Getting started...
Building card database, please wait...
/usr/sbin/alsaconf: line 451: /lib/modules/2.6.31.14/modules.pcimap No such file or directory
/usr/sbin/alsaconf: line 451: /lib/modules/2.6.31.14/modules.isapnpmap No such file or directory
...no device found


What do I do?

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 27 Jan 2011, 21:41    Post subject:  

starhawk wrote:
Oh bother... cleanup in Aisle 3...

Code:

#alsaconf
Getting started...
Building card database, please wait...
/usr/sbin/alsaconf: line 451: /lib/modules/2.6.31.14/modules.pcimap No such file or directory
/usr/sbin/alsaconf: line 451: /lib/modules/2.6.31.14/modules.isapnpmap No such file or directory
...no device found


What do I do?


That's only half!

What does alsamixer in console say about card and chip?

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Thu 27 Jan 2011, 21:49    Post subject:  

Oh, sorry, didn't realize you wanted me to do both...

Code:

Card: HDA Intel
Chip: Realtek ALC880

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
rjbrewer


Joined: 22 Jan 2008
Posts: 4422
Location: merriam, kansas

PostPosted: Thu 27 Jan 2011, 22:13    Post subject:  

starhawk wrote:
Oh, sorry, didn't realize you wanted me to do both...

Code:

Card: HDA Intel
Chip: Realtek ALC880


There's a place at the top of the forum page that says "search".

Type alc880 there.

Read the threads.
Tempestuous is good at new drivers.

_________________

Inspiron 700m, Pent.M 1.6Ghz, 1Gb ram.
Msi Wind U100, N270 1.6>2.0Ghz, 1.5Gb ram.
Eeepc 8g 701, 900Mhz, 1Gb ram.
Full installs

Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Thu 27 Jan 2011, 23:30    Post subject:  

OK, I feel grievously stupid because I don't quite know what to do. I did the search, and found tempestuous' thread, but it's a little more than too technical for me.

The thread I found was here: http://murga-linux.com/puppy/viewtopic.php?search_id=2029823497&t=22383

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
starhawk

Joined: 22 Nov 2010
Posts: 2754
Location: Everybody knows this is nowhere...

PostPosted: Thu 27 Jan 2011, 23:53    Post subject:  

Update -- rear audio works, front panel audio + USB does not.

EDIT: neither does the built-in card reader Mad

_________________
Loving X-Slacko 1.1! Get the PetGet patch on pg8; it's important.
Next system will be an HP MOCA-AR + Core2Duo in an innovative case... if I ever get off my butt and build it Razz
Back to top
View user's profile Send private message 
duck1dong


Joined: 06 Feb 2011
Posts: 40
Location: Calgary Alberta

PostPosted: Wed 09 Feb 2011, 10:58    Post subject:  

It is very very likely the sound card you have even if ALSA mixer recognizes it, may not work with Linux. The ALSA program may be all well and good with it, but the guts of Linux may not be compatible. Just a guess. My HP 4455 windows previously(9Cool doesnt seem to want Linux 5.2 Lucid Puppy to have sound, even though the ALSA mixer sound card installer sees four sound cards but when selected each time for each card there is a quarter second white screen with much writing among which says "no device detected". So likely a better idea than all this fumbling with the software coding is to actually look under the hood of the computer and identify which card you have. The ALSA sound card installer seems next to useless at truly identifying which card I have, how can it do its job if the Linux code that orchestrates it ultimately wont work with the card I have? Its like having a boss that wants one thing and the employees want another. The boss wins. Its irrelevant what the employees want. Having the ALSA sound card installer work at this point seems about like having employees having a revolution and overthrowing the boss. Not gonna happen.
Back to top
View user's profile Send private message 
rcrsn51


Joined: 05 Sep 2006
Posts: 8902
Location: Stratford, Ontario

PostPosted: Wed 09 Feb 2011, 11:10    Post subject:  

Here's another analogy. The snow tires that fit on my old car don't work on my new car. Whose fault is that? Who should I complain to? Who should I expect to fix the problem? Will insulting the the new car dealer help?
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 1 [13 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Audio
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1069s ][ Queries: 11 (0.0087s) ][ GZIP on ]