Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 27 Nov 2014, 09:23
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 5.0.4 (5.1 RC)
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 5 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Author Message
rodin.s

Joined: 22 Sep 2010
Posts: 338
Location: Ukraine

PostPosted: Wed 16 Feb 2011, 17:06    Post_subject: video_upgrade_wizard and two videocards  

One small thing with video_upgrade_wizard. I have two videocards: intel and savage. And the top message of video_upgrade_wizard is not correct.
video_upgrade_wizard.png
 Description   top message mistake
 Filesize   15.03 KB
 Viewed   1998 Time(s)

video_upgrade_wizard.png

Back to top
View user's profile Send_private_message 
maddox

Joined: 28 Sep 2007
Posts: 453
Location: sometimes in France

PostPosted: Wed 16 Feb 2011, 20:53    Post_subject:  

Compaq EN series SFF 350Mhz 256 RAM o/b snd chip ESS1869 full-install snd module es18xx
As I'm away from the computer for about 10 days while visiting family, won't be able to test moving up sleep line.
I was hoping to post output from 'cat /tmp/pup_event_module_devpath_log*' but brought the wrong usb stick with me, sheesh.

Sorry about the confusion, thinking a bit more I should have posted it like this :
My /tmp/pup_event_module_devpath_log files do NOT contain an entry with MODULE=snd_.* (still don't comprehend how/when they are created)
and rc.services has a line that looks for MODULE=snd_.* in those files.
In my case SNDPATTERN turns up empty, thus : goodflag not 1 & file rc_d_rc_services_alsa_ok isn't created.
alsa start) relies on the existence of this file to do it's magic (that's why I split the nested if, not necessary).

As a temporary fix for my full-install, have now done this :
restored 10alsa to original state
added a 'touch /tmp/rc_d_rc_services_alsa_ok' in rc.services (make sure it's created on every boot of full-install)
... everything works as expected, pcm values stay at desired settings.


As for the kill retrovol, during testing I wasn't sure on how retrovol was working backgrounded,daemon & preferred to be sure there was no interference to asound.state on shutdown.
..there is no diff on my side whether killed or not, have removed the line.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Wed 16 Feb 2011, 23:26    Post_subject:  

Quick manual frugal install of Wary 504 on my main Linux box.Everything working on initial boot and no real problems yet.
Pretty good on resource usage too.
wary 504.png
 Description   
 Filesize   158.1 KB
 Viewed   2043 Time(s)

wary 504.png

Back to top
View user's profile Send_private_message 
Terryphi


Joined: 02 Jul 2008
Posts: 763
Location: West Wales, Britain.

PostPosted: Thu 17 Feb 2011, 06:00    Post_subject:  

So far everything is working as expected for me on a frugal install.

I assume simplified filenames have been dropped. I hope the same applies to the final version. Wink

Kernel 2.6.32.28 is excellent and provides a basis for long term support. If Barry is committed to supporting 2.6.32.xx I think more people will feel inclined to produce browser updates and other pets and sfs for Wary. LTS is the way to go.

I already have a recent nightly build of Chromium 11 running happily on Wary.
Back to top
View user's profile Send_private_message Visit_website 
Sylvander

Joined: 15 Dec 2008
Posts: 3519
Location: West Lothian, Scotland, UK

PostPosted: Thu 17 Feb 2011, 07:43    Post_subject:  

Wary-504-k2.6.32.28.iso
md5sum checked as OK.
Burned the ISO image to CD-RW disk.
Copied the SFS file to sdc3 on Flash Drive [and also copy on internal HDD] to sit beside the Wary-500 pupsave file[s].
Booted the Wary-504 CD-RW disk.
2 Wary-500 pupsave files found; 1 on HDD, 1 on Flash Drive.
Used the pupsave on the Flash Drive.
Wary-504 updated the Wary-500 pupsave OK.

At desktop, the Puppy wasn't connected to the web.
Started the Puppy firewall.
Ran the classic "Internet Connection Wizard".
No network card seen.
i.e. eth0 not seen.
Unable to find a driver for NIC.
Unable to connect.

Wary-500 connects OK.
Just now finished copying the pupsave for Wary-500 from the internal HDD to the Flash Drive.
Will try that pupsave to see if any problems. [I'm back: No problems, working fine]

Hardware = circa 2003
Mobo = ASUS A7A266
Ethernet Controller = National Semiconductor Corporation DP83815

Edited_times_total
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4819
Location: GB

PostPosted: Thu 17 Feb 2011, 07:57    Post_subject:  

I reported the missing cursor inside the PPM when a message panel overlay is present. This is still a problem.
Otherwise everything seems to work, DHCP is on at boot, sound OK, etc.

Midori? Still an obvious choice for a compact distro. Has the advantage of no Java & Flash on default, so fast - ideal as the kick-off browser. Check it out in Fluppy. [Jemimah seems to have flash functioning, though.]
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7841
Location: qld

PostPosted: Thu 17 Feb 2011, 09:07    Post_subject:  

Ok.. on the old p3 copppermine 600, 128 RAM, acx wireless.

504 booted nicely, got my SB16 going ok then connected my acx TI card.. wouldn't work directly with sns/ndiswrapper so I tried Dougal's and still no go. Had to unload and then try sns again and then got online.

After a reboot the configuration didn't stick. had to jump through exactly the same hoops.

The following is the tail -n10 of dmesg:
Code:
9836 pages shared
23220 pages non-shared
ndiswrapper (NdisMAllocateSharedMemory:1086): couldn't allocate 409600 bytes of un-cached DMA memory
ndiswrapper (mp_init:219): couldn't initialize device: C0000001
ndiswrapper (pnp_start_device:435): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (mp_halt:262): device c6028300 is not initialized - not halting
ndiswrapper: device eth%d removed
ndiswrapper: probe of 0000:00:0c.0 failed with error -22
usbcore: registered new interface driver ndiswrapper
sb16 01:01.00: activated


That's before I got it going.

After that the video upgrade worked nicely with the vanta card.

edit: subsequent reboot was ok, connection was restored but

Code:
retrovol: hcontrol.c:570: snd_hctl_load: Assertion `hctl->count == 0' failed.
/usr/sbin/delayedrun: line 200:  2822 Aborted                 $a


sound was fine but retrovol failed to start (excerpt from /tmp/xerrs.log)

____________________________________________


On my Athlon 2100+ box, 768 RAM, huawei e169 3g modem there was not an issue, all worked perfectly... it's a resilient box, any puppy works perfectly!


Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
2byte

Joined: 09 Oct 2006
Posts: 357

PostPosted: Thu 17 Feb 2011, 15:14    Post_subject:  

BarryK wrote:
Shouldn't there be an actual phone number there, instead of x's?

--> Sending: ATX3DTxxxxxxx

Of course there was a valid phone number there Confused

charlie6 wrote:
You have a PCI modem, don't you; efax tells opened /dev/ttySL0.
Here using efax-gtk (on wary-500) + a PCTel PCI modem, I have set the 'modem' setting 'serial device' to /dev/modem'


Thanks charlie6, I didn't see your post 'til now. /dev/modem is just a symlink to /dev/ttySL0 (/dev/pts/0) on my machine. I tried it just to be sure; no difference.

_________________

Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Thu 17 Feb 2011, 15:40    Post_subject:  

Wary-5.0.4 updated save file fine from Wary-5.0.3. Everything appears to be working fine including all of the following except Bibletime:

    Bibletime_lucid-2.7.2a.sfs
    java_jre-6u22-Lucid-sfs4.sfs
    LibreOfc3-en-us_3.3.0.4_final_sfs4.sfs
    hplip-3.9.12-scan HP Scanner Drivers
    nvidia-260.19.12-k2.6.32.28-w5 NVIDIA X driver, for 2.6.32.28 kernel
    hplip-3.9.12-scan HP Scanner Drivers
    scrot_0.8-13 scrot CLI screen capture
    uget-1.6.1 Uget download manager
    desksetup-0.4 Desksetup Templates for Desk Icons
    numlockx-1.2-i486 turns on numlock at boot
    dbus-1.2.4.2permissive-w5 inter-process messaging
    LHP_sys_info-0.3 Lighthouse System Information & Video Report
    PupApps-1.3 PupApps launcher
    PupClockset-1.2 PupClockset manager
    PupControl-1.4 PupControl panel
    PupShutdown-1.5 PupShutdown manager
    PupSnap-1.4 PupSnap screen capture

Running bibletime in a console flashes the opening screen, then closes with this message, I did use ppm to reinstall dbus, however there is no change in the error message. Ideas?
Code:
# bibletime
# process 20652: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/var/lib/dbus/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.
  D-Bus not built with -rdynamic so unable to print a backtrace

Thanks,
Jim

EDIT: Started over with a new pup save and now bibletime works. Also, Openoffice 3.3.0 from Lucid's Quickpet works as well as LibreOffice 3.3.0. Everything is working great. This is posted from the latest Wary.
bibletime.jpg
Description 
jpg

 Download 
Filename  bibletime.jpg 
Filesize  265.26 KB 
Downloaded  440 Time(s) 

_________________
Favorites: Lighthouse 64 and Lucid + theWord
Back to top
View user's profile Send_private_message 
zigbert


Joined: 29 Mar 2006
Posts: 5788
Location: Valåmoen, Norway

PostPosted: Thu 17 Feb 2011, 19:36    Post_subject:  

I have been looking at pctorrent. I started a rewrite to get a more up-to-date gui. But I couldn't get pctorrent to download anything. The gui seems to work ok, - it's ctorrent that fails for me. I tried both the ctorrent-command built by pctorrent and the example command from ctorrent -h
Code:
ctorrent -s new_filename -e 12 -C 32 -p 6881 example.torrent
Has anyone got this working. I installed the good old Transmission 0.6.1, and the same torrent downloaded just fine.
I tried the latest Wary, Puppy 4.3.1 and Puppy 5.1.1.
Puppy 5.2 has skipped pctorrent.


Sigmund

_________________
Stardust resources
Back to top
View user's profile Send_private_message Visit_website 
don570


Joined: 10 Mar 2010
Posts: 3380
Location: Ontario

PostPosted: Thu 17 Feb 2011, 19:44    Post_subject: localisation of screen capture program  

It makes sense to localize the screen capture program in Puppy,
so I did this using Zigbert's method.

I renamed mtpaintsnapshot to psnapshot and made a pet package.
psnapshot-1.3.pet

and here's the French,German and Spanish locals
psnapshot-NLS-1.3.pet

_____________________________________________________
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2156
Location: Ontario Canada

PostPosted: Thu 17 Feb 2011, 19:45    Post_subject: Wary Puppy 5.0.4 (5.1 RC)
Sub_title: nvidia
 

I'm running 504 live with a save file.
Wired network and sound were good at 1st bootup.
I've installed kernel_src-2.6.32.28-patched.sfs + wary_devx_504.sfs +
NVIDIA-Linux-x86-260.19.36.run

# glxgears
Running synchronized to the vertical refresh. The framerate should be
approximately the same as the monitor refresh rate.
46517 frames in 5.0 seconds = 9303.235 FPS
51828 frames in 5.0 seconds = 10365.434 FPS
51858 frames in 5.0 seconds = 10371.523 FPS
# report-video
VIDEO REPORT: Wary Puppy, version 504

Chip description:
oem: NVIDIA
product: G84 Board - p402h00 Chip Rev

Driver used by Xorg:
#card0driver

Video mode used by Xorg:
Resolution: Depth 24 Depth: "Display"

...the above also recorded in /tmp/report-video
#
OpenGL
Vendor NVIDIA Corporation
Renderer GeForce 8600 GT/PCI/SSE2
Version 3.3.0 NVIDIA 260.19.36
Direct Rendering Yes

504 is working well on this pc.
2011-02-17_17-58-27-thumb.jpg
 Description   
 Filesize   31.21 KB
 Viewed   2072 Time(s)

2011-02-17_17-58-27-thumb.jpg

Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5939
Location: Kentucky

PostPosted: Fri 18 Feb 2011, 01:44    Post_subject:  

Did an upgrade of the frugal install on my old P3 test box from Wary 503 to 504. No problems.Everything is working as it should be. Smile
Back to top
View user's profile Send_private_message 
Sylvander

Joined: 15 Dec 2008
Posts: 3519
Location: West Lothian, Scotland, UK

PostPosted: Fri 18 Feb 2011, 04:37    Post_subject:  

Wary-504-k2.6.32.28.iso

As suggested in a PPM, I installed dhcpcd-5.2.11-w-20110214.pet but it made no improvement; still cannot connect to the web. Sad
Back to top
View user's profile Send_private_message 
abushcrafter


Joined: 30 Oct 2009
Posts: 1447
Location: England

PostPosted: Fri 18 Feb 2011, 09:15    Post_subject:  

How stable is the in-development version of The Gimp in the repo?
_________________
adobe flash is rubbish!
My Quote:"Humans are stupid, though some are clever but stupid." http://www.dependent.de/media/audio/mp3/System_Syn_Heres_to_You.zip http://www.systemsyn.com/
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 5 of 7 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1119s ][ Queries: 12 (0.0054s) ][ GZIP on ]