Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 04:02
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Wary Puppy 5.1.1 Final
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 12 [178 Posts]   Goto page: 1, 2, 3, ..., 10, 11, 12 Next
Author Message
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Sun 20 Feb 2011, 18:37    Post subject:  Wary Puppy 5.1.1 Final
Subject description: The official 5.1.1 release, bugs and feedback
 

Here is my blog announcement:

http://bkhome.org/blog/?viewDetailed=02149

Feedback welcome...

EDIT: Wary 5.1.1 released, 25 Feb. 2011

This thread was started with the release of 5.1. Discussion of 5.1.1, which is a minor bugfix release, starts on page 3 of this thread.

5.1.1 Blog announcement:

http://bkhome.org/blog/?viewDetailed=02158

_________________
http://bkhome.org/news/

Last edited by BarryK on Fri 25 Feb 2011, 19:05; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
broomdodger


Joined: 09 May 2008
Posts: 269
Location: Santa Cruz, CA

PostPosted: Sun 20 Feb 2011, 22:07    Post subject: PPM cursor
Subject description: cursor disappears behind main window if no package found
 

PPM cursor
Hi Barry

Puppy Package Manager when no package found

The cursor shows when over the desktop,
then disappears behind the main PPM window,
then shows again if you hit the
"Sorry, no matching package name" red dialog.

Ahhh! switching back to PPM from Seamonkey after copying the text in the red dialog without closing the dialog, the whole PPM window is blank. If I move it out of the way I can see the red dialog, click "okay" then PPM window displays.

Is it possible to have <return> trigger the "okay" as well as the mouse?

-Bill
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5721
Location: Kentucky

PostPosted: Mon 21 Feb 2011, 01:04    Post subject:  

Fresh manual frugal install of Wary 510 on my main Linux box.Display,audio and internet were all working on initial boot.
Added several pets including Pwidgets and Pidgin,all are working fine. No real problems at all. Looking good here.
Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4782
Location: GB

PostPosted: Mon 21 Feb 2011, 02:32    Post subject:  

Quote:
The cursor shows when over the desktop,
then disappears behind the main PPM window,


Have reported this twice before - nil response.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Mon 21 Feb 2011, 03:35    Post subject:  

Everything tested is working satisfactorily after upgrade from 504. Locale settings are now saved correctly on upgrade except LC_COLLATE for reason I described on BK's blog. However, the LC_COLLATE=en_US setting does not seem to break anything in the way that some other locale settings did.

Thanks for another great version. Smile
Back to top
View user's profile Send private message Visit poster's website 
BongoPlayer

Joined: 28 Feb 2010
Posts: 8
Location: Canada

PostPosted: Mon 21 Feb 2011, 04:48    Post subject:  

I tried to update using Delta files:

2b696ac4aa031e97e6f890529652bcd8 wary-504-k2.6.32.28.iso
e0ef5673eccd5ef4ee13cfd717cc48ba wary_devx_504.sfs

9c99aff9cb70599e8bd51c39c442604f wary-500.iso___wary-510-k2.6.32.28.iso.delta
f8fd6251b6aa02a4aa7770b0765c1ce0 wary_devx_500.sfs___wary_devx_510.sfs.delta

Got the following in both cases:

"ERROR! failed to recreate the new file. Error message:
xdelta3: target window checksum mismatch: XD3_INVALID_INPUT
okay"


P.S. All 4 checksums verified

jp

_________________
Asus K7V, AMD Athlon, 256MB RAM, ATI AGP 3DRage IIC,
HL-DT-ST-8400B (40x12x40), Lexmark OptraE+
Modem: PCI, ES2898S/ES2818P (ES56T-PI)
Hard Drives: Maxtor (3GB) & Maxtor (1.96GB)
USB Pen Drive (8GB)
OS: Puppy Linux 4.3.1 (k2.6.30.5) Live CD
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1395
Location: Malvern, Worcs, UK

PostPosted: Mon 21 Feb 2011, 08:00    Post subject:  

It looks like you are trying to update from 504 to 510....

The deltas are for 500 to 510....
Back to top
View user's profile Send private message 
drblock2

Joined: 19 Jan 2009
Posts: 141

PostPosted: Mon 21 Feb 2011, 08:58    Post subject:
Subject description: IBM ThinkPad A21m won't boot Wary 5.1
 

I have been trying to revitalize my old IBM ThinkPad A21m (Pentium III - 750 MHz, 128 MHz ram).

This machine will run Puppy 4.2.0 and Puppy 4.3.1 with the 2.6.21.7 kernel, but hangs on a frugal install of Wary 5.1 k2.6.31.14 after the first two lines following "Booting command list:"

Here is the grub entry with the same configuration that works on Puppy 4.3.1:

Code:
title Wary 5.1
rootnoverify (hd0,0)
kernel (hd0,0)/wary510/vmlinuz PMEDIA=idehd acpi=off PDEV1=hda1 psubdir=wary510
initrd (hd0,0)/wary510/initrd.gz
boot


Is there any thing that I can try to get Wary 5.1 to boot?
Back to top
View user's profile Send private message 
peebee


Joined: 21 Sep 2008
Posts: 1395
Location: Malvern, Worcs, UK

PostPosted: Mon 21 Feb 2011, 11:34    Post subject:
Subject description: IBM ThinkPad A21m won't boot Wary 5.1
 

drblock2 wrote:
I have been trying to revitalize my old IBM ThinkPad A21m (Pentium III - 750 MHz, 128 MHz ram).

This machine will run Puppy 4.2.0 and Puppy 4.3.1 with the 2.6.21.7 kernel, but hangs on a frugal install of Wary 5.1 k2.6.31.14 after the first two lines following "Booting command list:"

Here is the grub entry with the same configuration that works on Puppy 4.3.1:

Code:
title Wary 5.1
rootnoverify (hd0,0)
kernel (hd0,0)/wary510/vmlinuz PMEDIA=idehd acpi=off PDEV1=hda1 psubdir=wary510
initrd (hd0,0)/wary510/initrd.gz
boot


Is there any thing that I can try to get Wary 5.1 to boot?


My even older Thinkpad 600 with a PII 266MHz cpu, 196MB ram and a 2GB swap partition runs wary510 K2.6.32.28 fine frugal install with the following grub4dos entry:

Code:
title puptest
  find --set-root --ignore-floppies /puptest/initrd.gz
  kernel /puptest/vmlinuz pmedia=atahd psubdir=puptest pfix=fsck
  initrd /puptest/initrd.gz


[edit]Just realised it says atahd - this is what grub4dos generated and it works - but of course it has an ide disk not a sata....[/edit]

Cheers
Peter

Last edited by peebee on Mon 21 Feb 2011, 15:18; edited 1 time in total
Back to top
View user's profile Send private message 
gerry

Joined: 26 Jul 2007
Posts: 946
Location: England

PostPosted: Mon 21 Feb 2011, 12:44    Post subject:  

Several times today tried to download Wary 5.1, but Ibiblio seems to be sick. Or is it only the path from them to me personally?

gerry
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2455
Location: Texas, USA

PostPosted: Mon 21 Feb 2011, 13:06    Post subject:  

Full hd installation on an old Sony Vaio laptop with only 64MB ram. Everything appears to be working and this is the fastest that this old laptop has ever run.

Thanks,
Jim
Back to top
View user's profile Send private message 
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Mon 21 Feb 2011, 14:32    Post subject:  

gerry wrote:
Several times today tried to download Wary 5.1, but Ibiblio seems to be sick. Or is it only the path from them to me personally?

gerry

www.downforeveryoneorjustme.com/
Quote:
distro.ibiblio.org/ looks down from here.

_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send private message Visit poster's website 
Sylvander

Joined: 15 Dec 2008
Posts: 3426
Location: West Lothian, Scotland, UK

PostPosted: Mon 21 Feb 2011, 18:08    Post subject:  

Used Wary-510-k2.6.31.14-uniproc-ide.iso to make a CD-RW.
[The more up-to-date kernel wouldn't boot on my 2003 desktop PC]

FEATURE:
1. I notice that this Wary searches deeper than where the pupsave files are located [In case there might be more?]

BUG?
1. It lists TWO of everything it finds.
i.e. If there are 2 pupsave files; one on the HDD and one on a Flash Drive, it lists them as items 1 and 2, then lists them again as 3 and 4.
Back to top
View user's profile Send private message 
jrb


Joined: 11 Dec 2007
Posts: 1033
Location: Smithers, BC, Canada

PostPosted: Mon 21 Feb 2011, 20:01    Post subject:  

Sylvander wrote:
BUG?
1. It lists TWO of everything it finds.
i.e. If there are 2 pupsave files; one on the HDD and one on a Flash Drive, it lists them as items 1 and 2, then lists them again as 3 and 4.


Got the same situation with a humongous initrd.gz netbooting, otherwise everything I've tried has worked well. Didn't get it when booting from frugal.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 21 Feb 2011, 21:57    Post subject:  

gerry wrote:
Several times today tried to download Wary 5.1, but Ibiblio seems to be sick. Or is it only the path from them to me personally?

gerry


Some other mirrors of ibiblio:

http://ftp.cc.uoc.gr/mirrors/linux/quirky/wary-5.1/

...er, we seem to have a crisis situation, this is the only mirror that I can find with Wary 5.1. Unfortunately nluug.nl has dropped hosting all Puppy files.

We are going to have to lobby other ibiblio mirror sites to host Wary/Quirky. Or, find other hosts.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 12 [178 Posts]   Goto page: 1, 2, 3, ..., 10, 11, 12 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0898s ][ Queries: 12 (0.0058s) ][ GZIP on ]