Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 15:04
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
GUI to download LibreOffice - beta quality
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 14 of 18 [260 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17, 18 Next
Author Message
simargl

Joined: 11 Feb 2013
Posts: 572

PostPosted: Sat 16 Feb 2013, 08:23    Post subject:  

.
Last edited by simargl on Sun 01 Sep 2013, 10:30; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Sat 16 Feb 2013, 08:25    Post subject:  

Mick it's not working in Fatdog either trying to download LibreOffice-4.0.0.0. It works ok in Slacko but actually gets 4.0.0.3

It DL'ed 3.6.5 ok though.

It complained about not being able to get package info.

Cheers

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Sat 16 Feb 2013, 09:27    Post subject:  

smokey01 wrote:
Mick it's not working in Fatdog either trying to download LibreOffice-4.0.0.0. It works ok in Slacko but actually gets 4.0.0.3

It DL'ed 3.6.5 ok though.

It complained about not being able to get package info.

Cheers
Totally the maintainer's fault Embarassed

Some hard coding to x86 arch is the culprit, will be fixed tomorrow in *0.24. I just produced a sane sfs in Slackbones with a slight tweak..

Thanks.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sat 16 Feb 2013, 12:32    Post subject:  

Thanks, simargi

Thanks, 01micko

Henry
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Sat 16 Feb 2013, 17:46    Post subject:  

0.24 is out

-fixed 64 bit installs
-added some logging

see main post

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Sat 16 Feb 2013, 17:57    Post subject:  

01micko wrote:
0.24 is out

-fixed 64 bit installs
-added some logging

see main post


Thanks mate.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sat 16 Feb 2013, 19:22    Post subject:  

Here is something I wondered about -
Does this mean the program should be downloaded before the help file?
Lo.png
 Description   
 Filesize   27.65 KB
 Viewed   490 Time(s)

Lo.png

Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Sat 16 Feb 2013, 19:26    Post subject:  

Henry wrote:
Here is something I wondered about -
Does this mean the program should be downloaded before the help file?
No, well it hasn't made a difference so far.

The debs are all unpacked to the same directory then an sfs constructed, so in effect they are all installed at the same time. If it's a concern of yours Henry, just make sure the help pack box is unchecked. Since you are in the US the lang pack doesn't apply. This way, only the main program gets downloaded. This is what I do if I release an sfs for general consumption.

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
edoc


Joined: 07 Aug 2005
Posts: 4367
Location: Southeast Georgia, USA

PostPosted: Sat 16 Feb 2013, 19:32    Post subject:  

It ran and loaded LibreOffice 4.0.0.3 successfully on an old Panasonic Toughbook CF-29 running Exprimo 5x15

It seems a little slow on the old laptop but I have Writer open there right now.

Thanks!

_________________
Thanks! David
Home page: http://nevils-station.com
Don't google Search! http://duckduckgo.com
Puppy upup Raring 3992 & Lighthouse64-b602
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sun 17 Feb 2013, 01:02    Post subject:  

Here's what I did:

Installed LO 3.6.5 using .017 No problem

Installed LO 4.0 w/o help using .024 Failed

Instaled LO 4.0 w/help using .024 from get_libreoffice in terminal Failed Here is the last of the terminal output:

Code:
ar: ./opt/libreoffice4.0/share/xdg/javafilter.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/math.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/printeradmin.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/qstart.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/startcenter.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/writer.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/xsltfilter.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xpdfimport/xpdfimport_err.pdf: Cannot write: No space left on device
tar: Exiting with failure status due to previous errors
dpkg-deb: error: subprocess tar returned error exit status 2
ERROR: failed to unpack libreoffice4.0_4.0.0.3-103_i386
/usr/sbin/get_libreoffice: line 393: 26822 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg yellow -text "$INFOMSG2a $LIBO_EN_US $INFOMSG2b"  (wd: ~)
/tmp/libre_download/LibreOffice_4.0.0.3_Linux_x86_deb/DEBS
_en-US
xwininfo: can not set locale properly

(process:27482): Gtk-WARNING **: Locale not supported by C library.
   Using the fallback 'C' locale.
EXIT="Exit on timeout"
#


Long ago in a tidying session I may have removed non English locales. Often in the terminal I see something like this, which has never caused a problem, certainly not with the LO3.x.x installations.
Code:
rxvt: default locale unavailable, check LC_* and LANG variables.
Continuing


Just reporting FWIW. Sorry if I have somehow caused my own problem. Thanks - you have enough on your plate already!
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Sun 17 Feb 2013, 01:19    Post subject:  

Henry,

I only see half the story there...

Is the log in /tmp?

try this in a terminal
Code:
cp /tmp/LO_log* ~
..will copy the log to root.
_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sun 17 Feb 2013, 01:55    Post subject:  

01micko wrote:
Henry,

I only see half the story there...

Is the log in /tmp?

try this in a terminal
Code:
cp /tmp/LO_log* ~
..will copy the log to root.


Oops, sorry, I have already restored the backup system. (I did suspect something had gone wrong, as there were some odd readings in Pup-SysInfo.)

BTW I should note something a little different about this system: The HDD is sda1 and is the same as /mnt/home. I.e. the free space on sda1 is 0.0M
Back to top
View user's profile Send private message Visit poster's website 
01micko


Joined: 11 Oct 2008
Posts: 7797
Location: qld

PostPosted: Sun 17 Feb 2013, 07:07    Post subject:  

Henry

I suspect you may be running in PUPMODE=7, for which I think there is a bug in the script. Are you saving to entire partition?

Code:
grep "PUPMODE" /etc/rc.d/PUPSTATE


Thanks

---

On some thinking I'll post version 0.25.. ok it's up, see main post

BE WARNED I removed gtkdialog-splash ..

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send private message Visit poster's website 
smokey01


Joined: 30 Dec 2006
Posts: 1806
Location: South Australia

PostPosted: Sun 17 Feb 2013, 08:08    Post subject:  

Mick 24 worked fine for me.
_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
Henry

Joined: 29 Jul 2006
Posts: 829
Location: Oregon USA

PostPosted: Sun 17 Feb 2013, 09:24    Post subject: EDIT  

01micko wrote:
Henry

I suspect you may be running in PUPMODE=7, for which I think there is a bug in the script. Are you saving to entire partition?
Code:
grep "PUPMODE" /etc/rc.d/PUPSTATE

Thanks

On some thinking I'll post version 0.25.. ok it's up, see main post

BE WARNED I removed gtkdialog-splash ..


# grep "PUPMODE" /etc/rc.d/PUPSTATE
PUPMODE=12
#
Yes, I think saving to entire partition. I'll d/l ver 0.25

EDIT: Have tried 0.25. Failed. In /tmp I see
Code:
LO LOG
-------
Sun_Feb_17_05:51:08_PST_2013
get_libreoffice-0.25
PUPMODE = 12
en-US
Is it ok to build in RAM? yes
building in /tmp
moving to /initrd/mnt/dev_save
this is 4.0.0
major ver: 4.0
help enabled? true
lang enabled? false
LibreOffice_4.0.0_Linux_x86_deb_helppack_
LibreOffice_4.0.0_Linux_x86_deb_langpack_
Current working dir is /tmp/libre_download/LibreOffice_4.0.0.3_Linux_x86_deb/DEBS
ERROR: failed to unpack libobasis4.0-en-us-help_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us-math_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us-res_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us-writer_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-en-us_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-beanshell-script-provider_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-javascript-script-provider_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-mediawiki-publisher_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-nlpsolver_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-presentation-minimizer_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-python-script-provider_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-extension-report-builder_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-gnome-integration_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-graphicfilter_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-images_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-impress_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-javafilter_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-kde-integration_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-librelogo_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-math_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-ogltrans_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-onlineupdate_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-ooofonts_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-ooolinguistic_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-postgresql-sdbc_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-pyuno_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-writer_4.0.0.3-103_i386
ERROR: failed to unpack libobasis4.0-xsltfilter_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-base_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-calc_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-debian-menus_4.0.0-103_all
ERROR: failed to unpack libreoffice4.0-dict-en_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-dict-es_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-dict-fr_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-draw_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-en-us_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-impress_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-math_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-stdlibs_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-ure_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0-writer_4.0.0.3-103_i386
ERROR: failed to unpack libreoffice4.0_4.0.0.3-103_i386

Also in /tmp I see
libre_dwnload, 523.1M (debs), and
office_online_database_extrapacks, 8.7K

In terminal at end I see
Code:

 device
tar: ./opt/libreoffice4.0/share/xdg/draw.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/impress.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/javafilter.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/math.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/printeradmin.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/qstart.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/startcenter.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/writer.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xdg/xsltfilter.desktop: Cannot write: No space left on device
tar: ./opt/libreoffice4.0/share/xpdfimport/xpdfimport_err.pdf: Cannot write: No space left on device
tar: Exiting with failure status due to previous errors
dpkg-deb: error: subprocess tar returned error exit status 2
ERROR: failed to unpack libreoffice4.0_4.0.0.3-103_i386
/usr/sbin/get_libreoffice: line 388: 16745 Terminated              gtkdialog-splash -close never -icon /usr/share/pixmaps/throbber.gif -bg yellow -text "$INFOMSG2a $LIBO_EN_US $INFOMSG2b"  (wd: ~)
/tmp/libre_download/LibreOffice_4.0.0.3_Linux_x86_deb/DEBS
_en-US
#



Kept a copy of /tmp.
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 14 of 18 [260 Posts]   Goto page: Previous 1, 2, 3, ..., 12, 13, 14, 15, 16, 17, 18 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1077s ][ Queries: 12 (0.0111s) ][ GZIP on ]