Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 02 Sep 2014, 09:08
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Puppy Lupen- K 2.6.38.4.....Compiz-Fusion/Emerald/Cairo-dock
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 6 [89 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Author Message
puppyluvr


Joined: 06 Jan 2008
Posts: 3196
Location: Chickasha Oklahoma

PostPosted: Tue 17 May 2011, 16:27    Post subject:  

Very Happy Hello,
Cool... Cool
And by the dotconfig it looks you have enabled everything but the kitchen sink... Wink
Thanks for the ndiswrapper module as well...That thing, and rt5390 refuse to compile properly for me...
BTW, will things Ive compiled against lupe17 work the same for lupe22, since they are both 2.6.38.4??? Or do I need to recompile...I already D/L the lupe22 sources...

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 17 May 2011, 16:38    Post subject:  

I dont think so. I have made so many changes and repatched the kernel also.

Ndiswrapper from svn compiles fine, known trick.
ndiswrapper-1.56.tar.gz
Description 
gz

 Download 
Filename  ndiswrapper-1.56.tar.gz 
Filesize  196.28 KB 
Downloaded  275 Time(s) 
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 17 May 2011, 16:59    Post subject:  

I dont know if this works, it needed really a lot source patching.

It is for lupe22 kernel. Reboot is surely needed after installing this monster.
rt5390sta-v2.4.0.4-k2.6.38.4-lupe22.pet
Description 
pet

 Download 
Filename  rt5390sta-v2.4.0.4-k2.6.38.4-lupe22.pet 
Filesize  329.15 KB 
Downloaded  283 Time(s) 
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3196
Location: Chickasha Oklahoma

PostPosted: Tue 17 May 2011, 17:05    Post subject:  

Very Happy Hello,
Yep, that one compiled fine for me...
Now to build a lupe22 pup and compile it on that... Cool
And, yes I know you already did, and I have it already... Very Happy
Thank you... Cool

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
puppyluvr


Joined: 06 Jan 2008
Posts: 3196
Location: Chickasha Oklahoma

PostPosted: Tue 17 May 2011, 17:31    Post subject:  

Very Happy Hello,
@Nooby..
Until this point, it was just a test of the new kernel against 5.25, hence why it remained in the "new kernel testing" thread...
Using Woof and pemasus kernels, I built a Lupu, an Spup, and a T2pup..
All of them worked, but the ubuntu packages gave me a very solid base...So I kept building on Lupu...As it went along, I compiled everything for it...FF 4.0.1, E-16, etc, and am going to recompile everything I can, against the new kernel, for this Pup.. As I used it, it grew on me...so much so, I decided to release it... (psss...If all goes well, it will be the new Buddapup...I promised someone not to build a Buddapup for a while, but its been a really long while, over 2 years...so I think its time....but shhhh..LOL..)

I have to write a lot of "switching" scripts, and make a few mods, to make xcompmgr and E16 and GLX-dock and Openbox and Jwm get along...

BTW, the E16 I just built, the newest one, is in my meownplanet dir in my sig..it is a tarball with 1 pet and 1 deb...I combined e16, e16menu, e16data, and 4 themes into 1 pet, and the deb is imlib2, which Im gonna compile from source, as the current pet didnt work, and undeb left me one file short... Evil or Very Mad
I pretty much want to compile every part on this dog I can..

Yes, testing...
Alsamixer
Retrovol
USB drives/wireless/etc...
Watch your cpu usage over reboots, cairo-dock has given me some trouble, but its the ubuntu version, I havent compiled it yet against this Pup..
See how gl works with cairo-dock, and also try the nongl one two..
Both are in the menu....
Built for intel...need testing elsewhere...Im down to 1 machine atm...
Someone try pemasus nvidia pets a on this...

Jay...

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
puppyluvr


Joined: 06 Jan 2008
Posts: 3196
Location: Chickasha Oklahoma

PostPosted: Wed 18 May 2011, 22:09    Post subject:  

Very Happy Hello,
Latest testing...
Lupen 2.6.38.4-lupe22...


Compiz is stable, but missing some emerald and config stuff still....
And as you can see,Cairo-dock lost transparency... Rolling Eyes
But the cube works!! (Well, the triangle as it is set ATM )... Cool

So now Lupen can run:
Jwm
Openbox
Afterstep
E-16
Xfce4 / Compiz_Fusion....

Long way to go, but it is a start....

Cool Jay Cool
Lupen is gonna rock!!!

@Nooby,
Your thread on Knoppix is what got me going on Compiz...
And you can bet that level of stability for Compiz is what I want..
And I aint above snatching some of Klaus`s config stuff...
Knoppix is Debian...So is Ubuntu....So little modification should should be necessary...
I,m gonna have to write a heck of a WMSwitcher script...LOL...
Non of the above "get along" at all..
Both E16 and Compiz have composite managers, and Ciaro-dock sort of does...Plus xcompmgr.....Grrrr..
What, am I , nuts???

But it can work....maybe.... Embarassed
We will see..... Cool

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Thu 19 May 2011, 11:06    Post subject:  

Sad news again. Tested and failed to get internet. Very surprising.

Ice puppy just works. Another one that failed to get internet was one of the Dpup 485 if I remember.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
puppyluvr


Joined: 06 Jan 2008
Posts: 3196
Location: Chickasha Oklahoma

PostPosted: Tue 24 May 2011, 00:24    Post subject:  

Very Happy Hello,
Sorry Nooby for slow reply, been busy with B.S.
What card, wired or wireless...
These things I need to know...
The "base" released so far needs to be solid B4 I build a release with Compiz...

Oh yea, as much as I love Enlightenment, I am pretty sure Lupen will be a Compiz Pup... Ive been running the Compiz build for a week so far, and it is, to my amazement, staying true, and solid... Several reboots, and no new problems, just a few I am already working at...Namely, layering in composite..
Really, it is just Conky and/or Pwidgets..Not a biggie...you can see in this video..
http://www.youtube.com/watch?v=v_1QeAhq2go
Pwidgets and Conky are on the wrong layer..

But to comply with the Lupu standard it must boot straight to a (Compiz) desktop..So it will be pretty big, as video drivers are big, and Compiz needs GLX running first...I may create a boot option for no GLX/Compiz/Cairo-dock...Probably not...whats the point??? Either it works, or basically, its Lupu525 with a few additions...ATM at least...

I need to get it into an ISO for testing, as it is running "savefile" for now..
So far, the ISO`s have xorg problems, and Im not much for remastering...
So I combine the two...Works for Intel...Gonna borrow an ATI lappy to test..
Kernel "lupe22" seems to be the one.....The one I uploaded is "lupe17" based..
But I dont want to upload this one till it is dead on...Compiz is cool, and a pain... Mad
But the mixture of Xfce4, Rox, Thunar, GTK GLX and Cairo-dock, under the Intel XorgHigh drivers is sweet..and stable so far, thru many reboots...

Oh yea...Nooby, post some specs... Very Happy

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
puppyluvr


Joined: 06 Jan 2008
Posts: 3196
Location: Chickasha Oklahoma

PostPosted: Tue 24 May 2011, 00:37    Post subject:  

Very Happy Hello,
Regarding "combine the two" above...
Basically, I opened up 3builddistro and put a pause before mksquashfs and another before mkisofs...Simple xmessage like "here is where you want to edit the .sfs" or, "wanna edit the ISO?"...till I click "OK" xmessage pauses Woof...

Didnt even bother with xdialog... Cool Rolling Eyes

Allows more editing and configuring options...
Gets around some Woof defaults, backgrounds, configurations, etc..

Then click "OK" and Woof continues....

_________________
Close the Windows, and open your eyes, to a whole new world
http://puppylinuxstuff.meownplanet.net/puppyluvr/
Puppy Linux Users Group on Facebook

Puppy since 2.15CE...
Back to top
View user's profile Send private message Visit poster's website 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 24 May 2011, 07:00    Post subject:  

Atheros AR 8132 L1c Gigabit Ethernet LAN

is that a good way to retell what I have Smile

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 24 May 2011, 11:01    Post subject:  

That wired eth card uses atl1c driver which should have been as module all the time in lupe 2.6.38 kernels. I know that since my ethernet card uses same driver.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 24 May 2011, 12:44    Post subject:  

Yes you are right. When it works then most or all puppies do use that one
atl1c

But on the puppies where it fails them shut down the LAN card so even if them have atl1c it does not help because even if they load that atl1c driver them have already shut down LAN card so the Card don't get activated and the only way to repair that situation is to shut down and pull the power plug and take out the battery.

or else no OS apart from Windows can get it going again.

Something in these puppies are so damaging to the LAN card that it most likely is protected by some thing in BIOS or how else to explain that it impossible to repair without getting it to completely flatting the capacitors to get below 2.4 Volt.


Would be cool to find out what is going on. Is there no log in Spup that one can use or Puppy Lupen?

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 24 May 2011, 13:15    Post subject:  

Nooby. I think that older kernels dont support your eth card fully, but newer kernels have updated atl1c. I think that is the most reasonable explanation.
So it depends on what kernel Puppy uses whatkind support it has for your eth card.
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 24 May 2011, 13:38    Post subject:  

That seems to be a very reasonable explanation. So I should learn how to determine what kernel a puppy uses then.
Edit after reading below.

I looked and Snow pup 5 has 2.6.35.7 so that is a good kernel for me then. Most likely that is the one that Jemimah use for Fluppy 13?

So Now I should look in Spup and see what that one use. Or them tell it on first page maybe.

I am so lazy I should through each puppy and look for what kernel them use and note whom has what trouble and make a list on it but I am too lazy for that.

Puppy Lupen using 2.6.38.4 should work then because is that not one you used on Snow and Ice puppy too and that one worked?

So my wild guess is rather that I need puppies that have RFKILL in them?

Edit thanks to pemasu and GCMartin. both suggested ways to find kernel version did work.

_________________
I use Google Search on Puppy Forum
not an ideal solution though

Last edited by nooby on Wed 25 May 2011, 13:00; edited 4 times in total
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 24 May 2011, 14:02    Post subject:  

Nooby. That is easy. Just check inside /etc/modules folder.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 6 [89 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0952s ][ Queries: 12 (0.0193s) ][ GZIP on ]