Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 10:23
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Qt Interest Group
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 3 [33 Posts]   Goto page: Previous 1, 2, 3 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 20 Jun 2011, 01:09    Post subject:  

Makoto. Those Qt 4.80 packages have basic stuff compiled. They resemble the QT libs Barry Kauler made for Wary. The size is bigger because I cant compete with T2 compiling environment. Barry gets astonishing small packages with it.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Mon 20 Jun 2011, 15:22    Post subject:  

Are they already possibly stripped, and maybe even further compressed with something like UPX? Smile (Not that I know whether or not you could strip the Qt setup...)
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Mon 20 Jun 2011, 15:27    Post subject:  

They are stripped. UPXed no. And reboot is needed before they are recognized. The pinstall.sh is included in the main pet, at least.
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Tue 21 Jun 2011, 04:27    Post subject:  

Do Qt programs generally need the version of Qt they were compiled against, or higher?

I re-installed Qt 4.5.3, and installed your QComicbook 0.7.2 package... but if I try to run it, it always stops with this error:

Code:
qcomicbook: symbol lookup error: qcomicbook: undefined symbol: _ZN9QMetaType15registerTypedefEPKci

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Tue 21 Jun 2011, 10:29    Post subject:  

Backwards compatibility is something I dont have right answer. Hmm...If I dont strip the compiled package, would it help, I dont know yet.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Wed 22 Jun 2011, 06:22    Post subject:  

Quote:
Do Qt programs generally need the version of Qt they were compiled against, or higher?


Higher. Just like gtk2 apps. compiled on say pup4, will generally work fine with lupu, but not the reverse.

Unfortunately often developers will compile their app on the latest whiz bang qt4/gtk2 release, and the resultant binary can then have unrequired dependencies.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 22 Jun 2011, 16:29    Post subject:  

I am guilty. I confess my sins as using the latest Qt. I hope the penalty is not permaban.
Back to top
View user's profile Send private message 
muggins

Joined: 20 Jan 2006
Posts: 6690
Location: lisbon

PostPosted: Wed 22 Jun 2011, 17:45    Post subject:  

I'm referring to developers of qt4 apps. If you browse qt-apps.org you'll find many apps which will not compile with qt4-4.3.2, but require newer releases of qt4.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 22 Jun 2011, 17:50    Post subject:  

Ok. Havent tracked much, since my used new Qt libs does not have that problem. But not all older apps do like the new Qt4 also. I get errors which seems to come from incompatibility when compiling.
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1052
Location: the australian mallee

PostPosted: Wed 22 Jun 2011, 19:16    Post subject:  

muggins wrote:
I'm referring to developers of qt4 apps. If you browse qt-apps.org you'll find many apps which will not compile with qt4-4.3.2, but require newer releases of qt4.


Bare with me, i'll try to answer what I think you are asking.

A QT3 application needs QT3's libs to run.

A QT4 application needs QT4's libs to run.

An individual QT3/4 application may need you to update your QT3/4 libset. That may be because a libfault has been fixed, a function has been enhanced or a new function added. The last two require a "comittee" type signoff and extensive testing.

However, after upgrading your libset, all other QT4 applications you have already installed and did run with an earlier QT4 libset are suppose to still be able to run without problem. And so far I haven't seen this fail, except for one where the programmer was using the "QTlib fault" to perform a function in their program. It was fixed as soon as pointed out to them.

A prime rule in QT is that libs ARE required to be 99.999% backward compatable UNLESS a coding problem is being fixed, and that all certified QT applications are to be tested and give signoff against the upgrade.

Hope that helps.

scsijon
Back to top
View user's profile Send private message Visit poster's website 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Wed 22 Jun 2011, 21:32    Post subject:  

As for backward compatibility...

I uninstalled QComicbook 0.7.2, and reinstalled the previous version I had (0.3.4, qcomicbook-v0.3.4-i486.pet), with Qt 4.5.3 still installed. Here's the error the 0.3.4 package throws with Qt 4.5.3 installed (as I mentioned in my first post in this thread):

Code:
qcomicbook: error while loading shared libraries: libqt-mt.so.3: cannot open shared object file: No such file or directory


Could that be solved with a symlink? (Just curious.)

I don't suppose there are any Qt 4.5 dev packages around that'll work on Puppy 4.3.1, are there? Razz

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1052
Location: the australian mallee

PostPosted: Sun 26 Jun 2011, 21:59    Post subject:  

Maybe, ttuuxxxx would know.

I take it you've already checked the storage tree at http://distro.ibiblio.org/pub/linux/distributions/puppylinux/.

regards
scsijon
Back to top
View user's profile Send private message Visit poster's website 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Sun 26 Jun 2011, 22:09    Post subject:  

Yes, and I went ahead and checked it again, just now... not every directory, though, of course. Embarassed All I saw in the 4.3.1 directories was the Qt 4.3.2 pet. Smile
_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1052
Location: the australian mallee

PostPosted: Mon 27 Jun 2011, 03:02    Post subject:  

@makoto

Embarassed Embarassed apologies, I should have checked QT4 against the kernal version before answering.

According to the QT4 list puppy 4.3.1 's kernal should work with QT4.4.6/7, QT4.5 requires a later kernal.

Also:

your "qcomicbook: error while loading shared libraries: libqt-mt.so.3:..."

I haven't got this library on my dev box with QT4 either.

After a little chase,

I found it's a QT3 file, not a QT4 file (according to SLUG) and must be in a specific place. There are 48 listed errors against this one file and most seem to be still open (they go back to 2005). Part of Qt GUI Library (Threaded runtime version), Version 3.

Now I do know QT3 is in the tree and works in 4.3.1, as that's where I first used it (and I think Rolling Eyes where ttuuxxxx Wink first built a QT library for me).

regards
scsijon

Last edited by scsijon on Mon 27 Jun 2011, 03:22; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
Makoto


Joined: 03 Sep 2009
Posts: 1820
Location: Out wandering... maybe.

PostPosted: Mon 27 Jun 2011, 03:22    Post subject:  

It's probably worse since I'm using a Retro kernel (2.6.21.7, IIRC). Smile (Even though I really shouldn't have been using it, for 4.3.1.)

Guess I should uninstall Qt4.3.5 and reinstall Qt 3.3.8, then. The version of QComicbook I have runs without problem, there. At the moment, it's the only Qt program on my system. Sad (...and then I'll find something else I'll want to run that needs Qt4... Very Happy)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 3 [33 Posts]   Goto page: Previous 1, 2, 3 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0940s ][ Queries: 11 (0.0263s) ][ GZIP on ]