Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 20:48
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
E17 Build Script
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 1 [5 Posts]  
Author Message
Iguleder


Joined: 11 Aug 2009
Posts: 1927
Location: Israel, somewhere in the beautiful desert

PostPosted: Fri 17 Jun 2011, 03:59    Post subject:  E17 Build Script
Subject description: Build scripts for E17 and its dependencies
 

Here's something I've been working on for some time: an automated way to install E17 on Puppy.

To use any of the scripts (*.sh.gz) download them and run gunzip. You'll need the devx, of course.

How to use this thing? First of all, get Lua or use the build script. Then, run the Bluez build script (for the E17 Bluetooth gadget, if you want it). Acpid is a nice extra.

Once you have those, run e17.sh and e17-modules.sh for extra modules. I picked those that are really useful.

Once you have E17 and everything built correctly (assuming it worked), install the PET (it was created for 5.x but should work on any, I guess) to install a required tweak for Puppy and nice default settings that use the Rox wallpaper.

btw: the build script won't install the packages - for instance, copy the contents of "e17-r$something-1" to / in order to install e17.

Have fun!
screeny.png
Description 
png

 Download 
Filename  screeny.png 
Filesize  722.03 KB 
Downloaded  736 Time(s) 
e17-puppy-001.pet
Description 
pet

 Download 
Filename  e17-puppy-001.pet 
Filesize  170.86 KB 
Downloaded  788 Time(s) 
e17-modules.sh.gz
Description 
gz

 Download 
Filename  e17-modules.sh.gz 
Filesize  896 Bytes 
Downloaded  522 Time(s) 
e17.sh.gz
Description 
gz

 Download 
Filename  e17.sh.gz 
Filesize  889 Bytes 
Downloaded  545 Time(s) 
lua.sh.gz
Description 
gz

 Download 
Filename  lua.sh.gz 
Filesize  814 Bytes 
Downloaded  486 Time(s) 
bluez.sh.gz
Description 
gz

 Download 
Filename  bluez.sh.gz 
Filesize  607 Bytes 
Downloaded  524 Time(s) 
acpid.sh.gz
Description 
gz

 Download 
Filename  acpid.sh.gz 
Filesize  574 Bytes 
Downloaded  496 Time(s) 

_________________
My homepage
My GitHub profile
Back to top
View user's profile Send private message Visit poster's website MSN Messenger 
ICQ Number 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Tue 23 Aug 2011, 16:49    Post subject:  

e17-modules.sh script.

Code:
export CFLAGS="$CFLAGS -B$INSTALL_PREFIX/lib -I$INSTALL_PREFIX/include"
export CXXFLAGS="$CFLAGS"

lol(){
# download the sources and create tarballs


Lol, well, I removed that lol() and the script started to work. Is it just me who had lol() in the script and it prevents it working. Maybe just these weird days....
I had to struggle with missing config.guess and config.sub...again with Lucid Puppy. I would like to know what command or export or edit fixes it. I got it working with copying them to all folders, but there surely is subtle way to do it better.

Anyways, using 62731 rev.
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5465
Location: Finland

PostPosted: Wed 24 Aug 2011, 03:37    Post subject:  

Ok. I got e17 and modules compiled with scripts. I even added weather and forecasts modules to the script and they compiled also. Eweather and xkbswitch didnt. Eweather module compile errored that eweather module is not found. No surprise because I was just compiling it. Xkbswitch module complained missing headers. I have to investigate it more.

Next thing is to make complete one pet of e17 with everything in one pet. Bluez, Lua, configuration changes needed, some themes, preconfigured files, wmswitcher etc...

Aim is one click and install and have complete e17 for Lucid Puppies in one pet.
Back to top
View user's profile Send private message 
Chili Dog


Joined: 20 Dec 2011
Posts: 120

PostPosted: Mon 02 Sep 2013, 23:11    Post subject:  

I tried this today, but it didn't work.

You wouldn't happen to have an updated version kicking around, would you? Very Happy
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3982
Location: Kiel,Germany

PostPosted: Mon 11 Nov 2013, 08:34    Post subject:  

An E svn or git checkout takes 800mb space .
There are several E versions at http://download.enlightenment.org/snapshots/

e18 and e19 are discussed here : http://planet.enlightenment.org/
(EFL 1.8 Alpha 1 + Enlightenment 0.18 Alpha1 & Terminology 0.4 Alpha1)

git needs functioning autotools automake/autoconf --version 's .
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 1 of 1 [5 Posts]  
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Desktop
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0554s ][ Queries: 12 (0.0069s) ][ GZIP on ]