Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 22 Jul 2014, 09:26
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
SFStray
Post new topic   Reply to topic View previous topic :: View next topic
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Author Message
nancy reagan

Joined: 22 Jan 2009
Posts: 501

PostPosted: Sun 24 Jul 2011, 07:52    Post subject: sfs dirloader works in lupu as well  

Sorry but sfs dirloader seems to work in 5 series as well

http://www.murga-linux.com/puppy/viewtopic.php?t=44601
Back to top
View user's profile Send private message 
seaside

Joined: 11 Apr 2007
Posts: 886

PostPosted: Sun 24 Jul 2011, 11:34    Post subject:  

maxerro wrote:
Here's one wipeout version:

Code:
add() {
   echo -e "$APP" >> $HOME/.SFStray/sfstray_list
}


When you hit the Add button while nothing is selected (or there are no SFS files in the required dir) it creates a non-empty "empty" sfstray_list, and when you hit Apply it sends all writable mounted media down the toilet.



maxerro.

Thank you for pointing out that scenario. I've added the following code with an exit to ensure that doesn't happen.

Code:
 umount /mnt/"$P"
 STATUS=$?
 [ $STATUS -ne 0 ] &&  yaf-splash -font "8x16" -outline 0 -margin 4 -bg orange -text "FAILURE! $P could not unmount - Perhaps files are still in use or no directory was specified" && exit


A new pet is attached to the first post.

Thanks again for catching that possibility.

Regards,
s
Back to top
View user's profile Send private message 
seaside

Joined: 11 Apr 2007
Posts: 886

PostPosted: Sun 24 Jul 2011, 11:55    Post subject:  

nooby wrote:
Safest is to go through the Menu and not do right click which sometimes shuts down the xorg.

Hi nooby,

I've tried using SFS-exec on Pup525 lately and so far have not experienced any xorg failure. Is there a particular set of conditions for this happening?

Regards,
s
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 3 of 3 [33 Posts]   Goto page: Previous 1, 2, 3
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Utilities
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0470s ][ Queries: 12 (0.0067s) ][ GZIP on ]