Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 19:53
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.15
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 19 of 148 Posts_count   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, ..., 146, 147, 148 Next
Author Message
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sun 07 Aug 2011, 02:26    Post_subject:  

Speaking of Java, I made a java.sfs a while back for those that did not want to actually install it
http://puppylinuxstuff.meownplanet.net/DaveS/java/

username puppy
password linux

_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5867
Location: Kentucky

PostPosted: Sun 07 Aug 2011, 02:35    Post_subject:  

Dpup Exprimo 5.X.1 live pfix=ram on yet another machine.Display and internet working on boot....no sound.Well, actually it shows as muted but sound is working now.

# report-video
Dpup Exprimo, version 5.X.1 on Sun 7 Aug 2011

Chip description:
d.0 VGA compatible controller
nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

X Server: Xorg
Driver used: nv

# free
total used free shared buffers
Mem: 3374204 476024 2898180 0 67804
Swap: 8294396 0 8294396
Total: 11668600 476024 11192576

-Computer-
Processor : 2x AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
Memory : 3374MB (182MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Sun 07 Aug 2011 01:49:33 AM CDT
-Display-
Resolution : 1440x900 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA NVidia
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 07 Aug 2011, 03:20    Post_subject:  

Thank you of your feedbacks.

davids45 report of getting his Ati graphics working warms me most. That Ati Catalyst driver package works only with my lupe28 2.6.39.3 kernels. That kernel is close copy of Barrys recent 2.6.3.9.3 kernel, vgaswitcheroo, PAE and kernel debugfs taken out. Why so. PAE causes instability with older intel Pentium comps, even non booting, Vgaswitcheroo does not work with all ATI - intel dual graphics and lead with my graphics to kernel panic ( known and reported bug).

Iguleder has compiled and already recompiled his 2.6.39.3 kernel. It is brand new. Reports of its stability is needed. My kernel has been already in Polarpup 003 and MNS Office Edition, Nvidia and ATI graphics drivers compile with it ok.

I would like to see same kernel in all dpups so that compiled extra third party drivers are usable in all them.

But as I have posted in first page. This is still experimental build eventhough maturing.....

CLAM01. I think that your found problem is due to new kernels behavior and init script. Barry posted something about slow older usb 1.0 delay removal by linus. I dont know if there has been done something to the old cd drives also. But....your report is something that Barry Kauler should know. Would you like to report that to Barrys blog or PM him. Barry reads his forum PM messages even though he does not answer actively. But this kind problem is surely something he is interested.
Prolonging the cd drive content detection and booting time files searching time is done through init script. There is no way that I start to tinker with it. It is absolutely job done by Barry Kauler.
Luci devel thread has good example what happens when you use old woof and start to tinker with init script to have same fixes that new woof produces natively. Woof and changes through it is the way I follow.

Marco07. Good news about that java package. I could make a sfs of it so that we have the latest as sfs also. I will upload both to the slowly growing repo.

Edited_time_total
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7836
Location: qld

PostPosted: Sun 07 Aug 2011, 03:28    Post_subject:  

About sound...

I believe there is a missing option in 10alsa script (/etc/init.d/10alsa). My sound has always been mute on my main box, an nvidia chipset, X2 processor. In next spup (uploading shortly) I am adding these lines:
Code:
set 'Master Front' 75% unmute
set 'Master Front' -12dB


We'll soon find out if something breaks!

Cheers

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 07 Aug 2011, 03:37    Post_subject:  

01micko. Thank you of your post about 10alsa script. I will include your finding to init script. I have added to my alsafix script:
Code:
set Speaker 75 % unmute


It has helped my audio.
Back to top
View user's profile Send_private_message 
gnomic

Joined: 20 Aug 2010
Posts: 77

PostPosted: Sun 07 Aug 2011, 04:52    Post_subject:  

Hi, just having a little difficulty keeping up with the rapid pace around here -
is the iso of 4th August called squeeze-5.X.1-SCSI significantly different from the one I have from 3 August called 5.0.0.4-SCSI? Or is this just a name change, in which case I'll stick with the iso I have for now.
Back to top
View user's profile Send_private_message 
davids45


Joined: 26 Nov 2006
Posts: 652
Location: Chatswood, NSW

PostPosted: Sun 07 Aug 2011, 05:13    Post_subject:  

G'day,
I have now used the ati-11.7-k2.6.39.3-lupe28.pet with dpupsqueeze5004 to get 1600x900 graphics from the default 1280x1024.
I used this pet with dpup485 and dpup484beta4 (frugals) - and also got 1600x900 graphics from the previously intractable default 1280x1024, although the ATI Catalyst Control Centre doesn't run. In dpup484beta4 (posting from it now) the graphics are reported as 'vesa' by the report-video-glx.pet:

"Sun 7 Aug 2011 Operating System: Lenny Puppy-484 Linux 2.6.30.5
0.0 VGA compatible controller: ATI Technologies Inc Device 68f9
oem: ATI ATOMBIOS product: CEDAR 01.00

X Server: Xorg Driver: vesa
X.Org version: 1.4.2
dimensions: 1600x900 pixels (443x249 millimeters)
depth of root window: 24 planes

Pentium(R) Dual-Core CPU E5800
Core 0: 3226 1: 3226 MHz"

This result is like I found using the late-kernel lucid-ATI pet - some early kernel Pups (e.g. Puppy 4.2) would respond with the better graphic resolution, even though the Catalyst Control Centre didn't work.

But I'm very happy just to get good graphics off this 1600x900 monitor from all these older Pups.

David S.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sun 07 Aug 2011, 05:59    Post_subject:  

davids45. Yep. The fglrx kernel module graphics driver wont load. Wrong kernel. But the other framework libs might help still.

Anyway. Stu90 has found that libdrm_radeon was missing in our builds. It will be included to the next version.

Here it is as installable pet if someone wants to try it so that he does not need to install proprietary driver and go through that xorg.conf switching operation.

This pet should enable the radeon driver loading.
libdrm-radeon-2.4.21.pet
Description 
pet

 Download 
Filename  libdrm-radeon-2.4.21.pet 
Filesize  396.67 KB 
Downloaded  302 Time(s) 
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2131
Location: Ontario Canada

PostPosted: Sun 07 Aug 2011, 10:45    Post_subject: Dpup Exprimo 5.X.1
Sub_title: laptop
 

Manusl frugal install to acer laptop.
Installed devx+kernelsourcesfs+ati-driver-installer-11-7-x86.x86_64.run

# report-video
Dpup Exprimo, version 5.X.1 on Sun 7 Aug 2011

Chip description:
0.0 VGA compatible controller
ATI Technologies Inc Manhattan [Mobility Radeon HD 5000 Series]
oem: ATI ATOMBIOS
product: PARK 01.00

X Server: Xorg
Driver used: vesa Driver fglrx #card0driver

X.Org version: 1.7.7
dimensions: 1600x900 pixels (423x238 millimeters)
depth of root window: 24 planes

...the above also recorded in /tmp/root/ as report-video,
and archived with xorg.conf and Xorg.0.log as report-video-full.gz

It's running well on this laptop.
Back to top
View user's profile Send_private_message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Sun 07 Aug 2011, 10:52    Post_subject:  

I will give this one another chance. I get back within one hour and tell result.
Writing from within this one now. All went well. But as always them love to be
1024 x 600 and do refuse to be 1024 x 768. But that has been so for each Dpup since the first one so must be some wanted feature by some Devs Smile

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send_private_message 
Béèm


Joined: 21 Nov 2006
Posts: 11782
Location: Brussels IBM Thinkpad R40, 256MB, 20GB, WiFi ipw2100. Frugal Lin'N'Win

PostPosted: Sun 07 Aug 2011, 17:37    Post_subject:  

Wow,
Having been only a couple of days away and there are releases passing by.
Installed FRUGAL, Lin'N'Win, the 5.X.1

I did take probe, but didn't get a desktop. report-video told me I got the fbev driver installed for my radeon 7500 graphics controller.

I then did choose radeon.
I did get the desktop, but my keyboard, which was azerty, turned into qwerty.
Like the 5.0.0.2. So no-go for me.
I then chose vesa as in the 5.0.0.2
I got the desktop and the azerty keyboard

_________________
Time savers:
Find packages in a snap and install using Puppy Package Manager (Menu).
Consult Wikka
Use peppyy's puppysearch

Edited_time_total
Back to top
View user's profile Send_private_message 
scsijon

Joined: 23 May 2007
Posts: 1047
Location: the australian mallee

PostPosted: Sun 07 Aug 2011, 22:28    Post_subject:  

James C wrote:
I threw together another box out of some old parts so Dpup Exprimo 5.X.1 live pfix=ram. No hdd, no swap. Running short on sata drives.... Laughing
Everything working on boot....sound,internet and display.

Looking good here. Smile


I've now had all three of my boxes working from the cdrom by adding pfix=ram,nox and setting up video manually before starting xwin.

However, two of the three are still crashing after a frugal install and reboot, i'm still playing with the starting pfix parameters now to see if I can work out where the problem is but i'm beginning to wonder if it's actually a permissions problem.

UPDATE: will install the radeon pet to see if it fixes box2 up. more later.

regards
scsijon
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1465
Location: Malvern, Worcs, UK

PostPosted: Mon 08 Aug 2011, 16:15    Post_subject: Defaults for office programs  

A problem with not including Abiword and Gnumeric is that:

defaultwordprocessor and
defaultspreadsheet

still point to these non-existent programs.

I have successfully added the LibreOffice sfs to my frugal install but there needs to be an easy way to amend the defaultxxxx files to now point to LibreOffice....

I've edited the 2 defaults as follows:

defaultwordprocessor - exec LO-swrite "$@"
defaultspreadsheet - exec LO-scalc "$@"

I guess the icons should also be changed but I can live without that.

Cheers
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Mon 08 Aug 2011, 17:25    Post_subject:  

Because I cant know what people prefer, LibreOffice, Openoffice, Abiword-gnumeric combo, Softmaker etc....

I updated Scottmans great defaults chooser to have LibreOffice 3.4 as choosable defaults changer.

Another package has missing mimes for doc, docx, ppt etc...I dont use LibreOffice draw, so someone using it can give feedback of missing mimes for it and I create them.
The LibreOffice pet has also defaultwordprocessor, defaultspreadsheet and brand new defaultpresentation which changes LibreOffice as default handler. Defaultdraw is not included and is not changed. Defaultmath I didnt create, could be do that also, but I dont know the mime status for it.

Also here is link to Office pets and sfs for those I have packaged.

http://www.smokey01.com/pemasu/pet_packages-exprimo/
defaults-chooser-0.8-exprimo.pet
Description 
pet

 Download 
Filename  defaults-chooser-0.8-exprimo.pet 
Filesize  4.97 KB 
Downloaded  292 Time(s) 
LibreOfficeHandlers_mime_types-0.0.1.pet
Description 
pet

 Download 
Filename  LibreOfficeHandlers_mime_types-0.0.1.pet 
Filesize  1.25 KB 
Downloaded  295 Time(s) 
Back to top
View user's profile Send_private_message 
davids45


Joined: 26 Nov 2006
Posts: 652
Location: Chatswood, NSW

PostPosted: Mon 08 Aug 2011, 20:18    Post_subject:
Sub_title: missing libdrm_radeon pet works
 

G'day,

Just to confirm that installing the missing libdrm_radeon into a fresh Dpup Exprimo 5.X.1 produced on my computer the correct 1600x900 resolution.

So thank you to Stu90 for finding what wasn't there, and to pemasu for making what wasn't there into a pet.

This is a smaller and better alternative fix to the proprietary ATI Catalyst pet - I will check if the problem of the black screen/no-graphics on shut-down or prompt is present with the fixed radeon.

And if adding this libdrm_radeon to early Dpups (like dpup484) also fixes their poor graphics on this computer/monitor combination.

David S.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 19 of 148 Posts_count   Goto page: Previous 1, 2, 3, ..., 17, 18, 19, 20, 21, ..., 146, 147, 148 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1119s ][ Queries: 12 (0.0207s) ][ GZIP on ]