Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 02:02
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Dell Lattitude D400 locks up on closing lid
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message
shadowspawn

Joined: 14 Sep 2010
Posts: 7
Location: Austin, TX

PostPosted: Sun 14 Aug 2011, 10:02    Post_subject:  Dell Lattitude D400 locks up on closing lid
Sub_title: When I shut the lid on either live or frugal install, the system appears locked
 

I don't know if it's similar to this http://murga-linux.com/puppy/viewtopic.php?t=70622 but what I tried didn't work. (I tried out the 5.1.3 wary but it does the same thing.)

This is for Lucid 5.2.5

Please excuse me if this bug is posted somewhere else, but I could not find it. If it is posted elsewhere I will delete this and put this information in that thread.

This is for a Dell Latitude D400. I can reproduce this by using a USB Flash drive "live" distro or frugal full install on any type of drive.

I'm using a CF/IDE system, so I thought it was that, put in a regular HD (and even no HD, booted live with no HD), and then live with a regular HD. All combinations lock up when I close the lid, it never comes back to life. (The firewall is automagically done, so maybe that's why no response to ping)

I've tried using wlan and wired as my connection, and no network setup.

Xubuntu/ubuntu/debian/edubuntu/DSL I've tried, and it doesn't happen. (Doesn't happen with windows XP either, so I'm really guessing hard here I know, but it's not hardware).

I've ran memtests and dell's own diagnostic and it doesn't report anything bad.

I use puppy on a few older machines and this one is the only one that does it. Is there something I can do, using a live USB flash, to try to see what it is?

I'm not doing anything special, it's just an install without any configuration. It's easy for me to test: boot with the USB, go through the setups for wireless, everything works flawlessly (and lovely).

When I shut the lid and open it, the machine never comes back to life.

I have a different Latitude (d505) and Puppy is OK with that. Also a couple of thinkpads I tested with and no problems on shutting the screen.

Any help would be appreciated.
Back to top
View user's profile Send_private_message Visit_website 
ICQ 
HiDeHo

Joined: 16 Mar 2011
Posts: 286

PostPosted: Tue 14 Aug 2012, 02:30    Post_subject:  

Hi shadowspawn here are some things you can try.
  1. when you shut the lid does the laptop go into sleep or hibernation mode. if it does you will need to have a swap file or swap partition the same size as you have ram. eg for 4gb ram you need 4gb swap file or partition to achieve sleep or hibernation
  2. make sure you have the correct graphic driver installed on the computer with the issue.
I hope one of these options helps you.

_________________
HiDeHo is an ideas man. loves to come up with ideas that others think are good and can use
if you are a sneeky computer geek check out sneekygeekers click here
Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3972
Location: Kiel,Germany

PostPosted: Tue 14 Aug 2012, 09:23    Post_subject:  

I think this is a hardware problem , probably of the lid manager acpid . But mostly it seems to be kernel failure. You should post that at kernel.org or in the users section.
Back to top
View user's profile Send_private_message Visit_website 
bigpup


Joined: 11 Oct 2009
Posts: 5237
Location: Charleston S.C. USA

PostPosted: Sat 18 Aug 2012, 00:37    Post_subject:  

I have seen some state, tapping the power button, when you open lid, works.
_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 11 (0.0088s) ][ GZIP on ]