Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 12 Dec 2017, 02:54
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Lucid Puppy 5.2.8 - Updated ISO Version 005 - APR 05 2012
Moderators: Flash, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 191 of 191 [2854 Posts]   Goto page: Previous 1, 2, 3, ..., 189, 190, 191
Author Message
bigpup


Joined: 11 Oct 2009
Posts: 9647
Location: Charleston S.C. USA

PostPosted: Sat 07 Nov 2015, 23:49    Post subject:  

Quote:
that I updated to 5.2.8.7.

How did you do the update?
What specific version of 5.2.8.7?

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
rswain

Joined: 06 Oct 2009
Posts: 6
Location: Methven NZ

PostPosted: Sun 08 Nov 2015, 00:18    Post subject: No Sound
Subject description: Lucid 5.2.8.7 Upgrade
 

Booted off the 5.2.8.7 iso CD downloaded from http://www.mediafire.com/download/ndza54d2babdzua/lupu-5.2.8.7-20150702.iso Ran the install process and selected Upgrade. Elected not to do the grub stuff.

Noticed that I had sound when booted from CD OK but not after upgrade on hard drive full installation

Sorry should I be in the lucid revitalised forum (http://www.murga-linux.com/puppy/viewtopic.php?t=90461)

Thanks for your help


Have spent time analysing and found new rc.sysinit deletes /dev/snd as part of initialising. However they are not recreated. Copying devices from another machine restores sound after alsamixer is run to unmute etc.
Comment out the rm /dev/snd works around the problem

hope this helps someone
Back to top
View user's profile Send private message 
Karl Godt


Joined: 20 Jun 2010
Posts: 4208
Location: Kiel,Germany

PostPosted: Thu 31 Dec 2015, 01:07    Post subject: Re: Alsa Sound wizard
Subject description: Alsa sound wizard does not create devices in /dev/snd
 

rswain wrote:
Hi,

I have 2x5.2.8.5 full hd installations that I updated to 5.2.8.7.
On both /dev/snd is not populated so alsamixer and aplay do not work giving segment errors for aplay and empty window for alsamixer.

I have checked the module is loaded OK on both machines and /proc entries are ok. The configuration appears to be successful but the udev section where the /dev/snd entries are created appears not to work.

I suspect a change to rules.d or a library change.

Anyone have any ideas.

Thanks

This is how I create the missing device nodes :
/etc/init.d/alsa :

Code:
  ###<KRG>
   mkdir -p /dev/snd
   D=`find /sys -type d -name "*sound*"`
   POOL=''
    for i in $D ; do
     ##echo $i ;
     DEV=`find $i -type f -name "dev" -exec echo -n {}@ \; -exec cat {} \; | tr ':' '@' -exec echo \; ` ;
     POOL="$POOL $DEV" ;
    done
   POOL=`echo $POOL | rev`
    for i in $POOL ; do
     NODE=`echo $i | cut -f 3 -d '@'`
     NODE=`echo $NODE | rev`
     NODE=`basename $(dirname $(echo $NODE) )`
     MAJ=`echo $i | cut -f 2 -d '@'`
     MAJ=`echo $MAJ | rev`
     Min=`echo $i | cut -f 1 -d '@'`
     Min=`echo $Min| rev`
     echo "$NODE" "$MAJ" "$Min"
     rm -f /dev/$NODE 
     mknod /dev/$NODE c $MAJ $Min
     rm -f /dev/snd/$NODE 
     mknod /dev/snd/$NODE c $MAJ $Min
    done
   ###</KRG>

   if [ -f /etc/asound.state ] ; then

    alsactl -f /etc/asound.state restore #from /etc/asound.state.

   else

    #try and set all levels workable...
    #set_mixers #in functions4puppy4
    amixer -s -q <<EOF
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 15 Jan 2016, 01:55    Post subject: I was sent here by Angel Linux quickpet  

oh sorry.. I was sent here by Angel Linux quickpet ( very nice piplette)
But i can inform you that newer versionsof songbird can be used with your Puppy Sulu
here, with shoutcast.
multimedia.jpg
 Description   PPM lucid was not bad, downloads run fine, but newer stuff is provided inside our forum
 Filesize   72.04 KB
 Viewed   634 Time(s)

multimedia.jpg

songbird.jpg
 Description   see theAsrerisk topic
 Filesize   69.59 KB
 Viewed   645 Time(s)

songbird.jpg


_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
Display posts from previous:   Sort by:   
Page 191 of 191 [2854 Posts]   Goto page: Previous 1, 2, 3, ..., 189, 190, 191
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0965s ][ Queries: 14 (0.0481s) ][ GZIP on ]