Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 19 Apr 2014, 12:45
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Puppy Phone - VOIP using SIP
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 27 of 38 [557 Posts]   Goto page: Previous 1, 2, 3, ..., 25, 26, 27, 28, 29, ..., 36, 37, 38 Next
Author Message
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Mon 10 Oct 2011, 16:17    Post subject:  

Sylvander wrote:
1. Uninstalled the previous Psip mentioned above, then...

2. Installed the latest...
Psip32-1.2-Slacko.pet
Within...
Slacko-5.29-5 RC (k2.6.37.6)

3. Attempted to set up this new Puppy Phone version for use.
Previous problems were gone.
Was able to use "Setup" to enter all my details, and move on to the next step, where I had problems as follows:

4. Used "Add+" to add smokey01 as a buddy, which succeeded, but...
(a) His "Nickname" was displayed as "Puppy" [rather than the text I entered as his nickname], when I entered that text as "Category".
(b) Highlighted/selected the line and tried to use "Edit", but the program was/is frozen.
Won't "Remove" either.
(c) Am I doing something wrong?


Sylvander try starting without a .psip.conf file. There have been many changes and the later .psip.conf files are different, quite different.

In other words make sure you delete /root/.psip.conf before you run Psip32-1.2 for the first time.

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Mon 10 Oct 2011, 16:19    Post subject:  

Stripe I thought James had fixed the problem you are experiencing.

He did say it was a rough work around and wasn't happy with it.

Maybe he has some other ideas. I don't, for the moment.

Sorry

_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
Stripe

Joined: 23 Jun 2010
Posts: 642
Location: In a field. England

PostPosted: Mon 10 Oct 2011, 16:28    Post subject:  

hi all

@smokey01 dont worry about it, I am now running in console log level 6 to see if I can get more info for james

cheers

don
Back to top
View user's profile Send private message 
Stripe

Joined: 23 Jun 2010
Posts: 642
Location: In a field. England

PostPosted: Mon 10 Oct 2011, 18:19    Post subject:  

hi all

I have managed to get two logs both ending when the sound went quiet (but still the call was not dropped and sound was enabled again after the hold checkbox was checked then unchecked)

again these are text files with .gz added, to read just remove the .gz and open in a text editor

Hope this helps

Don
mode 6 log error 2.gz
Description 
gz

 Download 
Filename  mode 6 log error 2.gz 
Filesize  9.02 KB 
Downloaded  149 Time(s) 
mode 6 log error 1.gz
Description 
gz

 Download 
Filename  mode 6 log error 1.gz 
Filesize  6.01 KB 
Downloaded  157 Time(s) 
Back to top
View user's profile Send private message 
smokey01


Joined: 30 Dec 2006
Posts: 1792
Location: South Australia

PostPosted: Tue 11 Oct 2011, 03:27    Post subject:  

Stripe have you tried disabling TCP in the network tab under setup?
_________________
Puppy Software <-> Distros <-> Puppy Linux Tips
Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 1876
Location: The Blue Marble

PostPosted: Tue 11 Oct 2011, 05:28    Post subject:  

dogle wrote:
jamesbond wrote:
The function that crash is internal pjsip library's set-sound-device

What logging tool is best for determining the cause of crashes like this?
Well, in this particular case, I put print statements inside the code and re-compile. You could in theory enable maximum logging level in the setup dialog, but in this case the crash happens before you even have the chance to set the log-level ...

That being said:
jamesbond wrote:
Sylvander wrote:
(c) When attempting to use "Setup", once I'd typed my "Account" details, the program froze with blank dialog windows.
I just tested in Slacko RC++ - I used my binary compiled in Wary 5.0, it crashed just like Sylvander said. The function that crash is internal pjsip library's set-sound-device Shocked
Smokey01 will come up with one that is compiled properly in Slacko - hopefully this will mitigate the issue.

I need to eat back my words. The binary compiled in Wary works. It failed in Slacko when I run Slacko inside VirtualBox - so it's VirtualBox problem.

Stripe wrote:
The problem.
when I am talking on psip, occasionally the line goes quiet but the call is still connected in the call window, after some trial and error I have discovered that if I check the hold box for that call, then uncheck it, the call returns to normal. (without dropping the call) (according to the terminal window I have just suspended the call and then made it active, there is no entry for the line actually going quiet)
When this happens, please use the "Stats" button on the call window, and notice the lines after RX and TX line - which shows the number of network packets you have received. These numbers should increase with time, it they don't, you're not getting them --> something wrong with your network.

Stripe wrote:
what I have tried so far: different versions of puppy, different versions of psip, different router (all lan connections), different pc,s (incase it is hardware related). have even portfowarded the routers on 5060/5061 all without sucsess
Don't port-forward your routers, this is unnecessary except in the most extreme circumstances.

Options to try:
a) check "Disable TCP" option in network settings (as smokey01 said)
b) check "Disable Optional SRTP" option in network settings
c) worse comes to worst, use "stun.iptel.org" in the STUN server setting. (Note: STUN server, not TURN server. Don't touch the TURN server settings - there is no known public TURN server that we can use).

Let me know how you go with this.

I'm going to see at your logs to see if I can sniff anything ...

EDIT: The only thing I can see from your log is that you are experiencing a lot of packet loss (ie your network connection seems to be unstable, for whatever reasons) ... and after enough packet loss, psip just give up and drop the entire voice call. Using "hold" and "unhold" basically is the same as "drop and then call again" - so it re-starts the voice call again.
You're saying you're on LAN, so this is impossible? Try to change your SIP port from the default 5060 to say 5070 or something else, and see if that helps.

cheers!

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13
Back to top
View user's profile Send private message 
Sylvander

Joined: 15 Dec 2008
Posts: 3252
Location: West Lothian, Scotland, UK

PostPosted: Tue 11 Oct 2011, 07:20    Post subject:  

1. "Sylvander try starting without a .psip.conf file"
Having just now uninstalled Psip32-1.2-Slacko [working within Slacko-5.29.5 RC]...
Tried to "Find" a file named .psip.conf without success.
Then searched for psip, and the only file found was the PET file used to install the program.

2. Now having re-installed Psip32-1.2-Slacko...
I disabled the firewall, and the sound check was OK....
But...
The program is freezing when I attempt to enter my details. Sad
Back to top
View user's profile Send private message 
CatDude


Joined: 03 Jan 2007
Posts: 1432
Location: UK

PostPosted: Tue 11 Oct 2011, 15:29    Post subject:  

Hi

The attached .pet Psip32-1.2-Wary512.pet
is a repackaged Psip32-1.2-Lucid.pet, but the actual psip binary was compiled in Wary-5.12 especially for dogle

It was working OK for me on my Acer laptop, i was able to listen to the iptel Music test,
and also run the echo test too, and i even sent a voice mail to dogle
to let him know that i have posted this here (i hope he received it Rolling Eyes )

CatDude
.
Psip32-1.2-Wary512.pet
Description 
pet

 Download 
Filename  Psip32-1.2-Wary512.pet 
Filesize  696.6 KB 
Downloaded  234 Time(s) 

_________________

Back to top
View user's profile Send private message 
dogle

Joined: 11 Oct 2007
Posts: 321

PostPosted: Tue 11 Oct 2011, 16:38    Post subject:  

Thanks a bucket, CatDude.

Not good news though - I still get the same error messages re. Psip32's attempts to setup its initial audio configuration, and it still freezes when I attempt to put in data, without establishing a /.psip.config file.

Anyway maybe this is progress ... whatever the problem is, seems it is not resolved by recompiling as you have so kindly done. (I'm running a bit short on ideas right now).
Back to top
View user's profile Send private message 
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Wed 12 Oct 2011, 02:36    Post subject:  

has anyone else notice that Wary's devx is missing several .so files? ... causes some severe bloatage (cairo, png,rsvg, xvidcore ...) or maybe I have the wrong devx? the binaries are a lot smaller without a static cairo

btw I just stumbled on this:
http://www.creytiv.com/baresip.html

_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
jamesbond

Joined: 26 Feb 2007
Posts: 1876
Location: The Blue Marble

PostPosted: Wed 12 Oct 2011, 05:06    Post subject:  

dogle wrote:
Not good news though - I still get the same error messages re. Psip32's attempts to setup its initial audio configuration, and it still freezes when I attempt to put in data, without establishing a /.psip.config file.
It's almost certain the lock-up is caused by the specific interaction between pjsip's audio library (PortAudio), ALSA, and your machine. I have similar lock-up on very specific conditions then I run psip32 under VirtualBox - but not others. pjsip (the underlying library used by PSIP) can also under ALSA directly but it's horribly immature (I can't even get it to work on my machine). I welcome anyone who knows PortAudio better to look into pjsip's source and find what's wrong with that.

Quote:
has anyone else notice that Wary's devx is missing several .so files? ... causes some severe bloatage (cairo, png,rsvg, xvidcore ...) or maybe I have the wrong devx? the binaries are a lot smaller without a static cairo
Not with me - I have all these libraries?

Quote:
btw I just stumbled on this:
http://www.creytiv.com/baresip.html
Nice, I will see whether this will build. Documentation is next to nil though ...
_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 12 Oct 2011, 08:30    Post subject:  

technosaurus wrote:
has anyone else notice that Wary's devx is missing several .so files? ... causes some severe bloatage (cairo, png,rsvg, xvidcore ...) or maybe I have the wrong devx? the binaries are a lot smaller without a static cairo


You had me worried for a moment! I just checked, cairo, png, rsvg -- .so files are present. I am running Wary 5.1.106.

But, there is no libxvidcore.so!
...I'll fix it.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
technosaurus


Joined: 18 May 2008
Posts: 4134

PostPosted: Wed 12 Oct 2011, 15:12    Post subject:  

BarryK wrote:
technosaurus wrote:
has anyone else notice that Wary's devx is missing several .so files? ... causes some severe bloatage (cairo, png,rsvg, xvidcore ...) or maybe I have the wrong devx? the binaries are a lot smaller without a static cairo


You had me worried for a moment! I just checked, cairo, png, rsvg -- .so files are present. I am running Wary 5.1.106.

But, there is no libxvidcore.so!
...I'll fix it.
its probably the sfs version strings biting me in the but... symlinks were there, but pointed to wrong/missing versions(i usually just rename the devx as the zdrv ... have to version it now and its difficult to keep track, ill probably just start using my sfs linker that I posted in jwmtools, its just as fast and no headaches when in pfix=ram) I fixed mine up and removed redundant static libs ... huge size difference.
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send private message 
gcmartin

Joined: 14 Oct 2005
Posts: 3631
Location: Earth

PostPosted: Wed 12 Oct 2011, 17:38    Post subject: Picture of PSIP applicaiton  

I've looked thru most of the documentation we have. Sometimes trying to explain in words does not carry the messge as clearly as a picture does.

Here's a picture. Do we have a labeled similar picture?
VTalk Softphone Example.jpg
 Description   Picture is worth a 1000 words.
 Filesize   27.98 KB
 Viewed   606 Time(s)

VTalk Softphone Example.jpg


_________________
Get ACTIVE Create Circles; Do those good things which benefit people's needs!
We are all related ... Its time to show that we know this!
3 Different Puppy Search Engine or use DogPile
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 12 Oct 2011, 18:43    Post subject:  

GCMartin,
One thing I noticed right-off looking at your picture, is lack of a "help" button. The same with Psip -- well, I am trailing behind, I looked at it about a week ago, version 1.0 I think -- and I immediately noticed the main window lacked a "help" button.

Cos, newbies to Psip or voip in general might want some simple intro to what it is all about and how to get going.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 27 of 38 [557 Posts]   Goto page: Previous 1, 2, 3, ..., 25, 26, 27, 28, 29, ..., 36, 37, 38 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1065s ][ Queries: 12 (0.0229s) ][ GZIP on ]