Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 29 Aug 2014, 14:44
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Video
GeForce GTS 450 graphics card in Two-Headed Dog 528
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Author Message
xsilvergs

Joined: 20 Aug 2011
Posts: 12

PostPosted: Sat 20 Aug 2011, 11:33    Post subject:  GeForce GTS 450 graphics card in Two-Headed Dog 528
Subject description: Can't load correct drivers
 

Hi,

New to Puppy.

I installed Puppy 525 yesterday but had a problem with graphics, I then realised there was a 528 version so installed that but the problem was the same.

The PC has a GeForce GTS 450 graphics card and will only show at 1280x1024, my monitor displays at 1920x1080 so I have a black border all round. Ive tried different nvidia drivers but when I go to NVIDIA X server settings I get this message:-

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

No matter what I do I think it always defaults to Vesa.

Report Video GLX 0.4 reports:-

Code:
Sat 20 Aug 2011  Operating System: Two-Headed Dog-528  Linux 2.6.33.2
 0.0 VGA compatible controller: nVidia Corporation Device 1245 (rev a1) 
 oem: NVIDIA  product: BIOS-P/N@N8700 Chip Rev 

X Server: Xorg   Driver: vesa
X.Org version: 1.7.6
  dimensions:    1280x1024 pixels (533x302 millimeters)
  depth of root window:    24 planes


Intel(R) Core(TM) i3 CPU 540
 Core 0: 4185  1: 4185  2: 4185  3: 4185  MHz

...the above also recorded at '/tmp/root/report-video-glx'.


I also have Ubuntu on another partition and that displays correctly.

The PC is a quad core 4GHZ with 4gB of ram so isn't lacking.

Has anybody any ideas?

Thank you[/code]
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Sat 20 Aug 2011, 14:48    Post subject: nVidia driver installation to fresh Puppy  

Hi xsilvergs and welcome here at the Puppy forum.

What you describe is a known issue.

I suggest you start with a fresh Puppy booted from CD with "puppy pfix=ram" at the first splash screen. (Do not use your "corrupted" current save file!)
If you boot with grub, add pfix=ram to the boot parameter on the grub choice screen.

Then after the personalized settings have run through,
the first order of business is to establish an internet connection via the "connect" icon.
Next use the Quickpet icon and go to tab "drivers".
There you can test your card or directly click on the second button to choose an nVidia driver. Usually the highest numbered is a good choice.
After the installation procedure do exactly what is recommended in the small pop-up window. Write it down if your memory is short.

Exit to prompt , do the xorgwizard procedure and return to X.
Usually the graphics driver is then installed with the correctly chosen resolution.

Shutdown or reboot and save these settings to file.
Back to top
View user's profile Send private message 
xsilvergs

Joined: 20 Aug 2011
Posts: 12

PostPosted: Sun 21 Aug 2011, 02:52    Post subject:  

Hi wuwei thanks for getting back.

I tried what you suggested but still no luck:-

From Quickpet > Drivers if I 'Test Graphics Card' it reports nVidia Corp Device 1245 (rev a1) and tells me the best add on driver is Xorg-High. Elsewhere this comes up as 'xorg-High-1.1-Lucid graphics for Radeon, Intel, Other (not Nvidia)

From Quickpet > Drivers if I select Nvidia the Xorg-High is not an option.

That's as far as I've got.

Thanks
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Sun 21 Aug 2011, 05:24    Post subject:  

xsilvergs wrote:
Quote:
From Quickpet > Drivers if I 'Test Graphics Card' it reports nVidia Corp Device 1245 (rev a1) and tells me the best add on driver is Xorg-High.


I see what you mean. This is at best a dead-end street.
Better to use the second button in Quickpet, and choose the nVidia driver with the highest version number. It usually does the trick for me.
Back to top
View user's profile Send private message 
xsilvergs

Joined: 20 Aug 2011
Posts: 12

PostPosted: Sun 21 Aug 2011, 11:33    Post subject:  

wuwei

If I choose the second option and install any of the drivers I get

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

again.

Thanks for your ideas.
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5096
Location: Charleston S.C. USA

PostPosted: Sun 21 Aug 2011, 15:35    Post subject:  

xsilvergs wrote:
wuwei

If I choose the second option and install any of the drivers I get

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

again.

Thanks for your ideas.

Give specific details.
You do what?
You see what?

This sounds like you are just not doing the steps properly.

This is the manual way to change drivers. Quickpet has automated some of this.
http://www.murga-linux.com/puppy/viewtopic.php?t=58810

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
bigpup


Joined: 11 Oct 2009
Posts: 5096
Location: Charleston S.C. USA

PostPosted: Sun 21 Aug 2011, 16:02    Post subject:  

According to Nvidia support. The Nvidia 260 driver, in Quickpet, should work for your Video card.
There is a newer driver here:
http://www.murga-linux.com/puppy/viewtopic.php?t=69290

_________________
I have found, in trying to help people, that the things they do not tell you, are usually the clue to solving the problem.
When I was a kid I wanted to be older.... This is not what I expected Shocked
Back to top
View user's profile Send private message 
wuwei


Joined: 15 Sep 2007
Posts: 774
Location: de

PostPosted: Mon 22 Aug 2011, 01:48    Post subject:  

xsilvergs wrote:

Quote:
"If I choose the second option and install any of the drivers I get

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server." "


You will only get this, if you are using the savefile from a previous (frugal) installation. However, this savefile is corrupted by too many driver installations and maybe deinstallations. Therefore, start with a fresh Puppy by adding these parameters at the very first boot screen:

If starting from CD: puppy pfix=ram
If starting with Grub: pfix=ram

And do take bigpup's advice, as well.
Back to top
View user's profile Send private message 
xsilvergs

Joined: 20 Aug 2011
Posts: 12

PostPosted: Mon 22 Aug 2011, 11:48    Post subject:  

Hi bigdog

I've downloaded
Quote:
http://www.murga-linux.com/puppy/viewtopic.php?t=69290
but get an error message 'failed to install'

Just for info although I choose 1920x1080 it only displays as 1280x1024.

Thanks for help
Back to top
View user's profile Send private message 
mill0001

Joined: 01 Feb 2007
Posts: 375
Location: "People's Republik of Kalifornia"

PostPosted: Mon 22 Aug 2011, 12:33    Post subject:  

Hi, I had the same issue with my Nvidia 250 GTS. So here's a (hopefully) possble solution. (got mine working this way) Go to puppy package manager and uninstall any Nvidia driver pets you have installed and reboot the machine. When you get back to desktop open your terminal and type "nvidia-uninstall" without the quotes. This is just to try and get a clean install of the driver. Now open quickpet, test your card and then install the 260 driver from there. When you get to command prompt just follow the instructions. Your card will revert to vesa no matter what you do at this point. Let it and get back to the desktop. Now reboot into your Ubuntu system and find the X11 file. I don't use Ubuntu so I can't tell you where it is. You will have to use the find app in Ubuntu. Anyway when you find it copy the "xorg.cong" and the xorg.conf.NVIDIAXXXX (this is the config for your monitor and probably will have your monitor model number where I typed the XXXX) somewhere you can get to it in Puppy. Now reboot into Puppy and go to /etc/X11 and delete all the xorg.conf text files in there. Now copy the Ubuntu xorg.conf files into X11 and reboot. Now you should have your nvidia card workin. Open your terminal and type "nvidia-settings" (no quotes) and your nvidia settings manager should open up and let you adjust resolution and whatnot. Hope this works for you, Have a good day.
Back to top
View user's profile Send private message 
xsilvergs

Joined: 20 Aug 2011
Posts: 12

PostPosted: Tue 23 Aug 2011, 06:35    Post subject:  

mill0001

I tried your suggestion but the file structure seems different between my Ubuntu 11.04 and Puppy 528 OS's.

I have noticed that the xorg.conf file keeps being changed on reboot. If I set the driver to nvidia the next time I look it's back to vesa.

Thanks again
Back to top
View user's profile Send private message 
mill0001

Joined: 01 Feb 2007
Posts: 375
Location: "People's Republik of Kalifornia"

PostPosted: Tue 23 Aug 2011, 11:41    Post subject:  

Here's a copy of my xorg configs maybe they will help you get yours sorted out. Open them in geany and compare to what you have now.
xorg.tar.gz
Description 
gz

 Download 
Filename  xorg.tar.gz 
Filesize  2.36 KB 
Downloaded  377 Time(s) 
Back to top
View user's profile Send private message 
Peterm321

Joined: 29 Jan 2009
Posts: 225

PostPosted: Tue 23 Aug 2011, 13:36    Post subject:  

Quote:
I have noticed that the xorg.conf file keeps being changed on reboot. If I set the driver to nvidia the next time I look it's back to vesa.


AFAIK many versions of Puppy Linux were set up to change xorg.conf at each reboot. The rationale for this if I understand rightly, was that Puppy would be able to respond to hardware changes e.g. boot up automatically even if used as a live CD on another machine with different graphics hardware or even the same machine if the graphics card changed.

Nice in theory but neither Puppy Linux nor other versions of Linux I've tried take kindly to a machine with onboard AGP video with an addon PCI Nvidia GeForce graphics card. The latest versions of Linux kernel panic because the boot process does not see that while there is an AGP video device, it has been disabled due to the presence of the PCI Video. After disabling intel_agp and agpgart kernel modules the boot process still keeps resetting xorg.conf

I wrote my own script to start Xorg without any unwanted (in my view) checks for changes in graphics hardware.

You learn something new and in this forum I learned recently for the first time about the chattr command. Apparently you can use this command to make a file immutable. This might be a workaround; perhaps you can make xorg.conf immutable to stop it being changed. To make xorg.conf immutable on my system, the command is:

Code:
chattr +i /etc/X11/xorg.conf 


to reset it again [NB when you want to change it]:

Code:
chattr -i /etc/X11/xorg.conf 


You should be aware that the BusID under the section "Device" in xorg.conf can change from system to system.
Back to top
View user's profile Send private message 
xsilvergs

Joined: 20 Aug 2011
Posts: 12

PostPosted: Wed 24 Aug 2011, 13:50    Post subject:  

Peterm321, thanks for info, a useful command.

I'm still having trouble, using the xorg.conf shown below, I've made it immutable using the chattr command it boots to the prompt and wants me to use the xorgwizard but of course it won't work because I've chattr'ed it.

I've booted from disk and changed bits in xorg.conf but I can't get it to boot, can anyone see a mistake?

Code:
#Special base config file used in Puppy Linux.

# **********************************************************************
# Module section -- this  section  is used to specify
# which dynamically loadable modules to load.
# **********************************************************************
#
Section "Module"

# This loads the DBE extension module.

    Load        "dbe"     # Double buffer extension

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.
    SubSection  "extmod"
      Option    "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection

# This loads the font modules
#    Load        "type1"
#    Load        "freetype"

# This loads xtrap extension, used by xrandr
#   Load       "xtrap"

# This loads the GLX module (if present). xorg 7.4/5 need explicit disable to disable...
    Load    "glx" #LOADGLX

# This loads dri module (if present). 7.4 loads it by default, have to disable...
#Load       "dri" #LOADDRI
#    Disable "dri"

EndSection

# **********************************************************************
# Files section.  This allows default font paths to be set
# **********************************************************************

Section "Files"

# Multiple FontPath entries are allowed (which are concatenated together),
# as well as specifying multiple comma-separated entries in one FontPath
# command (or a combination of both methods)

    FontPath   "/usr/share/X11/fonts/misc/"
    FontPath   "/usr/share/X11/fonts/Type1/"
    FontPath   "/usr/share/X11/fonts/TTF/"

EndSection

# **********************************************************************
# Server flags section.
# **********************************************************************

Section "ServerFlags"

# Uncomment this to disable the <Crtl><Alt><Fn> VT switch sequence
# (where n is 1 through 12).  This allows clients to receive these key
# events.

#    Option "DontVTSwitch"

# Enables mode switching with xrandr
# There is a report that this can cause Xorg not to work on some
# video hardware, so default is commented-out...
# but i want to use it in xorgwizard so leave on...

    Option "RandR" "on"

# With this, Xorg won't talk to HAL to add evdev devices and you'll be back
# with the old Xorg behavior (pre-7.4)...

    Option "AutoAddDevices" "false"

# For no-Hal, kirk also suggests this...

#    Option "AllowMouseOpenFail" "true"

# Xorg 7.4, Ubuntu Jaunty, CTRL-ALT-BACKSPACE is disabled by default...

    Option "DontZap" "false"

EndSection

#everything past here is auto-generated by Puppy's Xorg Wizard...


Section "ServerLayout"
   Identifier     "X.org Configured"
   Screen      0  "Screen0" 0 0
   InputDevice    "Mouse0" "CorePointer"
   InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option      "XkbRules" "xorg"
   Option      "XkbModel" "pc102"
   Option      "XkbLayout" "gb" #xkeymap0
EndSection

Section "InputDevice"
   Identifier  "Mouse0"
   Driver      "mouse"
   Option       "Protocol" "IMPS/2" #mouse0protocol
   Option       "Device" "/dev/mouse"
   #Option      "Emulate3Buttons"
   #Option      "Emulate3Timeout" "50"
   Option      "ZAxisMapping" "4 5" #scrollwheel
EndSection

Section "Monitor"
   Identifier   "Monitor0"
   VendorName   "Monitor Vendor"
   ModelName    "Monitor Model"
   HorizSync    30-83
   VertRefresh  56-72
   #UseModes     "Modes0" #monitor0usemodes
   Option      "PreferredMode" "1920x1080"
   EndSection
   
Section "Modes"
   Identifier "Modes0"
   #modes0modeline0
EndSection

Section "Device"
   Identifier  "Card0"
   Driver      "nvidia" #card0driver
   VendorName  "nVidia Corporation"
   BoardName   "GTS450"
   BusID       "PCI:1:0:0"
EndSection

Section "Screen"
   Identifier "Screen0"
   Device     "Card0"
   Monitor    "Monitor0"
   DefaultDepth 24
#Option         "metamodes" "1280x1024_60 +0+0" #METAMODES_0
   Subsection "Display"
      Depth       24
      Modes       "1920x1080"
   EndSubsection
EndSection

#PuppyHardwareProfile=NVIDIASyncmaster


Thanks
Back to top
View user's profile Send private message 
mill0001

Joined: 01 Feb 2007
Posts: 375
Location: "People's Republik of Kalifornia"

PostPosted: Fri 26 Aug 2011, 01:55    Post subject:  

Try typing nvidia-xconfig at the prompt and then xwin. (oops before you do that unchattr the file.)
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [24 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Hardware » Video
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1146s ][ Queries: 12 (0.0125s) ][ GZIP on ]