Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 23 Sep 2019, 11:55
All times are UTC - 4
 Forum index » House Training » Beginners Help ( Start Here)
Atheros 5001 wi-fi & Puppy
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 2 of 2 [27 Posts]   Goto page: Previous 1, 2
Author Message
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Wed 14 Sep 2011, 05:03    Post subject:  

whisperwalker, I'm not trying to push you. I just thought that the rfkill-enable commands I supplied might be an easy fix. Since they have obviously failed, the problem now requires more extensive investigation ...

... if you want to continue, I think an important diagnostic step would be to run this command -
Code:
rfkill list

and report the result.
I should mention that the rfkill command will only work if you have installed the rfkill-upgrade dotpet, as we discussed earlier.
Back to top
View user's profile Send private message 
whisperwalker

Joined: 24 Aug 2011
Posts: 17
Location: USA

PostPosted: Wed 14 Sep 2011, 08:57    Post subject: rfkill_list command
Subject description: report
 

tempestuous, thanks for your persistence. Smile Ran the rfkill list, hope I'm doing this correctly.
[/img]
rfkill_list-528.jpg
 Description   
 Filesize   51.16 KB
 Viewed   545 Time(s)

rfkill_list-528.jpg

Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Wed 14 Sep 2011, 09:18    Post subject:  

OK, your rfkill results are all clear.

The next step is to see the output of the "dmesg" command, but this will be verbose, so the best way is to run these three commands -
Code:
cd /root
dmesg > dmesg.txt
gzip dmesg.txt

Now you will have a file in /root called dmesg.txt.gz which you can attach to the forum.
Back to top
View user's profile Send private message 
whisperwalker

Joined: 24 Aug 2011
Posts: 17
Location: USA

PostPosted: Wed 14 Sep 2011, 12:25    Post subject: dmesg
Subject description: gzip results post
 

tempestuous, hope this is done correctly, I'm on the steep side of the linux learning curve Smile thanks again
dmesg.txt.gz
Description 
gz

 Download 
Filename  dmesg.txt.gz 
Filesize  8.96 KB 
Downloaded  149 Time(s) 
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Thu 15 Sep 2011, 03:13    Post subject:  

From your dmesg output -
Quote:
ath: EEPROM regdomain: 0x65
ath: EEPROM indicates we should expect a direct regpair map
ath: Country alpha2 being used: 00
...
wlan0: direct probe to AP 00:0c:e5:4f:a0:94 timed out

This indicates a problem with reading the eeprom/setting country code, and this same problem has just been reported with the ath9k driver in the last week or so! This is eerie, because in the full year that Puppy 5.1.x-series has been available, no one has reported such a problem up until now.

Anyway, until the ath5k driver is completely updated in newer kernel versions, your only solution for now is to use a specially patched version of the ath5k driver which will allow you to manually specify your country-code.

I just posted the ath5k-set-country driver dotpet here -
http://www.murga-linux.com/puppy/viewtopic.php?p=563940#563940
Read the instructions in the previous post ... but some important tips:
- I think the rfkill-upgrade dotpet will conflict with the modified driver, so delete your pupsave file and start afresh.
- if you happen to be in the USA, your /etc/modprobe.d/ath5k.conf file should be -
Code:
options ath5k override_eeprom_regdomain=33608

then reboot, and run the Network Wizard.
If no success, power-cyle your wifi router and try again.

If still no success, run the "dmesg" command to look for clues.
Back to top
View user's profile Send private message 
whisperwalker

Joined: 24 Aug 2011
Posts: 17
Location: USA

PostPosted: Sat 17 Sep 2011, 15:46    Post subject: Country Code
Subject description: 1st attempt failed; dmesg
 

tempestuous, completed procedure, ran network wizard, unable to connect. power cycled router, ran network wizard - still unable to connect. Attached is the dmesg file - thanks again for your help Smile
dmesg.txt.gz
Description 
gz

 Download 
Filename  dmesg.txt.gz 
Filesize  8.7 KB 
Downloaded  156 Time(s) 
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Sun 18 Sep 2011, 03:02    Post subject:  

whisperwalker wrote:
completed procedure, ran network wizard, unable to connect.

At the outset, it would be really helpful if you could tell us what country you're in. I only used "USA" as an example.

Your dmesg results certainly show progress -
Code:
ath5k phy0: DANGER! You're overriding EEPROM-defined regulatory domain.
ath5k phy0: Your card was not certified to operate on the domain you choosed.
ath5k phy0: This might result in a violation of your local regulatory rules.
ath5k phy0: Do not ever do that unless you really know what you do!
ath: EEPROM regdomain: 0x8348
ath: EEPROM indicates we should expect a country code
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a

Are you really in the USA? If so, the error message "Your card was not certified to operate on the domain you choosed." is a concern.

What about the wifi router? Was it purchased in some other country than the one you're in?
Also I'm hoping that you have disabled all encryption at your wifi router. Encryption is only going to confuse the issue during testing.
Back to top
View user's profile Send private message 
whisperwalker

Joined: 24 Aug 2011
Posts: 17
Location: USA

PostPosted: Sun 18 Sep 2011, 12:35    Post subject: USA
Subject description: wi-fi router & present location
 

tempestuous, USA current location; wi-fi router purchased USA - no encryption, MAC address restricted. Thanks again, Smile
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Tue 20 Sep 2011, 10:33    Post subject:  

I'm running out of ideas here.
dmesg appears quite healthy - but the ath5k wifi adapter and the wifi router are failing to associate with each other.
Since we have eliminated the issue of channel/frequency compatibility, I'm now at a loss as to what else could be wrong.

You could possibly check the logs of your wifi router to obtain clues.

whisperwalker wrote:
MAC address restricted.

Could this be blocking the wifi adapter? Run this command to check your "wlan0" MAC address -
Code:
ifconfig -a

then check that the wifi router allows that MAC address ...
or to be certain, temporarily disable MAC address restrictions.
Back to top
View user's profile Send private message 
whisperwalker

Joined: 24 Aug 2011
Posts: 17
Location: USA

PostPosted: Wed 21 Sep 2011, 16:20    Post subject: MAC restriction lifted - unable to connect
Subject description: wi-fi router
 

tempestuous, performed your instructions for address checking and MAC filtering, it's the correct address. Turned MAC filtering off. Totally open wi-fi network and still unable to connect with Puppy. Sad
Mint 10 is installed on this machine and it connects immediately. Began wondering if it's a Mint thing, (I'm still a newbie). So I burnt an iso of Mint 11, (w/o the codecs), for a live cd Mint test. It took a while to boot, 640mb or so, but it connected immediately also. So that got me thinking it's a Mint thing. Confused
Really appreciate all your help with this riddle, but if it's not to be, that's cool Cool thanks again, wm whisperwalker Smile
Back to top
View user's profile Send private message 
tempestuous

Joined: 10 Jun 2005
Posts: 5472
Location: Australia

PostPosted: Thu 22 Sep 2011, 03:38    Post subject:  

It looks like the ath5k driver in Puppy 5.2.8 just doesn't play well with your wifi device, and I suspect the only solution is to move up to a more modern kernel version, which will have a more recent version of the ath5k driver.

Your results with Linux Mint add weight to this idea, since Mint 10 and 11 both have a more recent kernel than Puppy 5.2.8 :
Puppy 5.2.8 = kernel 2.6.33
Mint 10 = kernel 2.6.35
Mint 11 = 2.6.38

The good news is that the upcoming Puppy 5.2.9 will have a 2.6.37 kernel, so a (likely) Puppy-solution for you is to try the Luci-529 beta; "Three Headed Dog" available here -
http://www.murga-linux.com/puppy/viewtopic.php?t=70736
Back to top
View user's profile Send private message 
whisperwalker

Joined: 24 Aug 2011
Posts: 17
Location: USA

PostPosted: Thu 22 Sep 2011, 11:32    Post subject: Success! 529 3-Headed Puppy Fixes Atheros 5001 issue
Subject description: Problem Solved - Instant Connection
 

tempestuous, Your kernel insight is spot-on! Very Happy 529 connected immediately on this old Sony machine! Very Happy Ten-thousand thank you's! Very Happy
529wifi-connect.jpg
 Description   
 Filesize   105.77 KB
 Viewed   431 Time(s)

529wifi-connect.jpg

Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 2 of 2 [27 Posts]   Goto page: Previous 1, 2
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Beginners Help ( Start Here)
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0625s ][ Queries: 12 (0.0207s) ][ GZIP on ]