Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 01:46
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Fatdog64-520 Final
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 11 Posts_count   Goto page: 1, 2, 3, ..., 9, 10, 11 Next
Author Message
kirk

Joined: 11 Nov 2005
Posts: 1437
Location: florida

PostPosted: Sat 03 Sep 2011, 22:40    Post_subject:  Fatdog64-520 Final
Sub_title: All 64bit
 

Fatdog64-520 has been released. Lots of improvements!

Go here:

http://distro.ibiblio.org/pub/linux/distributions/fatdog/web/

And click the Latest link for all the changes since 511.

Big thanks to all who tested. Please note that we now have a bug tracker. You'll find a link to it in the FAQs on the Firefox home page.

IF YOU TESTED ANY 520beta/RC DELETE ALL OF IT'S FILES, INCLUDING SFS AND SAVE FILES..


Edit: We left tap to click on for those using a laptop touchpad. To turn it off, go to Setup - Adjust Touch Pad and then on the tapping tab change Tap Time to zero.

Edited_time_total
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Sun 04 Sep 2011, 01:34    Post_subject: Re: Fatdog64-520 Final
Sub_title: All 64bit
 

kirk wrote:
Lots of improvements!


Congratulations to Kirk and JamesBond
Have provided a link on the wiki
http://puppylinux.org/wikka/HomePage

JamesBond has also compiled this:
Quote:
I've uploaded a 64-bit pjsua here:

website: http://mydrive.ch
userid: dotpet@puppyshare
password: puppylinux

(under fatdog64 folder)


and I am just about to
replace this file (use the same name) to test
/usr/local/psip/pjsua_custom_03-0.9.0

to see if we can get PSIP2 working in Fatdog . . .
http://puppylinux.org/wikka/Psippy

Thanks guys
Have not used Fatdog in a while
Looking forward to trying it Smile

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
Sage

Joined: 04 Oct 2005
Posts: 4833
Location: GB

PostPosted: Sun 04 Sep 2011, 01:36    Post_subject:  

Really good news and thanks to you both.
Have been having problems with recent releases of FF in Mint and some other distros. Other folks seem to be reporting the same (not only this Forum). Opera and Midori seem to function even when I've got FF running and overloaded (deliberately!) with open tabs and windows. What was the reasoning for Jemimah to switch to Midori? Did she ever give a full expalantion? Was it a netbook-only matter?
Boot-up is very very slow with a long detente before the DE emerges. Still getting unacceptable grief in res. selection, resetting xorgwiz with SiS chipset. Definitely something amiss - one of the outstanding features of all the alphas/betas/RCs was the speed - that is now not only lost but it's slower than all the 32bit derivatives on the same machine.
I imagine the next step will be to reduce the .iso complement?!
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Sun 04 Sep 2011, 05:13    Post_subject:  

The Iblio server is a bit slow Sad
Any torrents or mirrors welcome . . .
Should this be released as our first official 64bit Puppy? I hope so . . .

FD64-520 went straight to desktop, connected to Ethernet
and I was in and browsing. Laughing
That is the way we like it!
Hopefully Icyos will do a review . . .
http://www.youtube.com/user/icyos

Do remember (I forgot again 'fatdog pfix=ram', when you want a clean boot up - most Puppys use 'puppy pfix=ram')

Had a problem importing my bookmarks again
I blame the Fox . . .
In the end I opened my saved HTML as a web page

In order to use the PPM (which was unpopulated)
I had to click the 'Configure Package Manager'

http://puppylinux.org/wikka/Fatdog64
Fatdog is a nice piece of work.
I wanted to get PSIP2 working in it but I need
the 32 bit code (being developed) + the 64bit compile (available).
So that would require a bit of time . . . Cool

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
jamesbond

Joined: 26 Feb 2007
Posts: 2232
Location: The Blue Marble

PostPosted: Sun 04 Sep 2011, 05:39    Post_subject:  

Sage, you have 4 options:
a) pfix=vesa
b) pfix=vesa nomodeset
c) pfix=vesa,nox and once you're in terminal, run xorgwizard-old
d) pfix=vesa,nox nomodeset and once you're in terminal, run xorgwizard-old
Any

Ed,
Your bookmark problem is probably access issue - it's probably "spot" can't access your bookmark file. Use Rox to go to that bookmark file, then select "Properties", and make sure that "World" has read permission. Of - if youcan't be bothered, edit /usr/local/bin/defaultbrowser and change that to "firefox" instead of "firefox-spot".

cheers!

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4833
Location: GB

PostPosted: Sun 04 Sep 2011, 06:00    Post_subject:  

Many thanks for your prompt suggestions, James.
I guess it's the strange combo of SiS chipset + cr*p Dell monitor. I think it sets up VESA by default without pfix=vesa? Problem is, every other 32/64 distro, Puppy & others, finds 1024x768 without this hassle. Either way, I am unable to get the higher res. by any subterfuge now, including setting it impossibly high on monitor capability and throttling back to 1024x768, which used to work on an earlier RC.
There is another weird and worrying feature now. The video DE never starts spontaneously - it holds at a flashing cursor, not prompt, after booting. Hitting 'x', (perhaps other alphanumerics? but not 'Enter') yields the desktop???
sr0 still not 'unmounting' from right-click on icon - needs to enter Pmount/mount/close panel/unmount !
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2185
Location: Ontario Canada

PostPosted: Sun 04 Sep 2011, 06:49    Post_subject: Fatdog64-520 Final  

I did a manual frugal install of 520 final.
Installed devx + nvidia-280.13-for-520-final.pet

Sun 4 Sep 2011 Operating System: Fatdog64-520 Linux 3.0.3
0.0 VGA compatible controller: nVidia Corporation Device 1082 (rev a1)
oem: NVIDIA product: GF110 Board - 12630002 Chip Rev

X Server: Xorg Driver: nvidia: vendor=NVIDIA Corporation
X.Org version: 1.9.5
dimensions: 1920x1080 pixels (513x292 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTX 560 Ti/PCI/SSE2
OpenGL version string: 4.1.0 NVIDIA 280.13

Intel(R) Core(TM) i7-2600 CPU
Core 0: 1600 1: 1600 2: 1600 3: 1600 4: 1600 5: 1600 6: 1600 7: 1600 MHz

# glxgears
104363 frames in 5.0 seconds = 20872.547 FPS
106346 frames in 5.0 seconds = 21269.037 FPS
106527 frames in 5.0 seconds = 21305.326 FPS

No problems here, thanks

edit: I've been running fd520 final for a few hours and no problems so
far, the wallpaper is a photo of our cat and she wants to go out and
play with the chipmonk that's watching from the safe side of the door
Smile
fdscrn.jpg
 Description   
 Filesize   178.49 KB
 Viewed   5560 Time(s)

fdscrn.jpg


Edited_time_total
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15122
Location: Paradox Realm

PostPosted: Sun 04 Sep 2011, 06:53    Post_subject:  

Quote:
Ed,
Your bookmark problem is probably access issue - it's probably "spot" can't access your bookmark file.


Makes sense. Cool
Fatdog uses the security of its own downloading folder . . .
OK will try later when back in 64bit world
Would just moving the bookmarks to the spot download directory be sufficient or must permissions still be altered?

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
rcrsn51


Joined: 05 Sep 2006
Posts: 9373
Location: Stratford, Ontario

PostPosted: Sun 04 Sep 2011, 08:07    Post_subject:  

Sage wrote:
Definitely something amiss - one of the outstanding features of all the alphas/betas/RCs was the speed - that is now not only lost but it's slower than all the 32bit derivatives on the same machine.

I have not experienced this. There has been no change in speed.
Back to top
View user's profile Send_private_message 
Sage

Joined: 04 Oct 2005
Posts: 4833
Location: GB

PostPosted: Sun 04 Sep 2011, 10:11    Post_subject:  

chacun_à_son_goût...
Back to top
View user's profile Send_private_message 
Fishy

Joined: 26 Jan 2006
Posts: 205

PostPosted: Sun 04 Sep 2011, 13:48    Post_subject: Calibre Install Issues Continue  

Followed instructions and installed dbus from package manager. As you can see from the screen shot it says dbus installed incorrectly. Not sure what to do about incorrect installation.

I have changed/removed spot from default browser and firefox in /usr/share/applications. Can I remove the default download folder and spot as I have one outside of save file? any other things to do to get it working like a standard puppy.

All in all seems to be working fine, looking forward to trying to fix the Fatdog install on his AMD socket FM1 system.

Thanks for all the hard work Very Happy
Calibre dbus.png
Description 
png

 Download 
Filename  Calibre dbus.png 
Filesize  158.2 KB 
Downloaded  604 Time(s) 
Back to top
View user's profile Send_private_message 
jamesbond

Joined: 26 Feb 2007
Posts: 2232
Location: The Blue Marble

PostPosted: Sun 04 Sep 2011, 20:01    Post_subject:  

Sage,
520 went under a couple of kernel changes - some of the betas used 2.6.38.8 and 2.6.39.4, the 520-rc uses 2.6.39.4, 520-rc2 uses 3.0.3 (same as final), and kirk optimised the settings on each iteration. It's possible that it could cause slowdown in your particular configuration - but the rest of us don't feel it (definitely not me or kirk or rcrsn51, we don't feel the slowdown).

I'll leave the graphics question to kirk when he's back. It's odd though that you need to press "x" before the DE starts, I've never encountered any of those issues. That being said, you're running in full install, I suppose?

Fishy, just run this:
Code:
dbus-uuidgen > /var/lib/dbus/machine-id
and you're good to go.
You can remove "/root/spot/Downloads" but please don't remove "/root/spot" as it's used not only by firefox but others.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
Fishy

Joined: 26 Jan 2006
Posts: 205

PostPosted: Sun 04 Sep 2011, 20:39    Post_subject: Dbus Issue  

Tried dbus-uuidgen > /var/lib/dbus/machine-id and received no such file or directory> Confused

But having fun, thanks.
Back to top
View user's profile Send_private_message 
jamesbond

Joined: 26 Feb 2007
Posts: 2232
Location: The Blue Marble

PostPosted: Sun 04 Sep 2011, 21:04    Post_subject:  

ah yes, the folder of course. I forgot to tell you before you run that uuidgen command you need to create the folder first
Code:
mkdir -p /var/lib/dbus

cheers!

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2185
Location: Ontario Canada

PostPosted: Sun 04 Sep 2011, 21:54    Post_subject: Fatdog64-520 Final  

I did a manual frugal install of fd520 final.
Installed devx + ati-catalyst-11.8-3.0.3.pet

Sun 4 Sep 2011 Operating System: Fatdog64-520 Linux 3.0.3
0.0 VGA compatible controller: ATI Technologies Inc Redwood PRO [Radeon HD 5500 Series]
oem: ATI ATOMBIOS product: REDWOOD 01.00

X Server: Xorg Driver: fglrxdrm: vendor=FireGL - ATI Technologies Inc.
X.Org version: 1.9.5
dimensions: 1920x1080 pixels (508x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5570
OpenGL version string: 4.1.11005 Compatibility Profile Context

AMD Phenom(tm) II X4 810 Processor
Core 0: 800 1: 800 2: 800 3: 800 MHz
# glxgears
35287 frames in 5.0 seconds = 7057.250 FPS
39300 frames in 5.0 seconds = 7859.910 FPS
39299 frames in 5.0 seconds = 7859.720 FPS

I installed Window Maker (just because I could I guess) and it's working well
with lxpanel.

The opensource video driver wasn't working 100%, some screens were
blurry, but the ati pet is working well.
fdscrn.jpg
 Description   
 Filesize   167.58 KB
 Viewed   5588 Time(s)

fdscrn.jpg

Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 11 Posts_count   Goto page: 1, 2, 3, ..., 9, 10, 11 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0922s ][ Queries: 12 (0.0044s) ][ GZIP on ]