Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 18 Dec 2014, 05:30
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Projects
Slacko B2
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 16 of 16 Posts_count   Goto page: Previous 1, 2, 3, ..., 14, 15, 16
Author Message
jpeps

Joined: 31 May 2008
Posts: 3220

PostPosted: Sun 18 Sep 2011, 13:55    Post_subject: libgpm  

libgpm is needed for apps like vim, so you might want to include it. I copied one from lucid:
libgpm-so.2.tar.gz
Description 
gz

 Download 
Filename  libgpm-so.2.tar.gz 
Filesize  17.34 KB 
Downloaded  290 Time(s) 
Back to top
View user's profile Send_private_message 
majorfoo

Joined: 07 Mar 2011
Posts: 446
Location: Wish I knew

PostPosted: Sun 18 Sep 2011, 18:03    Post_subject:  

01micko wrote:
Abiword 2.9.1

UUgghhh.. what a mission.. Rolling Eyes

Tried Ted, quickly discounted Ted.. it hasn't been developed in over 2 years so isn't compatible with the newer gtk/gdk/cairo/png libs. I got it to run, too many critical errors, plus it only opens .rtf.

Now abiword seems to depend on boost c++ libraries. There is a configure option "--with-boost=no" but it seems boost is now part of the core of abiword.. So with that I compiled the opendocument plugin which requires boost anyway. I did this very fastidiously! Every error in make I added only the required part of boost, it's still a 15M installed package (better than over 100M Rolling Eyes Surprised Shocked ).. thankfully none of the shared libs are needed so this is only a requirement for the devx, I got the compressed size down to under 1M. Yes, all this for a second rate WP. There is no real alternative considering size. As far as my testing goes, it opens .rtf, .doc, .odt, .abw that's all I use, and I don't use abiword anyway.

Here it is..

Abiword 2.7M



found minor problem when tried to run abiword. It would not open from desktop icon. There is no defined defaultwordprocessor in /usr/local/bin Once I added this, it worked great
Notice you have fixed this in Slacko B3

majorfoo
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 16 of 16 Posts_count   Goto page: Previous 1, 2, 3, ..., 14, 15, 16
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Projects
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0460s ][ Queries: 12 (0.0081s) ][ GZIP on ]