Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sun 26 Oct 2014, 03:24
All times are UTC - 4
 Forum index » Advanced Topics » Puppy Derivatives
Dpup Exprimo 5.X.3.1.10.3 SMP multicore optimized version
Moderators: Flash, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 70 Posts_count   Goto page: 1, 2, 3, ..., 68, 69, 70 Next
Author Message
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 16 Sep 2011, 16:24    Post_subject:  Dpup Exprimo 5.X.3.1.10.3 SMP multicore optimized version
Sub_title: 3.1.10 kernel, 31.3.2012 build, latest woof2 used, JWM and E17 wm
 

Check md5sum of download before posting bugs !

Download link: http://www.smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X31103/

Kernel sources (not changed): http://www.smokey01.com/pemasu/Kernel_sources/kernel-3.1.10-fixed-aufs/

Kernel 3.1.10, core 2 and up optimized, SMP, hyperthreading, multicore-scheduler, hibernation

Firefox 11 with Fireftp, Adblock and Flashblock preinstalled.

New version presents Uget-1.8 and aria2c-1.14.2 which as couple handles torrent downloads:
Aria2c is powerful downloader itself, you can use it easily from commandline:
http://aria2.sourceforge.net/
http://sourceforge.net/apps/trac/aria2/wiki/UsageExample

Uget-1.8:
Quote:
Support for Torrent and Metalink file (with aria2 plug-in).
Add new plug-in that support aria2 version >= 1.10.

It might be that there isn`t much need for Transmission in the future and I can shave some weight off, alltough slim and small is not my first priority.

New apps, not many: aria2-1.14.2, rox right-left click MultiCopyPaste, libXxf86misc for Xscreensaver etc..

Updates: Uget-1.8, Pmusic-2.5.2 with track info fix, delayedrun script new hack, so that Flash download offer stays in queue until net connection has been established, pnethood-0.6.8.9 by Shinobar, tempicon-0.08. Broadcom wireless wl driver added, thanks Peebee.
Exprimo repo updated with google-talk-plugin and new Virtual box sfs...

Dpup 5.X.3.1.10.3 has been uploaded
Woof used: [8974b31b2c] Leaf: version used to build wary/racy 5.2.91 (5.3RC2)
-------> http://bkhome.org/fossil/woof2.cgi/timeline

For live CD...there is now for booting grub4dos menu by grldr, menu.lst and splash.xpm.

Pet installation and PPM uses Shinobar`s recent petget-20120331.pet with dpup modified deps_check.sh. Overwriting warning and missing deps downloading suggestion now implemented. Classic UI only.

Getflash fixed, no more changed permissions or ownerships. Also ipv4 only feature added to the scripts. James C should be happy.

Lxterminal now the default console....so that gtk-youtube-viewer right click panel works now. You can watch the added and queued youtube videos now with right click. Rxvt-unicode ie urxvt is still there. Removing all the script dependencies for urxvt is not my priority. Vte preinstalled so you can add other vte using terminals easily.

Gnome-Mplayer-1.0.6b1 and Gecko-Mediaplayer-1.0.6b1. Firefox 11
Postscript files opens now with left click and has also right click choice to open. They have also exportable a4paper definition in /etc/profile.d/a4paper.
Gmeasures added for unit conversion, Gplanner with preview (when you have created something to preview) fixed, xosd - osd_cat patched - recompiled, vbetool added and volume scripts added.
Small fixes which I dont remember anymore....

Check md5sum of download before posting bugs !

Download link: http://www.smokey01.com/pemasu/DpupSqueeze5X/DpupExprimo5X31103/

Kernel sources (not changed): http://www.smokey01.com/pemasu/Kernel_sources/kernel-3.1.10-fixed-aufs/
DpupEXprimo5X10.2SMP.jpg
 Description   
 Filesize   164.61 KB
 Viewed   11584 Time(s)

DpupEXprimo5X10.2SMP.jpg

dpup-exprimo-5X10.jpg
 Description   
 Filesize   42.8 KB
 Viewed   14102 Time(s)

dpup-exprimo-5X10.jpg


Edited_times_total
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5871
Location: Kentucky

PostPosted: Fri 16 Sep 2011, 17:02    Post_subject:  

Downloading now.I'll give it a good test run on this quad-core....probably make a multi-session dvd.
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2131
Location: Ontario Canada

PostPosted: Fri 16 Sep 2011, 17:50    Post_subject: Dpup Exprimo 5.X.7 SMP multicore optimized version  

Manual frugal install to gateway desktop.
Installed mesa and the proprietary ati video driver.

Fri 16 Sep 2011 Operating System: Dpup Exprimo SMP-5.X.7 Linux 2.6.39.4
0.0 VGA compatible controller: ATI Technologies Inc Redwood PRO [Radeon HD 5500 Series]
oem: ATI ATOMBIOS product: REDWOOD 01.00

X Server: Xorg Driver: vesa
X.Org version: 1.7.7
dimensions: 1920x1080 pixels (507x285 millimeters)
depth of root window: 24 planes

direct rendering: Yes
server glx vendor string: ATI
server glx version string: 1.4
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 5570
OpenGL version string: 4.1.11005 Compatibility Profile Context

AMD Phenom(tm) II X4 810 Processor
Core 0: 2592 1: 2592 2: 2592 3: 2592 MHz

# glxgears
38164 frames in 5.0 seconds = 7632.698 FPS
39851 frames in 5.0 seconds = 7970.093 FPS
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Fri 16 Sep 2011, 17:52    Post_subject:  

Billtoo. Great ! Kernel source sfs usability test done. That is good news.

Edit. Your status info shows that you use vesa driver though.
Back to top
View user's profile Send_private_message 
Billtoo


Joined: 07 Apr 2009
Posts: 2131
Location: Ontario Canada

PostPosted: Fri 16 Sep 2011, 19:17    Post_subject:  

pemasu wrote:
Billtoo. Great ! Kernel source sfs usability test done. That is good news.

Edit. Your status info shows that you use vesa driver though.


That vesa shows up in some other pups too, it's wrong because hardware acceleration is working, I already played a level of nexuiz and you can't do that with the vesa driver.

I'm not sure but I think maybe the tv tuner card (el cheapo) is causing the error.
Back to top
View user's profile Send_private_message 
James C


Joined: 26 Mar 2009
Posts: 5871
Location: Kentucky

PostPosted: Fri 16 Sep 2011, 19:38    Post_subject:  

Haven't had a chance to do much exploring yet but.......Dpup Exprimo 5.X.7 live multi-session dvd.Sound,internet and screen resolution all working on initial boot.


Dpup Exprimo SMP, version 5.X.7 on Fri 16 September 2011
Chip description:
d.0 VGA compatible controller
nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2)
oem: NVIDIA
product: MCP61 - mcp61-86 Chip Rev

X Server: Xorg
Driver used: nv

X.Org version: 1.7.7
dimensions: 1368x768 pixels (414x232 millimeters)
depth of root window: 24 planes


-Computer-
Processor : 4x AMD Athlon(tm) II X4 620 Processor
Memory : 2854MB (173MB used)
Operating System : Unknown distribution
User Name : root (root)
Date/Time : Fri 16 Sep 2011 06:34:37 PM GMT-8
-Display-
Resolution : 1368x768 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA NVidia
Dpup Exprimo 5.X.7.png
 Description   
 Filesize   40.97 KB
 Viewed   14041 Time(s)

Dpup Exprimo 5.X.7.png


Edited_time_total
Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 16 Sep 2011, 20:04    Post_subject:  

5x7 usual pfix=ram install with broadcom pet. unable to load wl driver. looked at bootloader for loaded modules and only noticed a bcm...something. perhaps it should get blacklisted?
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Fri 16 Sep 2011, 20:18    Post_subject:  

Working great with all of my normal software, as usual. No problem installing Nvidia 280.13.

I hope that you are considering the new 3.0.4 kernel for this experimental version.

Thank you for sharing this,
Jim
image-1.jpg
 Description   
 Filesize   50.02 KB
 Viewed   13900 Time(s)

image-1.jpg

Back to top
View user's profile Send_private_message 
jim3630


Joined: 13 Feb 2011
Posts: 792
Location: Northern Nevada

PostPosted: Fri 16 Sep 2011, 21:35    Post_subject:  

made wifi connection with backup ar9170usb. reading the attached report noted could not find wl driver despite installed broadcom pet
sys-info-110916.gz
Description 
gz

 Download 
Filename  sys-info-110916.gz 
Filesize  10.61 KB 
Downloaded  517 Time(s) 
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 17 Sep 2011, 02:02    Post_subject:  

Jim3630. Two things. First is that my new kernel has new broadcom drivers included.
http://linuxwireless.org/en/users/Drivers/brcm80211
These drivers needs also firmware to be downloaded and installed from above link. Those firmwares are not included because the git.kernel.org is down. Something has happened in kernel.org.

Secondly. I forgot to add depmod -a execution command included pinstall.sh. You can do that execution in console yourself. Reboot.

Next thing. It is possible that you need to blacklist those new broadcom drivers also, not sure about that, you need to experiment.
The drivers are: brcmsmac and brcmfmac
If it is so, I can update the /etc/init.d/BC-wl script to rmmod them also.

I have reuploaded the broadcom pet so that it has now that pinstall.sh included which performs depmod -a.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 17 Sep 2011, 02:08    Post_subject:  

Jim1911. Thank you of the feedback and that you also tested kernel source sfs with proprietary Nvidia.

About 3.04 kernel. Not yet. Barry has stated that there are scripts in puppy that expects 2.6 kernel. I dont know implications of that and I dont know what scripts expect that.
So...because I build with woof, I wont yet compile 3.x kernels.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 17 Sep 2011, 03:59    Post_subject:  

Git.kernel.org is down, but I got from Tempestuous the firmware package for brcm80211. The new broadcom driver is for newer chips: http://linuxwireless.org/en/users/Drivers/brcm80211#Supported_Chips.
For older broadcom devices, this driver could be even nuisance if it tries to load without working.

Anyway...The firmware pet is attached. If somebody knows, that he will need this new driver, he will need this firmware package also.
It installs the firmwares to the usual location in /lib/firmware. Reboot is probably needed.
brcm80211-firmware-0.0.1.pet
Description 
pet

 Download 
Filename  brcm80211-firmware-0.0.1.pet 
Filesize  219.62 KB 
Downloaded  521 Time(s) 
Back to top
View user's profile Send_private_message 
Jim1911

Joined: 19 May 2008
Posts: 2457
Location: Texas, USA

PostPosted: Sat 17 Sep 2011, 11:44    Post_subject:
Sub_title: 4fs save file will not mount
 

Hi pemasu,

Just a minor problem, Dpup Exprimo 5.x.7 will not mount a 4fs save file when clicked. It mounts 3fs save files properly.

It would be great if a choice of 4fs save files were offered. Barry did offer it for a brief period, however, there were problems so rather than correct the problem he dropped that option. TazOC did solve the problem with 4fs save files and his LHP does offer that option. The 4fs save files on LHP have been faster than both 2fs and 3fs and are very reliable.

Thanks,
Jim
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Sat 17 Sep 2011, 11:48    Post_subject:  

Jim1911. Thanks for the 4fs savefile info. I keep it in mind and I try to dig out why it was dropped out. I remember the debate only vaguely.
Back to top
View user's profile Send_private_message 
DaveS


Joined: 09 Oct 2008
Posts: 3726
Location: UK

PostPosted: Sat 17 Sep 2011, 12:40    Post_subject:  

runs beautifully on my dual core laptop but hardinfo/sensors has no output. CPUtemp is fine.
_________________
Spup Frugal HD and USB
Root forever!
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 70 Posts_count   Goto page: 1, 2, 3, ..., 68, 69, 70 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Puppy Derivatives
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1172s ][ Queries: 12 (0.0344s) ][ GZIP on ]