Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 21 Apr 2014, 08:38
All times are UTC - 4
 Forum index » House Training » Bugs ( Submit bugs )
Racy Puppy 5.2.2 Final, 18 Nov. 2011
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 24 of 33 [487 Posts]   Goto page: Previous 1, 2, 3, ..., 22, 23, 24, 25, 26, ..., 31, 32, 33 Next
Author Message
aarf

Joined: 30 Aug 2007
Posts: 3620
Location: around the bend

PostPosted: Sun 20 Nov 2011, 04:04    Post subject:  

racy fixed no more disappearing windows
starts ok when pupsave is there.
lupufy (may be superfluous by adds may good things)

of course you also need /mnt/sdb3/opera-next-11.50-1040.i386.linux with latest libflashplayer.so parked on that same (sdb3) partition.

at prompt
Code:
#startx openbox

may have to start
Code:
#fbpanel
only once.
fixed.jpg
 Description   
 Filesize   16.35 KB
 Viewed   2503 Time(s)

fixed.jpg


_________________

ASUS EeePC Flare series 1025C 4x Intel Atom N2800 @ 1.86GHz RAM 2063MB 800x600p ATA 320G
_-¤-_

<º))))><.¸¸.•´¯`•.#.•´¯`•.¸¸. ><((((º>
Back to top
View user's profile Send private message Visit poster's website 
mave

Joined: 02 Apr 2009
Posts: 130
Location: Germany

PostPosted: Sun 20 Nov 2011, 14:52    Post subject: Seamonkey 2.3.1 language file
Subject description: ...not available
 

Hi,

I tried installing (german) language file for Seamonkey 2.3.1 in Racy, but on mozila-project the links are broken. Knows anybody a running source to get the *.xpi file(s)?

mave
Back to top
View user's profile Send private message 
broomdodger


Joined: 09 May 2008
Posts: 269
Location: Santa Cruz, CA

PostPosted: Mon 21 Nov 2011, 11:59    Post subject: cmus Error: libavformat.so.52  

racy522
frugal manual

cmus is an amazing music player.
http://cmus.sourceforge.net/

Note: current version is:
cmus-v2.4.2.tar.bz2, released 24.07.2011
Tried to compile, but pulse audio missing and
I do not know how to install it.

So... installed cmus-2.3.3-w5.pet from PPM.

Starting cmus:
cmus: Error: libavformat.so.52: cannot open shared object file: No such file or directory

This is installed:
/usr/lib/libavformat.so.53
/usr/lib/libavformat.so.53.13.0

Checked wary514 and it has libavformat.so.52
cmus runs with NO error.

-Bill
Back to top
View user's profile Send private message 
broomdodger


Joined: 09 May 2008
Posts: 269
Location: Santa Cruz, CA

PostPosted: Mon 21 Nov 2011, 12:25    Post subject: found cmus 2.4.2 pet  

I found cmus 2.4.2 pet:
http://www.smokey01.com/coolpup/
cmus-2.4.2-w-20111002.pet

It installs without errors.
More later.
Back to top
View user's profile Send private message 
seacyd

Joined: 14 Nov 2011
Posts: 25
Location: Austria

PostPosted: Mon 28 Nov 2011, 02:00    Post subject: claws-mail for racy
Subject description: Make Claws-Mail 3.7.10 work for puppy
 

Thanks for all this Puppy work! I enjoy using it on my old computer (which I work with daily).

Claws-Mail is an essential piece of software for me. I tried to get the latest version work. So far, no success. Before I will describe the installation steps I tried, isn't is easy for someone who compiles the Puppy if there is a T2 package available of claws-mail ( http://www.t2-project.org/packages/claws-mail.html )?

How can this be achieved to have an update Claws-Mail working with Puppy? If there would be easy steps to follow (mentioning really all the steps including any tiny command, I would be happy to learn to do it as well. )

With Lucy based Puppies I installed the debs and the libraries to make claws-mail work. With Racy I get the error message:

claws-mail: /lib/libc.so.6: version `GLIBC_2.11' not found (required by claws-mail)

Before that, I installed claws-mail_3.7.10-1ubuntu1~ppalucid0ubuntu1_i386.deb and
libetpan15_1.0-1lucidubuntu4_i386.deb. In racy all the following additional packages where requested on startup of claws-mail (here ordered alphabetically, not in order of request):

libbluetooth3_4.60-0ubuntu8_i386.deb
libcompfaceg1_1.5.2-5_i386.deb
libdb4.8_4.8.24-1ubuntu1_i386.deb
libdbus-1-3_1.2.16-2ubuntu4.3_i386.deb
libdbus-glib-1-2_0.84-1ubuntu0.2_i386.deb
libgcrypt11_1.4.4-5ubuntu2_i386.deb
libgnutls26_2.8.5-2_i386.deb
libgpg-error0_1.6-1ubuntu2_i386.deb
libgssapi-krb5-2_1.8.1+dfsg-2ubuntu0.10_i386.deb
libk5crypto3_1.8.1+dfsg-2ubuntu0.10_i386.deb
libkeyutils1_1.2-12_i386.deb
libkrb5-3_1.8.1+dfsg-2ubuntu0.10_i386.deb
libkrb5support0_1.8.1+dfsg-2ubuntu0.10_i386.deb
libldap-2.4-2_2.4.21-0ubuntu5.6_i386.deb
liblockfile1_1.08-3ubuntu1_i386.deb
libpisock9_0.12.4-7ubuntu1_i386.deb
libsasl2-2_2.1.23.dfsg1-5ubuntu1_i386.deb
libtasn1-3_2.4-1_i386.deb

However, the last error message was the one mentioned above (claws-mail: /lib/libc.so.6: version `GLIBC_2.11' not found (required by claws-mail)).
Back to top
View user's profile Send private message 
rokytnji


Joined: 20 Jan 2009
Posts: 1137
Location: Pecos/ Texas

PostPosted: Mon 28 Nov 2011, 03:42    Post subject:  

Code:
=== sys-info 0.6 === Sat 26 Nov 2011 on Linux 3.0.7 ===

Racy Puppy 5.2.2

75 Tasks, 2 Running. Uptime:  1:06,  load average: 0.11, 0.11, 0.08

Current window manager: JWM (starts from C.L. with: 'xwin jwm')

JWM vsvn-505
ROX-Filer 2.10

Network Interface wlan0 connected

=== report-video ===

Racy Puppy, version 5.2.2 on Sat 26 Nov 2011

Chip description:
 5.0 VGA compatible controller
 ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics]
oem: ATI ATOMBIOS
product: RS780M 01.00

X Server: Xorg
Driver used: # vesa

X.Org version: 1.11.0
  dimensions:    1366x768 pixels (361x203 millimeters)
  depth of root window:    24 planes
[    42.284]
X.Org X Server 1.11.0
Release Date: 2011-08-26
[    42.284] X Protocol Version 11, Revision 0


Wireless,Touchpad,Sound,Screen resolution,all 4gig of ram recognized and work on a

Code:
# inxi -F
System:    Host: puppypc11428 Kernel: 3.0.7 i686 (32 bit)
           Desktop JWM sn-505 Distro: Racy Puppy Linux
Linux 3.0.7 [i686 arch]
Machine:   System: Acer (portable) product: Aspire 5534 version: V1.10 serial: LXPJV0200293721BAE1601
           Mobo: Acer model: Aspire 5534 version: V1.10 serial: LXPJV0200293721BAE1601
           Bios: Acer version: V1.10 date: 08/26/2009
CPU:       Dual core (AMD Athlon X2 L310,1197.160,512 KB,fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt rdtscp lm 3dnowext 3dnow extd_apicid pni cx16 lahf_lm cmp_legacy svm extapic cr8_legacy 3dnowprefetch lbrv,2395.08,amd) (-MCP-) cache: unknown  flags: (-)
           Clock Speeds: 1: 1197.160 MHz 2: 1197.160 MHz
Graphics:  Card: ATI RS780M/RS780MN [Radeon HD 3200 Graphics]
           X.org: 1.11.0 drivers: ati,radeon (unloaded: vesa) tty size: 80x25 Advanced Data: N/A for root
Audio:     Card: ATI SBx00 Azalia (Intel HDA) driver: HDA Intel Sound: ALSA ver: 1.0.24
Network:   Card-1: Atheros AR928X Wireless Network Adapter (PCI-Express) driver: ath9k
           IF: wlan0 state: up mac: <filtered>
           Card-2: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
           IF: eth0 state: down mac: 00:26:22:2d:39:03
Drives:    HDD Total Size: (254.1GB,-) () 1: /dev/sda TOSHIBA_MK2555GS 250.1GB
           2: /dev/sdb SanDisk_Cruzer 4.1GB
Partition:
Sensors:   Error: You do not have the sensors app installed.
Info:      Processes: 72 Uptime: 1:25 Memory: 244.4/3796.1MB Client: Shell inxi: 1.7.27


Just installed tonight on 4 gig pendrive. Runs fast. Runs good.

Learned Something. Don't install user agent switcher and flash downloader for seamonkey in Racy puppy package manager. It breaks the symlink ,(at least for me), in /usr/bin/seamonkey which in turn breaks the /usr/bin/mozzila symlink also.

Took me a few to hunt down and see why browser icon and menu icons quit.

Code:
#which seamonkey


Did not return anything, like /usr/bin/seamonkey.

Fixed it by uninstalling both installed ppm installs first. Then deleted /usr/bin/seamonkey symlink and created new symlink from /usr/lib/seamonkey 2.3.2/seamonkey ,(made it absolute), which fixed the broken /usr/bin/mozilla symlink also.

Browser Desktop Icon works again after that. Menu internet entries work again also.

Turned off Tap because I haven't figured out yet how to edit sensitivity good enough yet either. All my functions like 2 finger tap=middle click worked OK. My mouse though had a mind of it's own though like a mexican jumping bean.

Copying personal save file on ntfs partition throws this error

Code:
Copying /mnt/home/racysave-racy1st.2fs as /mnt/sda3/Users/harry/Pupsave/racysave-racy1st.2fs
cp: preserving permissions for

/mnt/sda3/Users/harry/Pupsave/racysave-racy1st.2fs': Operation not supported
Failed to copy '/mnt/home/racysave-racy1st.2fs'

Done
There was one error.


Tried a fix suggested from 01micko that he uses in slack0 in line 52 in /bin/mount.

Code:
ntfs-3g $CMDPRMS -o umask=0 2>/tmp/ntfsmnterr${MYPID}.txt #hacked for spup


But did not work and threw a different error

Code:
The ntfs-3g driver was unable to mount the NTFS
partition and returned this error message:
Failed to write lock '/dev/sda3': Resource temporarily unavailable
Error opening '/dev/sda3': Resource temporarily unavailable
Failed to mount '/dev/sda3': Resource temporarily unavailable

So, the inbuilt kernel NTFS driver has been used
to mount the partition read-only.


I brought /bin/mount back to stock and just copied the save file (192MB) to a fat32 external pendrive instead for now.

This post mostly copied , but edited from :

http://puppylinux.info/topic.php?id=32

Since I have posted there I have installed Gnome-Mplayer and GogglesMM.sfs (thanks Billtoo). Useragent Switcher,FlashDownloader,WOT,Adblock, addons in Seamonkey 2.3.1 also.
Back to top
View user's profile Send private message Visit poster's website 
Sage

Joined: 04 Oct 2005
Posts: 4767
Location: GB

PostPosted: Mon 28 Nov 2011, 06:17    Post subject:  

Ha! Been asking for Claws for a while. One kind soul tried to help me with Claws but it didn't work. Only use Claws & EudoraOSE. There's .pet s for the latter (just sent my copies to 01micko for smokey01 website). Otherwise use Claws in Mint!
Back to top
View user's profile Send private message 
ttuuxxx


Joined: 05 May 2007
Posts: 10730
Location: Ontario Canada,Sydney Australia

PostPosted: Mon 28 Nov 2011, 07:33    Post subject:  

I did post this on Barry's blog but maybe he missed it,
I tried compiling metacity, libcanberra, and even lxtask, And nothing would compile, I had hundreds of lines of Gseal errors in each, Here's the link to the sources that failed to compile.

http://0pointer.de/lennart/projects/libcanberra/libcanberra-0.28.tar.gz

http://ftp.gnome.org/pub/gnome/sources/metacity/2.34/metacity-2.34.1.tar.bz2

http://sourceforge.net/projects/lxde/files/LXTask%20%28task%20manager%29/LXTask%200.1.4/lxtask-0.1.4.tar.gz/download

I think gtk2 needs to be patch and recompiled for the Gseal errors,
ttuuxxx

_________________
http://audio.online-convert.com/ <-- excellent site
http://samples.mplayerhq.hu/A-codecs/ <-- Codec Test Files
http://html5games.com/ <-- excellent HTML5 games Smile

Back to top
View user's profile Send private message Visit poster's website 
don570


Joined: 10 Mar 2010
Posts: 3078
Location: Ontario

PostPosted: Mon 28 Nov 2011, 16:34    Post subject: Right-click menu options  

I've made Right-click compatible to Slacko and Racy so the menu
options should all work.

http://208.109.22.214/puppy/viewtopic.php?p=585321&sid=450a06b41b26829eacc1807a443f7e80#585321

______________________________________________
Back to top
View user's profile Send private message 
seacyd

Joined: 14 Nov 2011
Posts: 25
Location: Austria

PostPosted: Mon 28 Nov 2011, 16:50    Post subject: claws-mail for racy  

@Sage: Thanks for your comment.

Actually, I have claws-mail working in lucid based puppy ( nowadays Puppy 5.28 and macpup 5.28 ) after having downloaded claws-mail packages from the Ubuntu ppa one by one and adding in one or the other library from the package manager in puppy. Someday earlier, I also went through the process of compiling it in Puppy itself. Both steps are rather lengthy. Thus, I hoped that the T2 package is more straight forward to get it going.

I do like the look and feel of racy though. And in racy wireless internet worked out of the box, which was not the case for me in Wary.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Mon 28 Nov 2011, 17:18    Post subject: Re: claws-mail for racy
Subject description: Make Claws-Mail 3.7.10 work for puppy
 

seacyd wrote:
Thanks for all this Puppy work! I enjoy using it on my old computer (which I work with daily).

Claws-Mail is an essential piece of software for me. I tried to get the latest version work. So far, no success. Before I will describe the installation steps I tried, isn't is easy for someone who compiles the Puppy if there is a T2 package available of claws-mail ( http://www.t2-project.org/packages/claws-mail.html )?

How can this be achieved to have an update Claws-Mail working with Puppy? If there would be easy steps to follow (mentioning really all the steps including any tiny command, I would be happy to learn to do it as well. )

With Lucy based Puppies I installed the debs and the libraries to make claws-mail work. With Racy I get the error message:

claws-mail: /lib/libc.so.6: version `GLIBC_2.11' not found (required by claws-mail)

Before that, I installed claws-mail_3.7.10-1ubuntu1~ppalucid0ubuntu1_i386.deb and
libetpan15_1.0-1lucidubuntu4_i386.deb. In racy all the following additional packages where requested on startup of claws-mail (here ordered alphabetically, not in order of request):

libbluetooth3_4.60-0ubuntu8_i386.deb
libcompfaceg1_1.5.2-5_i386.deb
libdb4.8_4.8.24-1ubuntu1_i386.deb
libdbus-1-3_1.2.16-2ubuntu4.3_i386.deb
libdbus-glib-1-2_0.84-1ubuntu0.2_i386.deb
libgcrypt11_1.4.4-5ubuntu2_i386.deb
libgnutls26_2.8.5-2_i386.deb
libgpg-error0_1.6-1ubuntu2_i386.deb
libgssapi-krb5-2_1.8.1+dfsg-2ubuntu0.10_i386.deb
libk5crypto3_1.8.1+dfsg-2ubuntu0.10_i386.deb
libkeyutils1_1.2-12_i386.deb
libkrb5-3_1.8.1+dfsg-2ubuntu0.10_i386.deb
libkrb5support0_1.8.1+dfsg-2ubuntu0.10_i386.deb
libldap-2.4-2_2.4.21-0ubuntu5.6_i386.deb
liblockfile1_1.08-3ubuntu1_i386.deb
libpisock9_0.12.4-7ubuntu1_i386.deb
libsasl2-2_2.1.23.dfsg1-5ubuntu1_i386.deb
libtasn1-3_2.4-1_i386.deb

However, the last error message was the one mentioned above (claws-mail: /lib/libc.so.6: version `GLIBC_2.11' not found (required by claws-mail)).


If you want to install .deb packages from Ubuntu, get them from an older release of Ubuntu.
Or, Debian Squeeze should be ok.

You are trying to install packages compiled for a later version of glibc.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
seacyd

Joined: 14 Nov 2011
Posts: 25
Location: Austria

PostPosted: Mon 28 Nov 2011, 21:33    Post subject: claws-mail for racy
Subject description: Make Claws-Mail 3.7.10 work using debian packages
 

Thank your for your hint.

I successfully installed a very basic (without any plugins) claws-mail 3.7.10 with the debian packages:

claws-mail_3.7.10-2_i386.deb, libbluetooth2_3.36-1_i386.deb, libcompfaceg1_1.5.2-4_i386.deb, libcurl3-gnutls_7.18.2-8lenny5_i386.deb, libdbus-1-3_1.2.1-5+lenny2_i386.deb, libdbus-glib-1-2_0.76-1_i386.deb, libetpan15_1.0-5_i386.deb, libgcrypt11_1.4.1-1_i386.deb, libgnutls26_2.12.14-3_i386.deb, libgnutls26_2.8.5-2_i386.deb, libgpg-error0_1.4-2_i386.deb, libldap-2.4-2_2.4.11-1+lenny2.1_i386.deb, libpisock9_0.12.3-5_i386.deb, libsasl2-2_2.1.22.dfsg1-23+lenny1_i386.deb

When claws-mail requested the missing libdb-5.1.so, I found
libdb5.1_5.1.25-11_i386.deb. There a link was required: ln -s /usr/lib/i386-linux-gnu/libdb-5.1.so /usr/lib/libdb-5.1.so

liblockfile1_1.08-3_i386.deb, libtasn1-3_1.4-1_i386.deb, libkrb53_1.6.dfsg.4~beta1-5lenny6_i386.deb, libkeyutils1_1.2-9_i386.deb

So, if somebody would like to join in getting claws going I am more than happy to provide a head start sending over all the individual deb files (5.6MB). They should also be free to distribute I assume being based on Debian, so I could also upload them somewhere.
---

Regarding the glibc error with the ubuntu files. I used Lucid files from the ppa. These claws-mail files work fine in 5.28. In racy I also got the same error message when installing umplayer with qt4 from pemasu's polarpup.
Back to top
View user's profile Send private message 
Billtoo


Joined: 07 Apr 2009
Posts: 1926
Location: Ontario Canada

PostPosted: Mon 28 Nov 2011, 21:48    Post subject: Racy Puppy 5.2.2 Final, 18 Nov. 2011
Subject description: Seamonkey 2.5
 

I made a pet of Seamonkey 2.5 and tested it in wary 5.2.2 and racy 5.2.2

The download link is:

http://www.datafilehost.com/download-28f94dea.html
seascrn.jpg
 Description   
 Filesize   73.85 KB
 Viewed   2015 Time(s)

seascrn.jpg

Back to top
View user's profile Send private message 
Sage

Joined: 04 Oct 2005
Posts: 4767
Location: GB

PostPosted: Tue 29 Nov 2011, 04:24    Post subject:  

Quote:
getting claws going I am more than happy to .... upload them somewhere.

Why not offer to 01micko for incorporation into smokey01 db?
Back to top
View user's profile Send private message 
rokytnji


Joined: 20 Jan 2009
Posts: 1137
Location: Pecos/ Texas

PostPosted: Tue 29 Nov 2011, 16:17    Post subject: Re: Racy Puppy 5.2.2 Final, 18 Nov. 2011
Subject description: Seamonkey 2.5
 

Billtoo wrote:
I made a pet of Seamonkey 2.5 and tested it in wary 5.2.2 and racy 5.2.2

The download link is:

http://www.datafilehost.com/download-28f94dea.html


Thanks again Billtoo. What was nice is it kept the launchers stock like browse ,and menu internet seamonkey lauchers also, without having to edit anything.

Just install and go. Wink

Same thanks for don570

Quote:
I've made Right-click compatible to Slacko and Racy so the menu
options should all work.


Works just fine in Racy 5.2.2. Smile
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 24 of 33 [487 Posts]   Goto page: Previous 1, 2, 3, ..., 22, 23, 24, 25, 26, ..., 31, 32, 33 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Bugs ( Submit bugs )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1222s ][ Queries: 12 (0.0172s) ][ GZIP on ]