Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 01 Aug 2014, 20:29
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Firefox official releases
Post new topic   Reply to topic View previous topic :: View next topic
Page 12 of 15 [216 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, 15 Next
Author Message
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 12 Mar 2013, 11:25    Post subject:  

Double post I explain in this post and ask you to ignore the next Smile

Finally I get what is going on at my place.

It really works with FF19 and many time but when one shut it down
for to use geany or to listen to music or to look at saved pictures
of cool Bikes whatever and then restart it

then it check if the extensions are compatible with FF19
and them realize they are not updated to be able to be used
on FF19 so it instantly goes back to a FF17 backup somewhere
it was done within a second so it must have prepared for it.

So now we know how it works at my install but who knows
maybe Makoto or others have other factors that set in.

So there is nothing to do about it just wait for that they update
ASAP

_________________
I use Google Search on Puppy Forum
not an ideal solution though

Last edited by nooby on Tue 12 Mar 2013, 15:11; edited 1 time in total
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Tue 12 Mar 2013, 14:29    Post subject:  

look at text above that one explain what goes on.
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3600
Location: World_Hub

PostPosted: Tue 12 Mar 2013, 15:15    Post subject:  

Image too big? Upload, then link your shot from here.

And I'd agree- Makotos`cause is different I'm sure..
Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1780
Location: Out wandering... maybe.

PostPosted: Tue 12 Mar 2013, 21:27    Post subject:  

In my case, it's probably something about Puppy 4.3.1 or some of my installed libs it doesn't like (though you'd think that with the latter, it would throw error messages).

For all I know, it looks at my kernel version and politely declines any more updates, because it thinks the system can't properly run it. The same behavior happens if you try to update past FF2 on a Win9X/ME system, IIRC. (It doesn't see the updates, and doesn't really tell you why.)

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Tue 12 Mar 2013, 22:46    Post subject:  

Makoto wrote:
In my case, it's probably something about Puppy 4.3.1 or some of my installed libs it doesn't like (though you'd think that with the latter, it would throw error messages).

For all I know, it looks at my kernel version and politely declines any more updates, because it thinks the system can't properly run it. The same behavior happens if you try to update past FF2 on a Win9X/ME system, IIRC. (It doesn't see the updates, and doesn't really tell you why.)


You can eliminate the kernel...... I used the kernel from 4.3.1 when I built Lucid Retro and I'm posting from Firefox 19.0.2 right now. Newer Firefox builds are probably requiring some built-in lib that's too old in the 4 series Puppy's.
Pretty sure Firefox quit updating in my install of Ttuuxxx's 4.32, I'll reboot and check.

On Windows 2000 Firefox won't update past 12.0 either.
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Tue 12 Mar 2013, 23:10    Post subject:  

Requirements for Firefox 19.0

Quote:
Firefox will not run at all without the following libraries or packages:

GTK+ 2.18 or higher
GLib 2.22 or higher
Pango 1.14 or higher
X.Org 1.0 or higher (1.7 or higher is recommended)
libstdc++ 4.3 or higher


http://www.mozilla.org/en-US/firefox/19.0/system-requirements/
Back to top
View user's profile Send private message 
James C


Joined: 26 Mar 2009
Posts: 5687
Location: Kentucky

PostPosted: Tue 12 Mar 2013, 23:15    Post subject:  

I had forgotten but Firefox 19.0.2 also works in 4.3.2. Not sure what Ttuuxxx upgraded from 431 though.
Puppy4.3.2.jpg
 Description   
 Filesize   24.05 KB
 Viewed   950 Time(s)

Puppy4.3.2.jpg

Back to top
View user's profile Send private message 
Makoto


Joined: 03 Sep 2009
Posts: 1780
Location: Out wandering... maybe.

PostPosted: Tue 12 Mar 2013, 23:36    Post subject:  

Hmm... well, I think my Puppy has GTK+ at 2.14.7, and glib at 2.18.3. The odd thing is, though, as I noted above - if I try running the v18/19 binaries from Mozilla, they'll run, but for some reason, believe they're v12 or earlier. Shocked

Edit: Ran a couple of basic ldd attempts against 19.0.2:

Code:
# ldd -v firefox
   linux-gate.so.1 =>  (0xffffe000)
   libpthread.so.0 => /lib/libpthread.so.0 (0xb7fb6000)
   libdl.so.2 => /lib/libdl.so.2 (0xb7fb2000)
   libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7ecb000)
   libm.so.6 => /lib/libm.so.6 (0xb7ea9000)
   libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb7e9e000)
   libc.so.6 => /lib/libc.so.6 (0xb7da2000)
   /lib/ld-linux.so.2 (0xb7fcc000)

   Version information:
   ./firefox:
      libgcc_s.so.1 (GLIBC_2.0) => /usr/lib/libgcc_s.so.1
      ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
      libdl.so.2 (GLIBC_2.1) => /lib/libdl.so.2
      libdl.so.2 (GLIBC_2.0) => /lib/libdl.so.2
      libstdc++.so.6 (GLIBCXX_3.4) => /usr/lib/libstdc++.so.6
      libstdc++.so.6 (CXXABI_1.3) => /usr/lib/libstdc++.so.6
      libpthread.so.0 (GLIBC_2.1) => /lib/libpthread.so.0
      libpthread.so.0 (GLIBC_2.0) => /lib/libpthread.so.0
      libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.3.2) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
   /lib/libpthread.so.0:
      ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
      ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2
      ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
      libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.3.2) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
      libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
   /lib/libdl.so.2:
      ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
      libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
      libc.so.6 (GLIBC_PRIVATE) => /lib/libc.so.6
   /usr/lib/libstdc++.so.6:
      ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
      libgcc_s.so.1 (GCC_3.3) => /usr/lib/libgcc_s.so.1
      libgcc_s.so.1 (GCC_3.0) => /usr/lib/libgcc_s.so.1
      libc.so.6 (GLIBC_2.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.1) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.2) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
   /lib/libm.so.6:
      ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
      libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
   /usr/lib/libgcc_s.so.1:
      libc.so.6 (GLIBC_2.1.3) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.2.4) => /lib/libc.so.6
      libc.so.6 (GLIBC_2.0) => /lib/libc.so.6
   /lib/libc.so.6:
      ld-linux.so.2 (GLIBC_PRIVATE) => /lib/ld-linux.so.2
      ld-linux.so.2 (GLIBC_2.3) => /lib/ld-linux.so.2
      ld-linux.so.2 (GLIBC_2.1) => /lib/ld-linux.so.2

_________________
[ Puppy 4.3.1 JP, Frugal install | 1GB RAM | 1.3GB swap ] * My Pidgin Builds for Puppy 4.3.1+
In memory of our beloved American Eskimo puppy (1995-2010) and black Lab puppy (1997-2011).
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3600
Location: World_Hub

PostPosted: Tue 02 Apr 2013, 18:28    Post subject:  

Released today >> https://www.mozilla.org/en-US/firefox/20.0/releasenotes/
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 3600
Location: World_Hub

PostPosted: Wed 15 May 2013, 06:30    Post subject:  

Yesterday >> https://www.mozilla.org/en-US/firefox/21.0/releasenotes/
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Wed 15 May 2013, 09:59    Post subject:  

Good that you tell us they have new versions already.

I am too dumb to get this feature.

https://blog.mozilla.org/privacy/2013/01/28/newdntui/

" the Do Not Track feature really has three states: “user says nothing”, “user says track”, and “user says don’t track”. In Firefox 4, we introduced two of these states with a checkbox (“user says nothing” and “user says don’t track”), and many people are voicing their desire to opt-out."

If one reveal that one don't want to be tracked that is a clear sign
one should be tracked and why would any tracker even care to obey?

Is it not something odd about it.

The better approach would be

These guys are tracking you which of them would you allow.


NoScript has something similar. all scipts are shut off until one allow them.

some site refuse to show Streaming Video from CNN unless all
the scripts are allowed Smile So rather annoying but one at least
know whom they are wanting to keep track using scripts.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1087

PostPosted: Mon 10 Jun 2013, 15:43    Post subject:  

Hello everyone

This is Firefox 21 ↓
Find the dependencies for Wary / Racy at /root/Firefox-Dependencies (install and reboot)

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1087

PostPosted: Thu 20 Jun 2013, 23:37    Post subject:  

Latest versions of Firefox won't run in Wary:

urxvt terminal emulator wrote:
Couldn't load XRE functions.


I tried an older pet (version 16.0.1) and it runs fine. Those who wish to use the latest versions (21 and later) will have to switch to a Puppy that can run them (Precise, Slacko, Dpup, etc.) until a solution for this is found. Tman's got packages for older versions in the link he posted in the first page of this thread.

**EDIT**
According to some Mozilla pages the affected versions are 18 and later.

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
nooby

Joined: 29 Jun 2008
Posts: 10557
Location: SwedenEurope

PostPosted: Fri 21 Jun 2013, 01:04    Post subject:  

I use an old Lupu 528-005 and FireFox 21 works with that one
use it daily. But I have not tested what you talk about.

Do you have frugal install on HD or what kind of install do you use?

When does one have to use urxvt terminal emulator wrote:
Couldn't load XRE functions.

_________________
I use Google Search on Puppy Forum
not an ideal solution though
Back to top
View user's profile Send private message 
vicmz


Joined: 15 Jan 2012
Posts: 1087

PostPosted: Fri 21 Jun 2013, 14:18    Post subject:  

nooby wrote:
I use an old Lupu 528-005 and FireFox 21 works with that one
use it daily. But I have not tested what you talk about.

Do you have frugal install on HD or what kind of install do you use?

When does one have to use urxvt terminal emulator wrote:
Couldn't load XRE functions.


Yes, it's a frugal install to HD of Wary 5.5. User VV5 has had the same problem.

I found a Mozilla page (sorry I missed the link) where someone says Firefox 18 and later requires glibc 2.11+, while Wary Puppy has glibc 2.10.

Actually I use Precise the most, but I thought others would want to know.

_________________
OB Precise 14.07.26 Woof-CE|Puppy Linux en español
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 12 of 15 [216 Posts]   Goto page: Previous 1, 2, 3, ..., 10, 11, 12, 13, 14, 15 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1021s ][ Queries: 12 (0.0149s) ][ GZIP on ]