Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 31 Jul 2014, 05:51
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Opera: problem with fonts
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Author Message
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Mon 28 Nov 2011, 09:29    Post subject:  Opera: problem with fonts  

I have installed Opera 11.52 (in puppy 5.28 ) but when i turn keyboard to greek keyboard and trying to type, instead of letters, it shows me strange shapes like: φδξδφ
What should I do?
(on the other hand, Firefox and Google Chrome work fine.)
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Mon 28 Nov 2011, 12:35    Post subject: Re: Opera: problem with fonts  

panoss wrote:
I have installed Opera 11.52 (in puppy 5.28 ) but when i turn keyboard to greek keyboard and trying to type, instead of letters, it shows me strange shapes like: φδξδφ
What should I do?
(on the other hand, Firefox and Google Chrome work fine.)


Possibly Opera is trying to use a font which is not on your system. Try changing your font settings in Tools>Preferences>Advanced>Fonts .

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
darkcity


Joined: 23 May 2010
Posts: 2436
Location: near here

PostPosted: Mon 28 Nov 2011, 13:22    Post subject:  

this may be unrelated but there is a Font Improvement pet for opera here-
http://www.murga-linux.com/puppy/viewtopic.php?p=478051#478051

_________________
helping Wiki for help | IF SendSpace link = "dead" THEN PM me ("up file to http://meownplanet.net/")
Back to top
View user's profile Send private message Visit poster's website 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Mon 28 Nov 2011, 14:43    Post subject: Re: Opera: problem with fonts  

Terryphi wrote:
panoss wrote:
I have installed Opera 11.52 (in puppy 5.28 ) but when i turn keyboard to greek keyboard and trying to type, instead of letters, it shows me strange shapes like: φδξδφ
What should I do?
(on the other hand, Firefox and Google Chrome work fine.)


Possibly Opera is trying to use a font which is not on your system. Try changing your font settings in Tools>Preferences>Advanced>Fonts .

I tried that, I tried all fonts, but all work the same way. No improvement.
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Mon 28 Nov 2011, 14:51    Post subject:  

darkcity wrote:
this may be unrelated but there is a Font Improvement pet for opera here-
http://www.murga-linux.com/puppy/viewtopic.php?p=478051#478051

I tried that, it didn't work.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Tue 29 Nov 2011, 02:40    Post subject:  

panoss:

Apologies if these suggestions seem obvious or you have already tried them:

What is your setting in Opera for View>Encoding? "Automatic selection" should work but there is also a Greek Option.

Have you set Opera Tools>Preferences>General>Language to Greek?

Have you set Opera Tools>Preferences>Advanced>International fonts to Greek?

Have you set Puppy to use UTF-8 ?

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 29 Nov 2011, 03:07    Post subject:  

Terryphi wrote:

What is your setting in Opera for View>Encoding? "Automatic selection" should work but there is also a Greek Option.

I think we have differrent versions of Opera, I have 11.52.
So at mine it is a little different: Opera>Settings>Preferences>General>Chosen preferred language for Opera and webpages: Language:greek>Details>Codepage for webpages without language definition.
I tried windows 1253, UTF8 but nothing.
Anyway, I think it's not the setting you are suggesting, can't find View>Encoding>Automatic selection.
Terryphi wrote:
panoss:
Have you set Opera Tools>Preferences>General>Language to Greek?

Yes.

Terryphi wrote:
panoss:
Have you set Opera Tools>Preferences>Advanced>International fonts to Greek?

Settings>Preferences>Advanced>Fonts>International Fonts: I chose 'Greek' from the list box and the text shown for testing is correct.

BUT: at Settings>Preferences>Advanced>Fonts>Choose:
A form shows up which lists all fonts by name, and lower on the form 'Sample' where you can see the text, to check out if it shows correctly.
Well, it doesn't. No matter which font I chose.
I think somewhere around here is the problem.

Also, I must clarify: the problem is not in reading webpages in greek but in writing. The fonts are incorrect when I'm trying to write.
Terryphi wrote:
panoss:
Have you set Puppy to use UTF-8 ?

I have no idea Laughing . How can I do this?

Last edited by panoss on Tue 29 Nov 2011, 03:32; edited 1 time in total
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Tue 29 Nov 2011, 03:31    Post subject:  

View>Encoding is on the Menu Bar which is hidden by default. To show the menu bar click on the Opera icon at the top left of the tab bar. You can then select "Show menu bar".
_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 29 Nov 2011, 03:36    Post subject:  

Terryphi wrote:
View>Encoding is on the Menu Bar which is hidden by default. To show the menu bar click on the Opera icon at the top left of the tab bar. You can then select "Show menu bar".

You're right. It's in 'automatic'.
I tried UTF8 and Greek but no success, I put it back in 'automatic'.
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Tue 29 Nov 2011, 03:42    Post subject:  

You said the fonts are only incorrect when writing. Writing what exactly?
_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 29 Nov 2011, 03:58    Post subject:  

Terryphi wrote:
You said the fonts are only incorrect when writing. Writing what exactly?

Writing in greek of course. Laughing
For example, if I write greek in this forum, it will show these strange shapes: ξδÏδκÏ

Last edited by panoss on Tue 29 Nov 2011, 04:00; edited 1 time in total
Back to top
View user's profile Send private message 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Tue 29 Nov 2011, 03:59    Post subject:  

I see that forum member Christos has recently posted about a Puppy Linux Greek Forum:

http://www.murga-linux.com/puppy/viewtopic.php?t=73387&search_id=1461811907

Without a Greek keyboard it is hard to help. Perhaps Christos or someone on his forum can help.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
Terryphi


Joined: 02 Jul 2008
Posts: 759
Location: West Wales, Britain.

PostPosted: Tue 29 Nov 2011, 04:02    Post subject:  

panoss wrote:
Terryphi wrote:
You said the fonts are only incorrect when writing. Writing what exactly?

Writing in greek of course. Laughing
For example, if I write greek in this forum, it will show these strange shapes: ξδ�δκ�


Well yes. I realised you were trying to write in Greek. Wink So it is any input typed when using Opera but every other program is OK?

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, Quirky, etc available here Smile
Back to top
View user's profile Send private message Visit poster's website 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 29 Nov 2011, 04:05    Post subject:  

I tried the links you gave, and thank you.
But they are inactive, I guess he abandoned the effort.
I think I also will, anyway firefox and chrome work fine, I'll switch to them.
Back to top
View user's profile Send private message 
panoss

Joined: 31 Oct 2011
Posts: 107

PostPosted: Tue 29 Nov 2011, 04:06    Post subject:  

Terryphi wrote:
panoss wrote:
Terryphi wrote:
You said the fonts are only incorrect when writing. Writing what exactly?

Writing in greek of course. Laughing
For example, if I write greek in this forum, it will show these strange shapes: ξδ�δκ�


Well yes. I realised you were trying to write in Greek. Wink So it is any input typed when using Opera but every other program is OK?

Yes, only Opera has this problem.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [19 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0894s ][ Queries: 11 (0.0132s) ][ GZIP on ]