Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 18 Sep 2018, 22:54
All times are UTC - 4
 Forum index » House Training » Users ( For the regulars )
No Flash after updating Firefox in Lucid 5.2 (Solved)
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Author Message
swiatmar


Joined: 09 Aug 2008
Posts: 249
Location: Danube, AT

PostPosted: Mon 28 Nov 2011, 13:25    Post subject:  No Flash after updating Firefox in Lucid 5.2 (Solved)  

Hello!!

After my Firefox update in lucid puppy 5.2 Firefox doesn't have flash!!!
There was also a problem with libnss3.so, but I already manage it.
Does anyone know how to bring flash to work in new firefox?
(I have libflashplayer.so in /usr/lib/mozilla/plugins)

Last edited by swiatmar on Wed 30 Nov 2011, 08:47; edited 1 time in total
Back to top
View user's profile Send private message Visit poster's website 
dk60902


Joined: 26 Sep 2010
Posts: 233
Location: In front of my computer

PostPosted: Mon 28 Nov 2011, 13:43    Post subject:  

How about one of these flash pets?

http://brainwavedesigncentral.net/mike/index.php?dir=flash-player%2F
Back to top
View user's profile Send private message 
swiatmar


Joined: 09 Aug 2008
Posts: 249
Location: Danube, AT

PostPosted: Mon 28 Nov 2011, 14:02    Post subject:  

The thing is much more complicated. There is something really different in flash 8.01. I have the latest flash version installed. This won't help- I already tried to install an older version.........
Back to top
View user's profile Send private message Visit poster's website 
dk60902


Joined: 26 Sep 2010
Posts: 233
Location: In front of my computer

PostPosted: Mon 28 Nov 2011, 14:35    Post subject:  

I'll have to check on my computer when I get home later. I have Puppy 5.28, but I can't remember what version FF is on it.

I'm using 5.25 @ work, but I've intentionally kept FF @ version 4 because I may have had a similar issue with FF not player flash with a later version.
Back to top
View user's profile Send private message 
p310don

Joined: 19 May 2009
Posts: 1234
Location: Brisbane, Australia

PostPosted: Mon 28 Nov 2011, 18:44    Post subject:  

From this thread

http://murga-linux.com/puppy/viewtopic.php?t=72612&start=15

this worked for me

Quote:
I renamed the symlink
/usr/lib/libnss3.so (it linked to the libnss3.so.1d)
and moved the file
/usr/lib/firefox/libnss3.so to the directory /usr/lib
Back to top
View user's profile Send private message 
swiatmar


Joined: 09 Aug 2008
Posts: 249
Location: Danube, AT

PostPosted: Tue 29 Nov 2011, 05:44    Post subject:  

libnss3.so doesn't solve the problem with flash.
It makes Firefox 8 running on puppy 5.2 (without changing the libnss3.so file Firefox does not react / is hanging after update) but it does not activate flash Sad
Back to top
View user's profile Send private message Visit poster's website 
dk60902


Joined: 26 Sep 2010
Posts: 233
Location: In front of my computer

PostPosted: Tue 29 Nov 2011, 16:41    Post subject:  

My FF browser autoupdated to 8.01. I'm running 5.28, but haven't had any problems with flash.
Back to top
View user's profile Send private message 
Semme


Joined: 07 Aug 2011
Posts: 7834
Location: World_Hub

PostPosted: Tue 29 Nov 2011, 19:56    Post subject:  

swiatmar- have you tried with add-ons disabled? Your Flashplayer version?

Does loading FF from a cmd shell dump any errors? Nay?..

Perhaps <under troubleshooting> create a new profile.
Back to top
View user's profile Send private message 
scsijon

Joined: 23 May 2007
Posts: 1347
Location: the australian mallee

PostPosted: Tue 29 Nov 2011, 20:17    Post subject:  

firefox8 requires the flashplayer11 or 11.1 to work, earlier ones seem to not!

It's pet is in the repo.
Back to top
View user's profile Send private message Visit poster's website 
duke93535


Joined: 05 May 2005
Posts: 194
Location: California , High Desert

PostPosted: Wed 30 Nov 2011, 07:42    Post subject:  

I am running Racy 5.2.2 and in order to get Firefox 8.0.1 to work with Flashplayer.

I symlinked all the library files listed in dependentlibs.list in the Firefox directory to /usr/lib. I am also running the newest Flashplayer.

duke
Back to top
View user's profile Send private message 
swiatmar


Joined: 09 Aug 2008
Posts: 249
Location: Danube, AT

PostPosted: Wed 30 Nov 2011, 08:50    Post subject:  

duke93535 wrote:
I am running Racy 5.2.2 and in order to get Firefox 8.0.1 to work with Flashplayer.

I symlinked all the library files listed in dependentlibs.list in the Firefox directory to /usr/lib. I am also running the newest Flashplayer.

duke


Thanks duke!!!!

Okey this seems to be very important to symlinking the files from the firefox folder with the files in /usr/lib/
simple copy the files listed on dependentlibs.list from firefox folder to /usr/lib/ and it works
Back to top
View user's profile Send private message Visit poster's website 
playdayz


Joined: 25 Apr 2008
Posts: 3794

PostPosted: Fri 02 Dec 2011, 20:54    Post subject:  

It is hard to imagine why Firefox does not use its own libnss by preference. This pet has the fix built-in. BTW, i just noted there is an 8.0.1 that will download. BTW, I only symlinked libnss, as the minimal necessary fix.

Firefox 8.0 -> ftp://distro.ibiblio.org/puppylinux/pet-packages-lucid/Firefox-8.0-Lucid.pet

Concerning Flashplayer, This version of FF8 seems to play video on youtube fine with the current flashplayer (11.1 as scsijon says above). The old programs do not download flashplayer correctly because Adobe has started moving it around. I recommend this one to update flashplayer -> ftp://distro.ibiblio.org/puppylinux/pet_packages-lucid/flash_install-0.1.pet In the menu as Internet -> Install Flashplayer.
Back to top
View user's profile Send private message 
duke93535


Joined: 05 May 2005
Posts: 194
Location: California , High Desert

PostPosted: Sun 04 Dec 2011, 14:05    Post subject:  

Please note that, playdays solution may work with some Puppy versions, but, NOT all (namely Racy 5.2.2 for example).
Slacko 5.3 seems to work fine without any special symlinks added for Firefox 8.0.1.
Back to top
View user's profile Send private message 
Tman


Joined: 22 Jan 2011
Posts: 815
Location: Toronto

PostPosted: Sun 04 Dec 2011, 15:32    Post subject:  

Please try the my Firefox pets for Wary/Racy and let me know if you have any problems with them.
http://www.smokey01.com/Tman/apps/firefox/

I use Wary/Racy with flashplayer 11 and they are fine for me.
Back to top
View user's profile Send private message 
duke93535


Joined: 05 May 2005
Posts: 194
Location: California , High Desert

PostPosted: Mon 05 Dec 2011, 00:10    Post subject:  

Tman:

Yes, your Firefox pet works very well on Racy 5.2.2 (fresh install). The only thing I did was to start fresh with my own /root/.mozilla/firefox/, for my own preferences.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 1 of 2 [17 Posts]   Goto page: 1, 2 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » House Training » Users ( For the regulars )
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0487s ][ Queries: 11 (0.0052s) ][ GZIP on ]