Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Wed 13 Dec 2017, 11:20
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
GetFlash install Flashplayer
Post new topic   Reply to topic View previous topic :: View next topic
Page 6 of 12 [171 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 Next
Author Message
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Sun 08 Mar 2015, 04:42    Post subject:  

OscarTalks wrote:
I found that the getflash script by BarryK worked for me in Racy 5.5 and Slacko 5.7 but not in Dpup Wheezy 3.5.2.11 or Precise 5.7.1

...but changing line 26 to http as suggested by Terryphi works for me in all of them.

Same result for me.
Tried in France with getflash-1.5-2.pet and precise-5.7.1-ce

_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
Terryphi


Joined: 02 Jul 2008
Posts: 768
Location: West Wales, Britain.

PostPosted: Sun 08 Mar 2015, 05:27    Post subject:  

I have tested on another machine running Racy 5.5 and BK's pet works with https. As I suggested earlier I think this is a security protocol issue because I vaguely remember updating libssl manually on this second machine.

What baffles me is why Barry found he needed to change connection to https. Maybe the version of wget he used requires this or was compiled with a later version of openssl?

Anyway, it seems that the http URL should work for everyone.

_________________
Classic Opera 12.16 browser SFS package for Precise, Slacko, Racy, Wary, Lucid, etc available here Smile
Back to top
View user's profile Send private message 
Argolance


Joined: 06 Jan 2008
Posts: 3129
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Mon 09 Mar 2015, 18:13    Post subject:  

Bonjour,
Silly question: Why not replace the URL by a variable that could be automatically updated instead of a new getflash script every time this URL changes?

I confirm: BK getflash-1.5-2.pet doesn't work with Puppy Precise 5.7.1 Confused.
Terryphi wrote:
Anyway, it seems that the http URL should work for everyone.

On the other hand, changing "https" to "http" works!
Just a little issue: the size of the new flashplayer is not correctly displayed (see picture).

Cordialement.
150310_002014_308x50_easyshot.png
 Description   
 Filesize   4.31 KB
 Viewed   4092 Time(s)

150310_002014_308x50_easyshot.png


_________________

Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8345
Location: Perth, Western Australia

PostPosted: Mon 09 Mar 2015, 21:31    Post subject:  

Alright, I have modified the script to test for http:// and https://

Now on "-3"

http://distro.ibiblio.org/quirky/quirky6/noarch/packages/pet_packages-noarch/getflash-1.5-3.pet

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
jamesbond

Joined: 26 Feb 2007
Posts: 3103
Location: The Blue Marble

PostPosted: Tue 10 Mar 2015, 03:03    Post subject:  

Fatdog doesn't use getflash but (very recently) got its own flash-updater. The URL used is this: "http://fpdownload.macromedia.com/get/flashplayer/pdc/$1/install_flash_player_11_linux.$ARCH.tar.gz"
where $1 is the flash version (e.g. 11.2.202.442) and $ARCH is i386 for 32-bit and x86_64 for 64-bit.

_________________
Fatdog64, Slacko and Puppeee user. Puppy user since 2.13.
Contributed Fatdog64 packages thread.
Back to top
View user's profile Send private message 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 10 Mar 2015, 14:59    Post subject:  

The size of the archive proposed by Adobe is not displayed on the screenshot of Argolance (see above).
I have the same problem.
Someone has an idea?
non_displayed_size.png
 Description   
 Filesize   5.53 KB
 Viewed   3944 Time(s)

non_displayed_size.png


_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
Argolance


Joined: 06 Jan 2008
Posts: 3129
Location: PORT-BRILLET (Mayenne - France)

PostPosted: Tue 10 Mar 2015, 17:23    Post subject:  

Bonsoir,
@ASRI éducation
I noticed something which seems to be a small error in the code line number 130:
Code:
     if [ $NEWMB -gt 0 ] ; then
       L=$(echo -n $NEWMB | wc -c)
       M=$(($L -1))
       NEWMB="$(echo $NEWMB -n | cut -c-$M).$(echo -n $NEWMB | cut -c$L)MB"
     else NEWFB='---'
     fi

NEWFB instead of NEWMB.
If modified, it looks like what the picture above shows: this is probably normal.
Is it another very minor one (line 81)?:
Code:
--placement center

which may be:
Code:
-placement center

Is eval missing (and . gettext.sh) at line 296? (this prevents string to be correctly translated):
Code:
        TEXT=$(gettext "The Adobe Flash Player has been downloaded to\n/usr/lib${lsuffix}/mozilla/plugins\nYou will need to exit from your web browser and restart it for the player to load")

Cordialement.
150310_221408_275x39_easyshot.png
 Description   
 Filesize   3.27 KB
 Viewed   3928 Time(s)

150310_221408_275x39_easyshot.png


_________________

Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8345
Location: Perth, Western Australia

PostPosted: Wed 11 Mar 2015, 06:12    Post subject:  

Argolance wrote:
Bonsoir,
@ASRI éducation
I noticed something which seems to be a small error in the code line number 130:
Code:
     if [ $NEWMB -gt 0 ] ; then
       L=$(echo -n $NEWMB | wc -c)
       M=$(($L -1))
       NEWMB="$(echo $NEWMB -n | cut -c-$M).$(echo -n $NEWMB | cut -c$L)MB"
     else NEWFB='---'
     fi

NEWFB instead of NEWMB.
If modified, it looks like what the picture above shows: this is probably normal.
Is it another very minor one (line 81)?:
Code:
--placement center

which may be:
Code:
-placement center

Is eval missing (and . gettext.sh) at line 296? (this prevents string to be correctly translated):
Code:
        TEXT=$(gettext "The Adobe Flash Player has been downloaded to\n/usr/lib${lsuffix}/mozilla/plugins\nYou will need to exit from your web browser and restart it for the player to load")

Cordialement.


Argolance,
Thanks, I have put your fixes in.

Also, yaf-splash (gtkdialog-splash) is deprecated in Quirky, so I have put in a test for existence of 'popup', which will be used if it exists.
The fallback, if neither popup nor yaf-splash exist, is still gxmessage.

Now up to '-4':

http://distro.ibiblio.org/quirky/quirky6/noarch/packages/pet_packages-noarch/getflash-1.5-4.pet

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Tue 24 Mar 2015, 15:15    Post subject:  

I appreciate, I use and I thank the contributors of 'getflash'.
I would therefore suggest some changes.
Code:
#150315 ASRI: try to improve main GUI, improve gettext, add conf file. And more...

I only changed the interface. I feel that it's better, but of course it's subjective.

My only problem is that I can not display the installed version: see screenshot (getflash-1.5-5_b.png) after "v" the version is not informed.
The problem seems to be related to the 'strings' command (line 54). If someone has an idea.
Code:
# getflash
/usr/sbin/getflash: ligne 54: strings : commande introuvable
INSTALLED=


Regards
getflash-1.5-5.pet
Description 
pet

 Download 
Filename  getflash-1.5-5.pet 
Filesize  11.3 KB 
Downloaded  528 Time(s) 
getflash-1.5-5_NLS.pet
Description  current = fr
pet

 Download 
Filename  getflash-1.5-5_NLS.pet 
Filesize  3.07 KB 
Downloaded  308 Time(s) 
getflash-1.5-5_b.png
 Description   problem to show version of installed flahplayer
 Filesize   42.89 KB
 Viewed   3545 Time(s)

getflash-1.5-5_b.png

getflash-1.5-5_a.png
 Description   
 Filesize   40.75 KB
 Viewed   3538 Time(s)

getflash-1.5-5_a.png


_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Wed 25 Mar 2015, 08:01    Post subject:  

ASRI éducation wrote:
My only problem is that I can not display the installed version: see screenshot (getflash-1.5-5_b.png) after "v" the version is not informed.
The problem seems to be related to the 'strings' command (line 54). If someone has an idea.

I understood.
The strings command is in the devx file. For getflash be functional, it need to mount the devx (not practical).

@ Barry
Do you think it is possible to replace the strings command with something else?

Regards
getflash-1.5-5_c.png
 Description   with devx, version is detected
 Filesize   40.82 KB
 Viewed   3398 Time(s)

getflash-1.5-5_c.png


_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 8345
Location: Perth, Western Australia

PostPosted: Wed 25 Mar 2015, 09:30    Post subject:  

ASRI éducation wrote:
ASRI éducation wrote:
My only problem is that I can not display the installed version: see screenshot (getflash-1.5-5_b.png) after "v" the version is not informed.
The problem seems to be related to the 'strings' command (line 54). If someone has an idea.

I understood.
The strings command is in the devx file. For getflash be functional, it need to mount the devx (not practical).

@ Barry
Do you think it is possible to replace the strings command with something else?

Regards


The 'strings' utility is from binutils, which is only in the devx in quirky, and probably other pups.

strings needs libbfd.so*, which is 950KB, so I don't want it in the main filesystem.

However, busybox also has strings.

If strings is needed in getflash, just substitute "busybox strings" in place of "strings".

You may need to run this to check available options:

# busybox strings --help

_________________
http://barryk.org/news/
Back to top
View user's profile Send private message Visit poster's website 
ASRI éducation


Joined: 09 May 2009
Posts: 3203
Location: France

PostPosted: Wed 25 Mar 2015, 10:27    Post subject:  

BarryK wrote:
If strings is needed in getflash, just substitute "busybox strings" in place of "strings".

Excellent, everything works.
As you suggested, simply substitute "strings" with "busybox strings".
A simple, fast and efficient solution.
Thank you Barry!

Line 54: old
Code:
FLASHVERSION=$(strings -n13 /usr/lib${lsuffix}/mozilla/plugins/libflashplayer.so  | grep 'FlashPlayer_' | cut -d '_' -f2-5| tr '_' '.')

Line 54: new
Code:
FLASHVERSION=$(busybox strings -n13 /usr/lib${lsuffix}/mozilla/plugins/libflashplayer.so  | grep 'FlashPlayer_' | cut -d '_' -f2-5| tr '_' '.')


Regards
getflash-1.5-6.pet
Description 
pet

 Download 
Filename  getflash-1.5-6.pet 
Filesize  11.33 KB 
Downloaded  2965 Time(s) 
getflash-1.5-6_NLS.pet
Description 
pet

 Download 
Filename  getflash-1.5-6_NLS.pet 
Filesize  3.01 KB 
Downloaded  383 Time(s) 
getflash-1.5-6.png
 Description   
 Filesize   41.16 KB
 Viewed   3376 Time(s)

getflash-1.5-6.png


_________________
Projet ASRI éducation => Association | Forum | Dépôt | Espace kids
Back to top
View user's profile Send private message Visit poster's website 
caiosama


Joined: 02 Jan 2015
Posts: 104
Location: Concepcion, Chile

PostPosted: Tue 31 Mar 2015, 16:56    Post subject:  

Thank you so much guys!
Back to top
View user's profile Send private message 
Pelo

Joined: 10 Sep 2011
Posts: 12591
Location: Mer méditerrannée (1 kms°)

PostPosted: Fri 03 Apr 2015, 04:48    Post subject: addon Video Without Flash 1.5.1
Subject description: Read videos without flash player
 

addon Video Without Flash 1.5.1
Forum iberico ou forum Français : pls comment if this addon works in other browsers than palemoon (Palemoon addon does the job Smile ).

_________________
Passenger Pelo ! don't ask him to repair the aircraft. Don't use him as a demining dog .... pleeease.
Back to top
View user's profile Send private message Yahoo Messenger 
peebee


Joined: 21 Sep 2008
Posts: 3036
Location: Worcestershire, UK

PostPosted: Fri 22 May 2015, 06:54    Post subject: 64-bit installs not working....  

I have tried to use getflash-1.5.6 for 64-bit install.....(Slacko64/LxPup64)

Both getflash-1.5.6 and a direct download from the Adobe website selecting ".tar.gz for Other Linux"
result in a download which seems to be tailored for KDE4 rather than generic and as a result getflash reports that the installation fails and webbrowser does not see the downloaded flashplayer.

I can obtain a working version from pkgs.org.....

Cheers
peebee

_________________
LxPup = Puppy + LXDE
Back to top
View user's profile Send private message Visit poster's website 
Display posts from previous:   Sort by:   
Page 6 of 12 [171 Posts]   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0694s ][ Queries: 12 (0.0077s) ][ GZIP on ]