Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Thu 24 Jul 2014, 13:53
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Using FFMPEG To Record Video & Sound in Puppy
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Author Message
Barkin


Joined: 12 Aug 2011
Posts: 675

PostPosted: Tue 20 Mar 2012, 06:24    Post_subject:  

Lobster wrote:
I have added a front end to the script
- tested in Slacko
should work in Lucid, Wary, Racy and other Puppy's with ffmpeg


Just tested your GUI in Lucid puppy 525, kernel 2.6.33.2 , it works.

[ For the uninitiated the video is saved in the same directory as the app ].
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 20 Mar 2012, 06:47    Post_subject:  

Thanks Barkin - edited my post to include a youtube tutorial on how the front end program was created
http://youtu.be/gUwMCMjVXL8

_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
Barkin


Joined: 12 Aug 2011
Posts: 675

PostPosted: Tue 20 Mar 2012, 07:04    Post_subject:  

Lobster wrote:
Thanks Barkin - edited my post to include a youtube tutorial on how the front end program was created
http://youtu.be/gUwMCMjVXL8

The audio in your youtu.be video is only in my left ear.

[ It's not due to the pup-rec app as that gives me stereo when I used it to record my desktop ]
Back to top
View user's profile Send_private_message 
Lobster
Official Crustacean


Joined: 04 May 2005
Posts: 15117
Location: Paradox Realm

PostPosted: Tue 20 Mar 2012, 07:37    Post_subject:  

That is convenient - you can listen to music of your choice with your right ear . . . Wink
_________________
Puppy WIKI
Back to top
View user's profile Send_private_message Visit_website 
antiloquax


Joined: 27 Jan 2012
Posts: 405

PostPosted: Tue 20 Mar 2012, 08:43    Post_subject:  

I am currently using Racy 5.2.9 and I am getting an error:
Code:
unknown input format: 'x11grab'


Embarassed
Which is a shame, because I wanted to use this ...

Great video by the way Lobster!

_________________
My System:Arch-Arm on RPi!
"RacyPy" puplet on Toshiba Tecra 8200. PIII, 256 MB RAM.
RaspberryPy: Lobster and I blog about the RPi.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 20 Mar 2012, 11:04    Post_subject:  

Dont be ashamed. Install the new version of ffmpeg.
http://bkhome.org/blog/?viewDetailed=02756

# ./configure --prefix=/usr --cpu=i486 --enable-shared --enable-gpl --enable-nonfree --disable-ffplay --enable-x11grab --enable-small --enable-runtime-cpudetect --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libdc1394 --enable-libfaac --enable-libfreetype --enable-libmp3lame --enable-libschroedinger --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxvid --enable-zlib --enable-postproc --disable-debug --enable-bzlib --enable-version3 --enable-libtheora --enable-swscale --enable-network --enable-libcdio
Back to top
View user's profile Send_private_message 
antiloquax


Joined: 27 Jan 2012
Posts: 405

PostPosted: Tue 20 Mar 2012, 11:16    Post_subject:  

pemasu wrote:
Dont be ashamed. Install the new version of ffmpeg.
http://bkhome.org/blog/?viewDetailed=02756


Thanks for this pemasu!


Edit
Didn't work though! Could I be missing some libraries I wonder?

_________________
My System:Arch-Arm on RPi!
"RacyPy" puplet on Toshiba Tecra 8200. PIII, 256 MB RAM.
RaspberryPy: Lobster and I blog about the RPi.
Back to top
View user's profile Send_private_message 
pemasu


Joined: 08 Jul 2009
Posts: 5463
Location: Finland

PostPosted: Tue 20 Mar 2012, 11:54    Post_subject:  

What error do you get in console.
If I suspect that something is missing but I cant get grap of it...I test with strace command system calls output, in console: strace ffmpeg +the+options+for+ffmpeg
I have managed to solve some really strange missing files problems this way.

Dpup Exprimo launched gtkdialog apps 2.5 times slower than in other puppies.
strace some-gtkdialog-app showed that there was system call to the gconv-modules.cache and that call was unanswered. File not found with every location search. I installed that file and boom...gtk-dialog-apps started to behave.
Back to top
View user's profile Send_private_message 
antiloquax


Joined: 27 Jan 2012
Posts: 405

PostPosted: Tue 20 Mar 2012, 13:06    Post_subject:  

Here's the console output.
pup_rec.png
 Description   
 Filesize   12.79 KB
 Viewed   966 Time(s)

pup_rec.png


_________________
My System:Arch-Arm on RPi!
"RacyPy" puplet on Toshiba Tecra 8200. PIII, 256 MB RAM.
RaspberryPy: Lobster and I blog about the RPi.
Back to top
View user's profile Send_private_message 
antiloquax


Joined: 27 Jan 2012
Posts: 405

PostPosted: Tue 20 Mar 2012, 13:17    Post_subject:  

I've tried running with strace (not too sure what I am doing, but I tried to make a ffmpeg command similar to that in the script).
Edit I think the problem is with x264. I don't know how to fix it. I installed the x264 package from the repos, but that didn't help.
puprec.png
 Description   
 Filesize   257.62 KB
 Viewed   986 Time(s)

puprec.png


_________________
My System:Arch-Arm on RPi!
"RacyPy" puplet on Toshiba Tecra 8200. PIII, 256 MB RAM.
RaspberryPy: Lobster and I blog about the RPi.
Back to top
View user's profile Send_private_message 
bill

Joined: 28 May 2008
Posts: 492

PostPosted: Tue 20 Mar 2012, 22:26    Post_subject: Using FFMPEG To Record Video & Sound in Puppy
Sub_title: Details on Lobsters recgui.zip
 

Fine job on your recgui.zip Lobster.Works a treat in Slacko 5.3.1
Unfortunately it is a no go in Puppy Studio 3.3
The line in pup_rec, /usr/local/lib/gegl-0.1/ff-load.so was not available
because this directory structure in Studio3.3 is
/usr/local/lib/gegl-0.0/NO ff-load.so
I made a directory gegl-0.1 and installed ff-load.so.Still no joy.
so then I installed complete gegl-0.1 in 3.3 but still no luck.Not saving
video1.I turned my attention in 3.3 to rs and this was the message.Using
./rs this message appeared at the bottom" Unknown input format:'x11grab'
What this means is not clear to me but it has been fun anyway. Thanks
for all your effort and I guess now it is more Google search time. Wink
cheers [/img]
UnknownFormatx11grab.jpg
 Description   
 Filesize   139.92 KB
 Viewed   977 Time(s)

UnknownFormatx11grab.jpg

Back to top
View user's profile Send_private_message 
Karl Godt


Joined: 20 Jun 2010
Posts: 3953
Location: Kiel,Germany

PostPosted: Fri 23 Mar 2012, 22:53    Post_subject:  

For get X11grab to work i had to compile --with-pic .

x11grab showed up as configured but did not work for me either configured otherwise ,

Quote:
ffmpeg version 0.7.11, Copyright (c) 2000-2011 the FFmpeg developers
built on Jan 13 2012 23:04:34 with gcc 4.4.3
configuration: --disable-yasm --enable-sram --enable-pic --enable-zlib --enable-bzlib --enable-gpl --enable-x11grab


http://www.murga-linux.com/puppy/viewtopic.php?p=596152#596152
Back to top
View user's profile Send_private_message Visit_website 
Tman


Joined: 22 Jan 2011
Posts: 814
Location: Toronto

PostPosted: Sun 14 Oct 2012, 15:18    Post_subject:  

Here is a pet with a modification of Karl Godt's code from this thread:
http://www.murga-linux.com/puppy/viewtopic.php?t=75139

If the pet does not work, it means that the installed ffmpeg does not support x11grab.
ffmpeg_vidcap-0.4.pet
Description 
pet

 Download 
Filename  ffmpeg_vidcap-0.4.pet 
Filesize  1.49 KB 
Downloaded  772 Time(s) 
Back to top
View user's profile Send_private_message 
the-jub


Joined: 09 Nov 2011
Posts: 31
Location: England

PostPosted: Sun 02 Jun 2013, 19:33    Post_subject:    

Just tested this pet in precise 5.5 and it works great Very Happy
Found the script in /usr/bin and had a little look at it in geany. Its amazing, wish I could bash like that...

Just about to add this to the wikka.

_________________
er.. I should write my pc specs here, I'm forever forgetting my video card specifics Rolling Eyes
Back to top
View user's profile Send_private_message 
Pelo


Joined: 10 Sep 2011
Posts: 2890
Location: Mer méditerrannée (1 kms°)

PostPosted: Mon 03 Jun 2013, 14:56    Post_subject: Xvidcap is based on FFMPEG
Sub_title: Use IT !
 

I was very suprised that FFMPEG is able to record screencast
Sure, FMPEG does it but how ?
Xvidcap 1.1.7 xvidcap 1.1.6 or Pup-record do that
Record my desktop too
FFMPEG vidcap requires X11 grab, but it is a new item ( i did not know it).

Wednesday : FFMPEG vidcap tested and it works fine.
puprec.zip
Description  very basic, look for the pet xvidcap in puppyrus repository
zip

 Download 
Filename  puprec.zip 
Filesize  3.08 KB 
Downloaded  197 Time(s) 

Edited_time_total
Back to top
View user's profile Send_private_message YIM 
Display_posts:   Sort by:   
Page 2 of 3 Posts_count   Goto page: Previous 1, 2, 3 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Multimedia
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0944s ][ Queries: 12 (0.0176s) ][ GZIP on ]