Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 02:27
All times are UTC - 4
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Broadcom-STA "wl" wifi drivers - repository of latest
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 4 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Author Message
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Wed 27 Feb 2013, 04:56    Post_subject: Delta for Racy 5.5  

Here is the delta file for Racy 5.5 with kernel 3.0.66

Just load this followed by the multi-kernel pet from post #1 and reboot

[edit]I've made the multi-kernel driver a dependency.....from download #5[/edit]
broadcom_wl_delta-k3.0.66.pet
Description  Delta file for kernel 3.0.66
pet

 Download 
Filename  broadcom_wl_delta-k3.0.66.pet 
Filesize  41.76 KB 
Downloaded  436 Time(s) 

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
scsijon

Joined: 23 May 2007
Posts: 1047
Location: the australian mallee

PostPosted: Thu 07 Mar 2013, 21:42    Post_subject:  

Hi Peebee, i'm about to build what I hope is the final beta for mage2.

I was wondering that since there is no change to the kernel or associated components, is there a need to get a new delta pet or will it be ok to use the earlier one?

I do intend having it already built into the iso.

thanks

_________________
Puppy T290 - BarryK's Racy but with T2 Version 9.0 is under development.
http://www.murga-linux.com/puppy/viewtopic.php?t=94575
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Fri 08 Mar 2013, 14:44    Post_subject:  

scsijon wrote:
Hi Peebee, i'm about to build what I hope is the final beta for mage2.

I was wondering that since there is no change to the kernel or associated components, is there a need to get a new delta pet or will it be ok to use the earlier one?

I do intend having it already built into the iso.

thanks


Hi scsijon

The latest mage2 delta is dated 10 sept 12 for k3.3.8-mage2-p64gsw-i586 and is attached - as long as the kernel is still exactly the same including the name then it will work to generate the correct wl.ko (as long as you have xdelta3 in your build).

Are you using the latest woof2? If so all should be fine as BK has built all the necessary support files produced by rerwin in.

Cheers
peebee
broadcom_wl_delta-k3.3.8-mage2-p64gsw-i586.pet
Description 
pet

 Download 
Filename  broadcom_wl_delta-k3.3.8-mage2-p64gsw-i586.pet 
Filesize  42.52 KB 
Downloaded  399 Time(s) 

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
scsijon

Joined: 23 May 2007
Posts: 1047
Location: the australian mallee

PostPosted: Fri 08 Mar 2013, 20:53    Post_subject:  

@peebee yes, thanks and good. So any problem is mine! Great to know.
_________________
Puppy T290 - BarryK's Racy but with T2 Version 9.0 is under development.
http://www.murga-linux.com/puppy/viewtopic.php?t=94575
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Tue 12 Mar 2013, 17:32    Post_subject: Delta for PHATSlacko k3.8.2  

Here is the delta file for PHATSlacko with kernel 3.8.2.

Load this followed by the multi-kernel pet from post #1
broadcom_wl_delta-k3.8.2.pet
Description 
pet

 Download 
Filename  broadcom_wl_delta-k3.8.2.pet 
Filesize  90.04 KB 
Downloaded  405 Time(s) 

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Sun 31 Mar 2013, 16:07    Post_subject: Delta files for PhatSlacko and ThinSlacko  

Attached are the delta files for:
    ThinSlacko 5.5.01 with kernel 3.8.5.0 (non-PAE)

    and

    PhatSlacko 5.5.02 with kernel 3.8.5.1 (PAE)
Load the delta then load the multi-kernel pet from post #1 and reboot

Delta can then be unloaded if desired

Cheers
peebee
broadcom_wl_delta-k3.8.5.0.pet
Description  Delta for ThinSlacko with k3.8.5.0
pet

 Download 
Filename  broadcom_wl_delta-k3.8.5.0.pet 
Filesize  90.06 KB 
Downloaded  379 Time(s) 
broadcom_wl_delta-k3.8.5.1.pet
Description  Delta for PhatSlacko with k3.8.5.1
pet

 Download 
Filename  broadcom_wl_delta-k3.8.5.1.pet 
Filesize  90.05 KB 
Downloaded  374 Time(s) 

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
jayjays

Joined: 11 Apr 2013
Posts: 3

PostPosted: Thu 11 Apr 2013, 20:45    Post_subject: Re: Broadcom-STA "wl" wifi drivers - repository of latest
Sub_title: Version 5.100.82.112 wl drivers for recent puppies
 

Hi there, I want to download "post #1".pet files but always shows "An Error Occurred". Do you know any other links? (I have a problem to connect to wifi with broadcom wifi adaptor...)
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Fri 12 Apr 2013, 03:51    Post_subject: Re: Broadcom-STA "wl" wifi drivers - repository of latest
Sub_title: Version 5.100.82.112 wl drivers for recent puppies
 

jayjays wrote:
Hi there, I want to download "post #1".pet files but always shows "An Error Occurred". Do you know any other links? (I have a problem to connect to wifi with broadcom wifi adaptor...)


Looks like it's a forum error.....

I've uploaded the multi-kernel pet here

The smaller delta files seem to download OK still.

Which Puppy version do you have the problem with?

Cheers
PeeBee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
jayjays

Joined: 11 Apr 2013
Posts: 3

PostPosted: Fri 12 Apr 2013, 06:53    Post_subject:  

Thanks, PeeBee. I've loaded and reboot but... nothing changed.

Puppy version: 528 jp (Japanese Version)
Machine: eMachines eM350 model NAV51
Wife adapter: Broadcom 801.11 Network Adapter

Would appreciate if you could give any hints.

Cheers

jayjays
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Fri 12 Apr 2013, 13:03    Post_subject:  

jayjays wrote:
Thanks, PeeBee. I've loaded and reboot but... nothing changed.

Puppy version: 528 jp (Japanese Version)
Machine: eMachines eM350 model NAV51
Wife adapter: Broadcom 801.11 Network Adapter

Would appreciate if you could give any hints.

Cheers

jayjays


Hi jayjays

Derivatives based on lupu528 need a pet with extra logic as lupu528 doesn't contain the logic that is now built-in to more up-to-date puppies.

I've uploaded the pet with the added logic for lupu528 here.

Cheers
PeeBee

_________________
LxPup-14.10 = Puppy + LXDE

Edited_time_total
Back to top
View user's profile Send_private_message Visit_website 
jayjays

Joined: 11 Apr 2013
Posts: 3

PostPosted: Fri 12 Apr 2013, 19:24    Post_subject:  

Thanks, PeeBee. My Japanese pal on another BBS showed the link of pet file and it has fixed the problem.

http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=34219&sid=74432852a60202f8ac1c3a43c14c88bf

Thanks for your concerning and help. Much appreciated.

Cheers

jayjays
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Sat 13 Apr 2013, 02:21    Post_subject:  

jayjays wrote:
Thanks, PeeBee. My Japanese pal on another BBS showed the link of pet file and it has fixed the problem.

http://www.murga-linux.com/puppy/viewtopic.php?mode=attach&id=34219&sid=74432852a60202f8ac1c3a43c14c88bf

Thanks for your concerning and help. Much appreciated.

Cheers

jayjays


That is the older 5.6.48.36 version of the driver - pleased to hear it worked for you.

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
Pelo


Joined: 10 Sep 2011
Posts: 3225
Location: Mer méditerrannée (1 kms°)

PostPosted: Wed 17 Apr 2013, 03:59    Post_subject: Lucid 528-005 driver wifi Wl
Sub_title: Failure
 

Failure on Lucid 528-005. On the recent distros the driver wl works well for the public wifi.
However thanks to you helping us to improve Lucid 528, which is moreover a nice distro.
Sure i can work with eth0. But i have a laptop Medion P7624. I'd like to do not have a chain in the leg at home. The electric cable is fixed yonder on my chandelier so that I am not caught the feet inside.
It's not a disaster...
Bonne journée.
Back to top
View user's profile Send_private_message YIM 
redandwhitestripes

Joined: 02 Jan 2009
Posts: 124

PostPosted: Wed 17 Apr 2013, 11:42    Post_subject:  

OK this seems as good a place as any to ask for help.

My broadcom driver is :

10:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01

2.6.33.2 SMP mod_unload modversions 486


I'm using lupu_525 on a full hard disk install.
Have been doing so for a while with no problems, when I set it up I installed the broadcom-5.10.27.14-k2.6.25.16.pet as I did with all previous puppies and all was fine.

Today I tried running precise 5.5 on a live CD and the weird thing is that it
sees my neighbours' wi-fi networks but not my own! No clue atall.
Some neighbours are using WPA2, just like me.

When I go back to my full install, everything is fine again.

Can anyone suggest why this might be and what I need to install/uninstall?


EDIT: I scanned this thread and installed the closest pet I could find (Precise 5.2 version) but I get an error message "incorrect kernel for this data".

Edited_time_total
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1464
Location: Malvern, Worcs, UK

PostPosted: Fri 19 Apr 2013, 03:49    Post_subject:  

redandwhitestripes wrote:
OK this seems as good a place as any to ask for help.

My broadcom driver is :

10:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01

2.6.33.2 SMP mod_unload modversions 486


I'm using lupu_525 on a full hard disk install.
Have been doing so for a while wtth no problems, when I set it up I installed the broadcom-5.10.27.14-k2.6.25.16.pet as I did with all previous puppies and all was fine.

Today I tried running precise 5.5 on a live CD and the weird thing is that it
sees my neighbours' wi-fi networks but not my own! No clue atall.
Some neighbours are using WPA2, just like me.

When I go back to my full install, everything is fine again.

Can anyone suggest why this might be and what I need to install/uninstall?


EDIT: I scanned this thread and installed the closest pet I could find (Precise 5.2 version) but I get an error message "incorrect kernel for this data".


Hi there

Seen you've had some advice already over on the Precise 5.5 thread.

Precise 5.5 contains all the logic and drivers - b43 and wl - to support Broadcom wifi - you don't need to install any additional pets.

The fact that you can see neighbours signals indicates that the Puppy part of the system is behaving correctly.

Do you think your router might be set to hidden SSID? Have you tried typing the SSID explicitly into whichever Network Manager you are using?

Have you tried all 3 available Network Managers - SNS, Frisbee and NetWiz? If not find the Internet Connection Wizard in the Setup menu and try Frisbee.

If that doesn't work I recommend that you try going through the manual methods described in How to configure wifi from the commandline to see where things are going wrong.

Otherwise, post the evidence produced by running the pdiag command to the forum in the above thread.

Hope this helps
Cheers
PeeBee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 4 of 8 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware » Networking » Wireless
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0997s ][ Queries: 12 (0.0189s) ][ GZIP on ]