Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 30 Jun 2015, 10:35
All times are UTC - 4
 Forum index » Advanced Topics » Hardware
Some Macs and Puppies
Moderators: Flash, Ian, JohnMurga
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 1 of 1 Posts_count  
Author Message

Joined: 13 Nov 2008
Posts: 485

PostPosted: Wed 07 Mar 2012, 08:18    Post_subject:  Some Macs and Puppies  

I have tried an early version of the Intel Macbook, the one that had a touchpad with a button, without installing yet.

With most Puppies the touchpad does not work at all (Slacko, Studio, 4.3.1, Dpup Exprimo latest version, Arcade 10, Lucid with the old kernel). But I tried them all also with a trackball (which works the same as a mouse) and they all seem to work fine with the trackball.

Obviously to do an install rEFIt will have to be used, as Grub does not work. I will eventually install some Puppy on it.

The touchpad works in Lucid 5.2.8, but the OS crashes about 5 seconds after it's finished booting, every time. This is clearly a not a good candidate for installing.

The only Puppies that seem to work with the touchpad at all are Three Headed Dog, Music2Go (which is also a Three Headed Dog based Puppy) and Racy (edit: also TXZ and Saluki). I can't get the Synaptics driver to work on any of them (so I can turn off or configure the tapping), but I've started another topic to see what can be done.

Wary was really weird, most of the time the cursor would just move up and down two cm or so if I used the touchpad, but a few times I also had the trackball plugged in and the touchpad started to work the same way as on Racy or Three Headed Dog. Really weird and also no way to get to the configuration as with the above.

(edit: have not successfully installed alongside MacOS, experienced problems getting the hd to be seen correctly. Working installation with wiped MacOS tested: working correctly, hd was reformatted to Windows type scheme.)

Other than that, I also did a brief test of a brand new Mac Mini by booting Slacko 5.3.1 with an external CD drive. Seemed to work fine, however brief my test was, but I have no plans for installing Puppy on it as it is not my computer.
Back to top
View user's profile Send_private_message 

Joined: 13 Nov 2008
Posts: 485

PostPosted: Thu 14 Jun 2012, 08:36    Post_subject:  

So I'll make the list clearer. Tried on Macbook 2,1.

Crashes: Lucid 5.2.8 early version

No touchpad support, works with USB mouse or similar: Puppy 4.3.1, Slacko 5.3.1, Arcade 10, Puppy Studio, Dpup Exprimo, Lucid 5.2.5 w/older kernel. I think several other older Puppies too.

Touchpad and button work, but tapping is permanently on and synclient does not load, so no touchpad tweaks possible: Lucid, Slacko 5.3.3, Three Headed Dog (all or most versions), Music2Go, TXZ, Saluki (only tried 14 and 17), Racy (but I think I may have had some problems with this, don't remember exactly).

Touchpad working, but not button (my Macbook has a button): FatDog64 5.2.1. I think Lighthouse64 was similar.

Touchpad and button work perfectly: FatDog64 600 Alpha 2. Tapping is disabled when booting up. Touchpad can be tweaked, as flsynclient works. Note that the right button is accessed by keeping two fingers on the touchpad and hitting the button.
Back to top
View user's profile Send_private_message 
Ted Dog

Joined: 13 Sep 2005
Posts: 3302
Location: Heart of Texas

PostPosted: Fri 06 Jul 2012, 17:47    Post_subject:  

try new fatdog 600. Have not has an issue with my trackpad in the last few fatdogs.
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 1 of 1 Posts_count  
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Hardware
Jump to:  

You cannot attach files in this forum
You can download files in this forum

Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0423s ][ Queries: 11 (0.0028s) ][ GZIP on ]