Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Mon 22 Dec 2014, 20:57
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
Post new topic   Reply to topic View previous topic :: View next topic
Page 13 of 14 [201 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Author Message
sindi

Joined: 16 Aug 2009
Posts: 397

PostPosted: Wed 07 May 2014, 12:05    Post subject: Youtube-viewer at 333MHz 256MB RAM Thinkpad 390e
Subject description: Works at 240p, full screen
 

Lupu 5.2.8.6 (latest) mini. Uses 50MB memory to boot, less if I kill ROX-filer, freememapplet, etc. Changed roxterm to urxvt as defaultterminal.
This all saves some cpu time and memory, mostly memory.

Youtube-viewer and gtk-youtube-viewer both work at 240p, but not 360p even with --framedrop. Made a script viewtube

youtube-viewer --resolution=240

Alt-F10 expands mplayer from phone-sized to full screen fuzzy.

Tried without X in a real terminal (Ctrl-Alt-F2) and got a squished image.
On other laptops mplayer plays correctly -vo fbdev. Could try Xorg instead of Xvesa. The limiting factor is not memory but cpu speed and X uses memory but not much cpu. Mplayer uses about 50% cpu at 240p which implies 9/4 x 50% (over 100%) at 360p. Not a stutter at 240p.

240p mplayer also works at 233MHz with 96MB RAM and movgrab.

youtube-viewer is perl 5.10 based. Can someone in the know get it to work in puppy 4 with perl files added to the package? I tried and failed.
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3398
Location: Oregon

PostPosted: Thu 17 Jul 2014, 01:32    Post subject:  

I have Lucid 520 and had downloaded the GTK Youtube viewer for Lucid a while back. I have since downloaded and installed it again.
But when I run it and try doing a search, the search never completes now whereas it used to work fine.
Has Youtube changed anything that would cause Youtube viewer to not work?
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1972
Location: wales

PostPosted: Thu 17 Jul 2014, 12:09    Post subject:  

hi 8-bit
just booted up a vanilla lucid 528 and gtk youtube viewer worked fine for me

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1972
Location: wales

PostPosted: Thu 17 Jul 2014, 12:13    Post subject: Re: Youtube-viewer at 333MHz 256MB RAM Thinkpad 390e
Subject description: Works at 240p, full screen
 

sindi wrote:
Lupu 5.2.8.6 (latest) mini. Uses 50MB memory to boot, less if I kill ROX-filer, freememapplet, etc. Changed roxterm to urxvt as defaultterminal.
This all saves some cpu time and memory, mostly memory.

Youtube-viewer and gtk-youtube-viewer both work at 240p, but not 360p even with --framedrop. Made a script viewtube

youtube-viewer --resolution=240

Alt-F10 expands mplayer from phone-sized to full screen fuzzy.

Tried without X in a real terminal (Ctrl-Alt-F2) and got a squished image.
On other laptops mplayer plays correctly -vo fbdev. Could try Xorg instead of Xvesa. The limiting factor is not memory but cpu speed and X uses memory but not much cpu. Mplayer uses about 50% cpu at 240p which implies 9/4 x 50% (over 100%) at 360p. Not a stutter at 240p.

240p mplayer also works at 233MHz with 96MB RAM and movgrab.

youtube-viewer is perl 5.10 based. Can someone in the know get it to work in puppy 4 with perl files added to the package? I tried and failed.


i couldn't get it working on puppy 4
have you installed your graphic drivers in lucid?

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
8-bit


Joined: 03 Apr 2007
Posts: 3398
Location: Oregon

PostPosted: Fri 18 Jul 2014, 01:31    Post subject:  

I want to clarify my statement of GTK Youtube Viewer for Lucid not working.
It works fine in Lupu 5.5 and up. But not with Lupu 520 on my PC.
This PC has 4gigs of memory, dual core processor, and the Invidia graphics driver installed.
Since I can still get videos using Lupu 5.5, and also Slacko using the version for it, I have work arounds.
I do not know what is different in Lupu 520 that interferes as starting the application from a terminal does not give any errors at any point.
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1972
Location: wales

PostPosted: Fri 18 Jul 2014, 06:43    Post subject:  

hi 8bit

install the devx http://ftp.nluug.nl/os/Linux/distr/puppylinux/puppy-5.2/
it should work on 520 then ... did for me

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
greengeek

Joined: 20 Jul 2010
Posts: 2755
Location: New Zealand

PostPosted: Wed 23 Jul 2014, 16:27    Post subject:  

I tried the slacko 5.4 pet on slacko 5.6 but it does not start the viewer and it gives the following message:
Code:
# bash: ./gtk-youtube-viewer: /usr/bin/perl5.16.1: bad interpreter: No such file or directory

If I rename /usr/bin/perl5.16.3 to /usr/bin/perl5.16.1 the viewer window opens up fine and I can download or play some videos, but most fail to download, leaving correctly named but empty text files in /root.

Do you think it is a simple matter to change the perl version in slacko 5.6, or to modify gtk-viewer to work with perl5.16.3?
Back to top
View user's profile Send private message 
Semme

Joined: 07 Aug 2011
Posts: 4139
Location: World_Hub

PostPosted: Wed 23 Jul 2014, 18:56    Post subject:  

Odd.. my previous troubles have cleared. MPlayer works again, as do dwnlds. Cool

Greengeek, while the problem's probably YTs coding, lose the rename and try the real deal.
perl5.16.1.gz
Description 
gz

 Download 
Filename  perl5.16.1.gz 
Filesize  2.8 KB 
Downloaded  61 Time(s) 

_________________
>>>Punctuation Crash Course<<<
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1972
Location: wales

PostPosted: Thu 24 Jul 2014, 06:27    Post subject:  

here's a recipe to install the latest gtk-youtube-viewer on slacko 5.6 & 5.7

1. install the devx.sfs
2. open the PPM, type perl into the find box and install these....
libwww-perl
perl-gtk2
perl-pango

3. type lxterminal into the find box and install that.
4. open a terminal then highlite the following and paste it into the terminal with 'middle click' and press return
Code:
cpan install Data::Dump XML::Fast HTML::Entities URI::Escape Text::CharWidth Term::UI Term::ReadLine Term::ANSIColor File::ShareDir IO::Socket::SSL
just click ok to any questions
5. grab the youtube-viewer tarball from here https://code.google.com/p/trizen/
6. unzip the package and navigate to the folder with the build file, right click in the window and choose 'window' then 'terminal here'
7. paste this into the terminal and press return
Code:
perl Build.PL --installdirs vendor --gtk-youtube-viewer
./Build
./Build install --install_path script=/usr/bin
cp /usr/share/perl5/vendor_perl/auto/share/dist/WWW-YoutubeViewer/gtk-youtube-viewer.desktop /usr/share/applications
cp /usr/share/perl5/vendor_perl/auto/share/dist/WWW-YoutubeViewer/icons/gtk-youtube-viewer.png /usr/share/pixmaps
fixmenus
jwm -restart


and that's it ... there's some of the missing icons attached below if you want them
icons.pet
Description 
pet

 Download 
Filename  icons.pet 
Filesize  36.66 KB 
Downloaded  77 Time(s) 

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
Aztk

Joined: 22 Aug 2014
Posts: 9

PostPosted: Fri 22 Aug 2014, 23:10    Post subject:  

Hi there. I really liked your GTK Youtube Viewer application. I had used it with no problems at Precise Puppy. My problem started to uninstall an application that I used and did not help me (can not remember which application it was), but I installed after installing the GTK Youtube Viewer.

Now from terminal me this error message:


Quote:
mplayer: could not connect to socket
mplayer: No such file or directory


A picture is worth a thousand words:

http://postimg.org/image/o11sn5l7v/[/url]
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1972
Location: wales

PostPosted: Sat 27 Sep 2014, 04:53    Post subject:  

sorry for the late reply

seems you've uninstalled mplayer .... either reinstall or use vlc

_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
slenkar

Joined: 10 Jul 2009
Posts: 214

PostPosted: Sat 27 Sep 2014, 15:00    Post subject:  

thanks for the build guide
Last edited by slenkar on Sat 27 Sep 2014, 15:01; edited 1 time in total
Back to top
View user's profile Send private message 
666philb


Joined: 07 Feb 2010
Posts: 1972
Location: wales

PostPosted: Sat 27 Sep 2014, 15:01    Post subject:  

what puppy?
_________________
Tahrpup, built with trusty tahr packages http://murga-linux.com/puppy/viewtopic.php?t=96178
Quickpet_Precise, install popular apps quickly http://www.murga-linux.com/puppy/viewtopic.php?t=83642
Back to top
View user's profile Send private message 
slenkar

Joined: 10 Jul 2009
Posts: 214

PostPosted: Sat 27 Sep 2014, 15:02    Post subject:  

I think I forgot to install the libwww and libpango libraries
sorry my mistake

Im using quirky tahir BTW
Back to top
View user's profile Send private message 
slenkar

Joined: 10 Jul 2009
Posts: 214

PostPosted: Sat 27 Sep 2014, 15:27    Post subject:  

It's working now Smile
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 13 of 14 [201 Posts]   Goto page: Previous 1, 2, 3, ..., 11, 12, 13, 14 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0838s ][ Queries: 12 (0.0074s) ][ GZIP on ]