Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Tue 25 Sep 2018, 06:42
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
gtk-youtube-viewer (for lots of pups)
Post new topic   Reply to topic View previous topic :: View next topic
Page 22 of 22 [324 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22
Author Message
hamoudoudou

Joined: 24 Jul 2014
Posts: 1467
Location: rabat

PostPosted: Sat 02 Jun 2018, 02:02    Post subject: my Puppypup !  

slitazpup Very Happy Gtk YT works well on my Ubuntupup, my Debianpup, my devuanpup,
and my Puppypup !
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5184
Location: Republic of Novo Zelande

PostPosted: Sat 22 Sep 2018, 03:54    Post subject:  

Is anyone else having trouble with this? It stopped working for me after I tried to download videos about the israeli attack on Syria.

cheers!

Code:
> 20
ERROR: Signature extraction failed: Traceback (most recent call last):
  File "/usr/local/bin/youtube-dl/youtube_dl/extractor/youtube.py", line 1191, in _decrypt_signature
    video_id, player_url, s
  File "/usr/local/bin/youtube-dl/youtube_dl/extractor/youtube.py", line 1102, in _extract_signature_function
    res = self._parse_sig_js(code)
  File "/usr/local/bin/youtube-dl/youtube_dl/extractor/youtube.py", line 1163, in _parse_sig_js
    jscode, 'Initial JS player signature function name', group='sig')
  File "/usr/local/bin/youtube-dl/youtube_dl/extractor/common.py", line 808, in _search_regex
    raise RegexNotFoundError('Unable to extract %s' % _name)
RegexNotFoundError: Unable to extract Initial JS player signature function name; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
 (caused by RegexNotFoundError(u'Unable to extract \x1b[0;34mInitial JS player signature function name\x1b[0m; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.',)); please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; type  youtube-dl -U  to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.
Back to top
View user's profile Send private message 
musher0

Joined: 04 Jan 2009
Posts: 12697
Location: Gatineau (Qc), Canada

PostPosted: Sat 22 Sep 2018, 05:27    Post subject:  

Hi.

It has nothing to do with any subject of the vids.

youtube-dl is funny that way: it'll stop working if you do not update it...

It may have worked ok for you at 11:43, but if a new version was uploaded at
11:44, it'll give you an error when you try using your "old" version at 11:45.

So do like it says in your error message, try
Code:
youtube-dl -U
?

IHTH

_________________
musher0
~~~~~~~~~~
Siempre será canción nueva... (V. Jara, Manifiesto)
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5184
Location: Republic of Novo Zelande

PostPosted: Sun 23 Sep 2018, 15:17    Post subject:  

musher0 wrote:
So do like it says in your error message, try
Code:
youtube-dl -U
I did try that but no joy:
Code:
# youtube-dl -U
bash: youtube-dl: command not found
#


I presume I just open a terminal in /root and type that command. No need to cd into a special directory first?
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3390
Location: holland

PostPosted: Sun 23 Sep 2018, 15:34    Post subject:  

Hi greengeek, not sure if it's about the yt-viewer cde package, if it is, see here:
http://murga-linux.com/puppy/viewtopic.php?p=991640#991640

Quote:
For a part, youtube-viewer is depending on "youtube-dl".
However it was earlier included in the package, it couldn't be used by itself. Now it can, for example to update youtube-dl (and to download, see below):
Code:
./youtube-dl.cde -U


But I don't know if this will solve the problem though.

EDIT: Looking better at the error output you posted, I don't think it has to do with the cde package, but what did you use then ?

Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5184
Location: Republic of Novo Zelande

PostPosted: Sun 23 Sep 2018, 16:43    Post subject:  

Hi Fred, thanks for the links - yes it is the cde package i am using so that info appears to address my problem. I hope to work through that after work tonight.
cheers!
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5184
Location: Republic of Novo Zelande

PostPosted: Yesterday, at 04:02    Post subject:  

fredx181 wrote:
for example to update youtube-dl (and to download, see below):
Code:
Code:
./youtube-dl.cde -U


But I don't know if this will solve the problem though.

Hi Fred,

I installed my cde pet then opened a terminal inside the /root/youtube-viewer directory and did the following:

Code:
# ./youtube-dl.cde -U
bash: ./youtube-dl.cde: No such file or directory
#


I can only assume that I must be using an older version of the pet that does not use youtube-dl

I will scan back through the thread.

cheers!
Back to top
View user's profile Send private message 
fredx181


Joined: 11 Dec 2013
Posts: 3390
Location: holland

PostPosted: Yesterday, at 04:53    Post subject:  

Hi greengeek, sorry, I don't know which .pet you mean.
The youtube cde "package" is a tar.gz archive, when extracted you get folder "yt-viewer-3.1.5_youtube-dl".
In that folder open a terminal and update youtube-dl like this:
Code:
root@live:~/yt-viewer-3.1.5_youtube-dl# ./youtube-dl.cde -U
WARNING: Assuming --restrict-filenames since file system encoding cannot encode all characters. Set the LC_ALL environment variable to fix this.
Updating to version 2018.09.18 ...
Updated youtube-dl. Restart youtube-dl to use the new version.


Fred

_________________
Dog Linux website
Back to top
View user's profile Send private message 
greengeek


Joined: 20 Jul 2010
Posts: 5184
Location: Republic of Novo Zelande

PostPosted: Yesterday, at 05:53    Post subject:  

fredx181 wrote:
The youtube cde "package" is a tar.gz archive, when extracted you get folder "yt-viewer-3.1.5_youtube-dl".
Thanks - I had made a pet of the previous version that you made. I have now downloaded the 315 version, untarred it, made a pet of it, loaded it, and run your syntax:
Code:
# ./youtube-dl.cde -U
Updating to version 2018.09.18 ...
Updated youtube-dl. Restart youtube-dl to use the new version.
#


and now it works again.

Many thanks!
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 22 of 22 [324 Posts]   Goto page: Previous 1, 2, 3, ..., 20, 21, 22
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » Browsers and Internet
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1244s ][ Queries: 12 (0.0665s) ][ GZIP on ]