Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 18 Apr 2014, 01:31
All times are UTC - 4
 Forum index » Advanced Topics » Cutting edge
Precise Puppy RC2, October 20, 2012
Moderators: Flash, Ian, JohnMurga
Post new topic   Reply to topic View previous topic :: View next topic
Page 16 of 59 [875 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18, ..., 57, 58, 59 Next
Author Message
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Wed 06 Jun 2012, 14:15    Post subject:  

Precise 5.2.60 :
- glxgears very slow 85 FPS instead of 480 for Racy or 1200 for Wary.
- # basichtmlviewer
(surfer:16876): GNet-CRITICAL **: gnet_conn_http_run_async: assertion `conn->uri != NULL' failed
- # cddetect
open: No such file or directory
- # inkscapelite
(inkscapelite:17182): Gtk-CRITICAL **: IA__gtk_style_detach: assertion `style->attach_count > 0' failed
- # xcalc
Warning: Cannot convert string "calculator" to type Pixmap
Warning: Missing charsets in String to FontSet conversion
Back to top
View user's profile Send private message 
broomdodger


Joined: 09 May 2008
Posts: 269
Location: Santa Cruz, CA

PostPosted: Wed 06 Jun 2012, 15:45    Post subject:  

Precise 5.2.60 frugal
Seems as smooth and fast as racy530.
Sylpheed 3.1.4 compiled in racy530 works great.
vim 7.3.543 compiled in racy430 works great

linuxcbon wrote:
Precise 5.2.60

In addition to those listed by linuxcbon, I see:

- ycalc (when using the [X] close box, but not when "Off" is clicked twice)
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
after 143 requests (140 known processed) with 0 events remaining.

- glxgears
84 frames in 5.0 seconds = 16.760 FPS
XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
after 959 requests (957 known processed) with 0 events remaining.

Bill
Precise 5.2.60 frugal
IBM ThinkPad X30
Mobile Intel(R) Pentium(R) III CPU - M 1200MHz

=== report-video ===
Precise Puppy, version 5.2.60 on Wed 6 Jun 2012

Chip description:
2.0 VGA compatible controller
Intel Corporation 82830 CGC [Chipset Graphics Controller] (rev 04)
oem: Almador Graphics Chip Accelerated VGA BIOS
product: Almador Graphics Controller Hardware Version 0.0

X Server: Xorg
Driver used: # vesa

X.Org version: 1.11.3
dimensions: 1024x768 pixels (270x203 millimeters)
depth of root window: 24 planes
Back to top
View user's profile Send private message 
vtpup


Joined: 15 Oct 2008
Posts: 1077
Location: Republic of Vermont

PostPosted: Wed 06 Jun 2012, 17:01    Post subject:  

Downloading the new version now, but before I switch I thought I'd report on the last version (listed below) which is doing great with Intel integrated graphics on this laptop.

Google Sketchup under Wine (which is usually very tough for rendering) ran as fast and smooth as on Racy 53. That is the top speed I've found on 5 of the various late kernal Puplets. All of the others show more or less jerky 3D moves in Sketchup (a CAD app.) Racy and Precise are absolutely smooth and rotate and scale complex assemblies with perspective as fast as I can grab them and move the mouse.

GLx gears is tied to frame referesh rate so can only show 60 FPS -- which is normal and doesn't indicate actual rendering speed.

Precise seems extremely good on this notebook so far.

Acer Aspire 5349-2635

Precise Puppy, version 5.2.58 on Wed 6 Jun 2012

Chip description:
2.0 VGA compatible controller
Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
oem: Intel(R)Sandybridge Mobile Graphics Chipset Accelerated VGA BIOS
product: Intel(R)Sandybridge Mobile Graphics Controller Hardware Version 0.0

X Server: Xorg
Driver used: intel

X.Org version: 1.11.3
dimensions: 1366x768 pixels (361x203 millimeters)
depth of root window: 24 planes

Display
Resolution 1366x768 pixels
OpenGL Renderer Mesa DRI Intel(R) Sandybridge Mobile x86/MMX/SSE2
X11 Vendor The X.Org Foundation
Multimedia
Audio Adapter HDA-Intel - HDA Intel PCH
Input Devices
AT Translated Set 2 keyboard
SynPS/2 Synaptics TouchPad
Logitech USB Receiver
Logitech USB Receiver
Power Button
Sleep Button
Lid Switch
Power Button
Acer WMI hotkeys
PC Speaker
1.3M WebCam
HDA Digital PCBeep
HDA Intel PCH HDMI/DP,pcm 3=
HDA Intel PCH Mic
HDA Intel PCH Headphone
Video Bus
Printers (CUPS)
CUPS-PDF Default
SCSI Disks
ATA TOSHIBA MQ01ABD0
HL-DT-ST DVDRAM GT51N
Operating System
Version
Kernel Linux 3.2.18 (i686)
Compiled #1 SMP Wed May 30 22:40:54 GMT-8 2012
C Library GNU C Library version 2.15 (stable)
Default C Compiler Unknown
Distribution Unknown distribution
Current Session
Computer Name puppypc1168
User Name root (root)
Home Directory /root
Desktop Environment Unknown (Window Manager: JWM)
Misc
Uptime 22 minutes
Load Average 0.21, 0.42, 0.33
Kernel Modules
Loaded Modules
cpufreq_ondemand 'cpufreq_ondemand' - A dynamic cpufreq governor for Low Latency Frequency Transition capable processors
acpi_cpufreq ACPI Processor P-States Driver
mperf
i915 Intel Graphics
drm_kms_helper DRM KMS helper
drm DRM shared core routines
i2c_algo_bit I2C-Bus bit-banging algorithm
snd_hda_codec_hdmi HDMI HD-audio codec
snd_hda_codec_realtek Realtek HD-audio codec
fan ACPI Fan Driver
uvcvideo USB Video Class driver
videodev Device registrar for Video4Linux drivers v2
arc4 ARC4 Cipher Algorithm
ath9k Support for Atheros 802.11n wireless LAN cards.
ath9k_common Shared library for Atheros wireless 802.11n LAN cards.
ath9k_hw Support for Atheros 802.11n wireless LAN cards.
mac80211 IEEE 802.11 subsystem
ath Shared library for Atheros wireless LAN cards.
cfg80211 wireless configuration support
snd_hda_intel Intel HDA driver
snd_hda_codec HDA codec core
snd_hwdep Hardware dependent layer
snd_pcm_oss PCM OSS emulation for ALSA.
snd_mixer_oss Mixer OSS emulation for ALSA.
snd_pcm Midlevel PCM code for ALSA.
snd_seq_dummy ALSA sequencer MIDI-through client
pcspkr PC Speaker beeper driver
snd_seq_oss OSS-compatible sequencer module
snd_seq_midi Advanced Linux Sound Architecture sequencer MIDI synth.
snd_seq_midi_event MIDI byte <-> sequencer event coder
snd_rawmidi Midlevel RawMidi code for ALSA.
snd_seq Advanced Linux Sound Architecture sequencer.
sg SCSI generic (sg) driver
atl1c Atheros 1000M Ethernet Network Driver
snd_seq_device ALSA sequencer device management
snd_timer ALSA timer interface
i2c_i801 I801 SMBus driver
i2c_core I2C-Bus main module
snd Advanced Linux Sound Architecture driver for soundcards.
shpchp Standard Hot Plug PCI Controller Driver
soundcore Core sound module
snd_page_alloc Memory allocator for ALSA system.
acer_wmi Acer Laptop WMI Extras Driver
sparse_keymap Generic support for sparse keymaps
rfkill RF switch support
intel_agp
intel_gtt
agpgart AGP GART driver
wmi ACPI-WMI Mapping Driver
battery ACPI Battery Driver
video ACPI Video Driver
thermal ACPI Thermal Zone Driver
evdev Input driver event char devices
button ACPI Button Driver
ac ACPI AC Adapter Driver
processor ACPI Processor Driver
thermal_sys Generic thermal management sysfs support
hwmon hardware monitoring sysfs/class support
fuse Filesystem in Userspace
aufs aufs -- Advanced multi layered unification filesystem
squashfs squashfs 4.0, a compressed read-only filesystem

_________________
New Acer Aspire 5349-2635 dual proc, 4gb ram, re-partitioned with frugal Racy 5.3, dual boot, running rings around Win 7.
Back to top
View user's profile Send private message 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 06 Jun 2012, 20:19    Post subject: Re: PPM oddity on update  

peebee wrote:
I updated my 5.2.58 savefile which included installed pets.

When I ran the Package Manager in 5.2.60 only the description of the pets was displayed (no pet name) and if that was clicked to uninstall then a big red error box appeared (sorry didn't capture).

However easily fixed as if PPM is exited and then restarted both the name of the pet and an icon are displayed and an uninstall click works correctly.

Thought I'd mention....
Cheers
peebee


That must have been some problem with upgrading the savefile, as I did some bug fixing on the ppm after 5.2.58. If anyone else reports this bug on a pristine bootup then there is a more serious problem that will need fixing.
Of course, I would like to avoid your bug also.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
BarryK
Puppy Master


Joined: 09 May 2005
Posts: 7047
Location: Perth, Western Australia

PostPosted: Wed 06 Jun 2012, 20:21    Post subject: Re: beta2  

cowonjolt wrote:
On toshiba tecra 1.66ghz core duo w/1.5gb ram beta2 will not boot. Had no trouble with 5.2.55 or with 5.2.58 except 5.2.58 takes 6 minutes to boot up with long wait time to load drivers etc. With 5.2.60 it just sits and never loads drivers or moves forward. Have burnt iso 2 times and verified the burn both times with same result. I am running a live multi session of 5.2.58 with no working hard drive.
PS: not to sound dumb but what do the deltas do and/or how do you apply it?; I assumed the delta was to update 5.2.58 to 5.2.60 without a full install but I am not finding info on it.
Also, thanks to runtt21 for the fix for 2 of my first post questions and to OscarTalks for the vlc pet link. I will give the vlc pet a try and post back if it works... thanks again.


For the delta files, checkout 'Utility -> Xdelta file difference manager' in the menu.

_________________
http://bkhome.org/news/
Back to top
View user's profile Send private message Visit poster's website 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Wed 06 Jun 2012, 20:52    Post subject: Re: PPM oddity on update  

BarryK wrote:
peebee wrote:
I updated my 5.2.58 savefile which included installed pets.

When I ran the Package Manager in 5.2.60 only the description of the pets was displayed (no pet name) and if that was clicked to uninstall then a big red error box appeared (sorry didn't capture).

However easily fixed as if PPM is exited and then restarted both the name of the pet and an icon are displayed and an uninstall click works correctly.

Thought I'd mention....
Cheers
peebee


That must have been some problem with upgrading the savefile, as I did some bug fixing on the ppm after 5.2.58. If anyone else reports this bug on a pristine bootup then there is a more serious problem that will need fixing.
Of course, I would like to avoid your bug also.
I did not check an upgraded save file. I have this same problem with a new save file. Image1 is on first opening of ppm, image 2 is after closing and restarting ppm. The same problem occurred with b1.

The only other problem I've seen is that Xsane fails to recognize my usb scanner even though hplip_scan-3.12.4.pet is installed, also had same problem with b1.

Otherwise everything checked appears to be fast and stable. Later I will check it out on a laptop to see how well wifi is handled.

Thank you for Precise.
image-2.jpg
 Description   After closing and restart
 Filesize   62.54 KB
 Viewed   1602 Time(s)

image-2.jpg

image-1.jpg
 Description   Initial opening
 Filesize   58.67 KB
 Viewed   1570 Time(s)

image-1.jpg

Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Wed 06 Jun 2012, 23:43    Post subject: Installation of beta 2 on Dell Inspiron Laptop  

Cannot make connection to my wifi network. Scan picks up my available connection however my network controller does not appear to be supported. I am posting from the laptop using Slacko.

Other software appears to be working fine.

=== NETWORK ===

Network controller: Intel Corporation Centrino Wireless-N 1030
VENDOR: 8086 DEVICE: 008a
KERNEL MODULE: iwlagn

Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller
VENDOR: 10ec DEVICE: 8136
KERNEL MODULE: r8169
Back to top
View user's profile Send private message 
pemasu


Joined: 08 Jul 2009
Posts: 5458
Location: Finland

PostPosted: Thu 07 Jun 2012, 01:23    Post subject:  

Jim1911. There isnt iwlagn anymore in 3.2.X kernels. It is iwlwifi driver nowadays.
Barry K posted that he has updated the firmwares for iwlwifi and it also looks so...when I checked the firmware folder.
Could you post the result of wireless probing when you launch in console dmesg. It might be that you have problems with firmware loading. Just a hunch.
Or better....post whole dmesg content...as you have done once in Saluki thread....if I recall right.
dmesg > dmesg.gz and post it as attachment.
Back to top
View user's profile Send private message 
shinobar


Joined: 28 May 2009
Posts: 2385
Location: Japan

PostPosted: Thu 07 Jun 2012, 01:54    Post subject: Re: input method (half solved)  

Thanks Barry for making a link /usr/lib/gtk-2.0/2.10.0/gtk.immodules.
But still we have a problem.
shinobar wrote:
The SCIM in lang_pack_ja worked on Pemasu's precise and on Barry's alpha-3 by the treatment above.
But on the beta-1(EDIT: and beta-2), SCIM launches and can input KANA letters but fails to convert int KANJI letters. Pressing the space-bar to swithing the mode but does not work.

We are aware that the /usr/lib/gconv is cut down. So we add japanese stuff with the lang_pack_ja. Of cource we need to refresh the cache running 'iconvconfig'.

The problem is the file /usr/lib/gconv/gconv-modules is also cut down. We reverted the file with the one of the alpha3 and re-run 'iconvconfig'. Now the SCIM works OK,

There is a room to condider the file gconv-modules to be cut down or not...

_________________
Google Chrome portable
Downloads for Puppy Linux http://shino.pos.to/linux/downloads.html
Back to top
View user's profile Send private message Visit poster's website 
Billtoo


Joined: 07 Apr 2009
Posts: 1925
Location: Ontario Canada

PostPosted: Thu 07 Jun 2012, 02:35    Post subject: Precise Puppy beta2, June 6, 2012
Subject description: another install
 

Manual frugal install to a 64gb flash drive.

Precise Puppy, version 5.2.60 on Thu 7 Jun 2012

Chip description:
0.0 VGA compatible controller
NVIDIA Corporation GF114 [GeForce GTX 560 Ti] (rev a1)
oem: NVIDIA
product: GF110 Board - 12630002 Chip Rev

X Server: Xorg
Driver used: nvidia

X.Org version: 1.11.3
dimensions: 1920x1080 pixels (513x292 millimeters)
depth of root window: 24 planes

OpenGL
Vendor NVIDIA Corporation
Renderer GeForce GTX 560 Ti/PCIe/SSE2
Version 4.2.0 NVIDIA 295.53
Direct Rendering Yes

Network controller Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe

I opened ppm and updated it adding the precise repos then exited and
restarted ppm.
I installed kdegames which had a ton of dependencies and it took
approx 25 minutes to finish downloading and installing.
QT 481 was downloaded with kdegames and caused a problem for some of
my pets so I installed QT 482 which didn't break kdegames.
Did some more customizing, wbar,icewm,etc.

It's working well so far.
screenshot.jpg
 Description   
 Filesize   160.06 KB
 Viewed   1514 Time(s)

screenshot.jpg

Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Thu 07 Jun 2012, 10:45    Post subject:  

Precise 5.2.60 :
- I got a radeon HD3200, is the KMS stuff related ?
From puppy, type ctrl alt backspace , then type X, it shows a black screen.
Type Ctrl alt backspace again, it shows :
(EE) AIGLX error: r600 does not export required DRI extension
(EE) AIGLX: reverting to software rendering
This shows the same problem https://bbs.archlinux.org/viewtopic.php?pid=1102688
Back to top
View user's profile Send private message 
linuxcbon

Joined: 09 Aug 2007
Posts: 749

PostPosted: Thu 07 Jun 2012, 11:16    Post subject:  

Precise 5.2.60 :

- /tmp/xerrs.log also shows :
(EE) Failed to load module "fglrx" (module does not exist, 0)
(EE) Failed to load module "fglrx" (module does not exist, 0)
(EE) open /dev/fb0: No such device

- missing libraries in /usr/lib/ :
ldd /usr/lib/libbonoboui-2.so
libcanberra.so.0 => not found
ldd /usr/lib/libedit.so
libbsd.so.0 => not found
ldd /usr/lib/libgnome-2.so
libcanberra.so.0 => not found
ldd /usr/lib/libgnomeui-2.so
libcanberra.so.0 => not found
ldd /usr/lib/libIntelXvMC.so
libxcb-dri2.so.0 => not found
ldd /usr/lib/libva-glx.so
libva-x11.so.1 => not found

- missing libraries in /usr/bin/ :
ldd /usr/bin/cddb_query
/usr/bin/cddb_query: /usr/lib/libcdio.so.12: version `CDIO_12' not found (required by /usr/bin/cddb_query)
ldd /usr/bin/gnome-open
libcanberra.so.0 => not found
ldd /usr/bin/gphoto2
libcdk.so.5 => not found
ldd /usr/bin/gtkhash
libgtk-3.so.0 => not found
libgdk-3.so.0 => not found
ldd /usr/bin/jiv
libglut.so.3 => not found
ldd /usr/bin/sftp
libbsd.so.0 => not found
ldd /usr/bin/spumux
libMagickCore.so.4 => not found
Back to top
View user's profile Send private message 
linux28

Joined: 05 Apr 2009
Posts: 179

PostPosted: Thu 07 Jun 2012, 12:03    Post subject: Re: input method  

input method

Thanks You. can use.
Back to top
View user's profile Send private message 
Jim1911

Joined: 19 May 2008
Posts: 2445
Location: Texas, USA

PostPosted: Thu 07 Jun 2012, 13:34    Post subject:  

pemasu wrote:
Jim1911. There isnt iwlagn anymore in 3.2.X kernels. It is iwlwifi driver nowadays.
Barry K posted that he has updated the firmwares for iwlwifi and it also looks so...when I checked the firmware folder.
Could you post the result of wireless probing when you launch in console dmesg. It might be that you have problems with firmware loading. Just a hunch.
Or better....post whole dmesg content...as you have done once in Saluki thread....if I recall right.
dmesg > dmesg.gz and post it as attachment.
Hi pemasu,

It's good to see you on the forum again. Hope all is well for you and yours.
dmesg output for laptop which does not connect is attached.
dmesg.gz
Description 
gz

 Download 
Filename  dmesg.gz 
Filesize  50.95 KB 
Downloaded  163 Time(s) 
Back to top
View user's profile Send private message 
LateAdopter

Joined: 27 May 2011
Posts: 136
Location: Reading UK

PostPosted: Thu 07 Jun 2012, 13:47    Post subject:  

Hello linuxcbon

The Radeon R600 driver setup is broken in these Puppies at the moment.

Kernel modesetting is mandatory for current Radeon cards and drivers but it is disabled in several places.

The underlying problem is that drm reports that modesetting is not supported.

I think this is probably a kernel configuration problem.

You can enable modesetting with radeon modeset=1 but that only affects the radeon kernel module. It does not affect the drm kernel module.

The drm kernel module does not seem to have a method of overriding this configuration.

pemasu's kernel might be different, but I couldn't get that version to load the the radeon drivers.
Back to top
View user's profile Send private message 
Display posts from previous:   Sort by:   
Page 16 of 59 [875 Posts]   Goto page: Previous 1, 2, 3, ..., 14, 15, 16, 17, 18, ..., 57, 58, 59 Next
Post new topic   Reply to topic View previous topic :: View next topic
 Forum index » Advanced Topics » Cutting edge
Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1124s ][ Queries: 12 (0.0150s) ][ GZIP on ]