Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Fri 21 Nov 2014, 20:42
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
pup-volume-monitor-0.1.15 and desktop-drive-icons-0.0.6
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 11 of 11 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11
Author Message
sfs

Joined: 02 Nov 2013
Posts: 24
Location: Russia

PostPosted: Mon 11 Aug 2014, 04:30    Post_subject: Re: p-v-m and tahrpup  

Need help
Porteus:
Code:
# mount |grep sda1
/dev/sda1 on /mnt/sda1 type ext4 (rw,noatime,nodiratime,data=ordered)
/dev/sda1 on /mnt/live/memory/changes type ext4 (rw,noatime,nodiratime,data=ordered)

Label = sda1 mount in /mnt/live/memory/changes
http://forum.puppyrus.org/index.php?action=dlattach;topic=15904.0;attach=11998;image

_________________
PuppyRus-Arch
Back to top
View user's profile Send_private_message Visit_website 
mikeb


Joined: 23 Nov 2006
Posts: 8621

PostPosted: Mon 11 Aug 2014, 04:43    Post_subject:  

Interesting... on slax 6 the changes mount does not appear in mount
Code:
bash-3.1# mount
aufs on / type aufs (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hda2 on /mnt/hda2 type ext3 (rw,noatime)
/dev/hda1 on /mnt/hda1 type fuseblk (rw,noatime,allow_other,blksize=512)
/dev/hda3 on /mnt/hda3 type ext3 (rw,noatime)
/dev/sda1 on /mnt/sda1 type vfat (rw,noatime,quiet,umask=0,check=s,shortname=mixed)
bash-3.1# cat /proc/cmdline
ramdisk_size=7120 pty.legacy_count=10 root=/dev/ram0 rw vga=788 splash=silent quiet changes=/nimblex autoexec=startxfce4
bash-3.1#

It only appears if you cat the initrd mtab.
Code:
bash-3.1# cat /mnt/live/etc/mtab
rootfs / rootfs rw 0 0
/dev/root /mnt/live ext2 rw 0 0
proc /mnt/live/proc proc rw 0 0
/dev/hda2 /mnt/live/mnt/hda2 ext3 rw,noatime,data=ordered 0 0
/dev/hda2 /mnt/live/memory ext3 rw,noatime,data=ordered 0 0


The problem will be similar to the puppy bind mount problem since the same thing is happening.
mike
Back to top
View user's profile Send_private_message 
saintless


Joined: 11 Jun 2011
Posts: 2644
Location: Bulgaria

PostPosted: Mon 11 Aug 2014, 04:55    Post_subject:  

I don't know if it helps and what is the problem exactly, but it is the same here booting with porteus initrd - sda3 is mounted twice in mount command output:
http://mail.murga-projects.com/puppy/viewtopic.php?p=759046&sid=92fe77b43d32983911a08186959d5b0e#759046

_________________
Farewell, Nooby, you will be missed...
Back to top
View user's profile Send_private_message MSNM 
mikeb


Joined: 23 Nov 2006
Posts: 8621

PostPosted: Mon 11 Aug 2014, 05:02    Post_subject:  

Not really a problem... any distro using aufs in mysterious ways will give some odd mount information...its simply the nature of the mechanism. What is needed is for any software working with that info to be aware of it though in this case its up to us to modify the sources. I did test these icons on slax and they worked nicely apart from this..if it was a live boot than there is no problem. I use xfce4 so its drive icons do the job anyway without any quirks.

Mike
Back to top
View user's profile Send_private_message 
Display_posts:   Sort by:   
Page 11 of 11 Posts_count   Goto page: Previous 1, 2, 3, ..., 9, 10, 11
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.0532s ][ Queries: 12 (0.0055s) ][ GZIP on ]