Puppy Linux Discussion Forum Forum Index Puppy Linux Discussion Forum
Puppy HOME page : puppylinux.com
"THE" alternative forum : puppylinux.info
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

The time now is Sat 25 Oct 2014, 15:30
All times are UTC - 4
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
pup-volume-monitor-0.1.15 and desktop-drive-icons-0.0.6
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
Page 6 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Author Message
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Wed 07 Nov 2012, 14:33    Post_subject:  

I forgot Embarassed

I've now updated link on third post.
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1703

PostPosted: Sun 11 Nov 2012, 02:00    Post_subject:  

I finally got around to compile and install pup-volume-monitor-0.1.10 and desktop-drive-icons-0.0.1 in precise 5.4.1 after I installed your glib-2.32.3-patched-precise-i686.pet.
Compiled fine though desktop-drive-icons-0.0.1 still needs "LIBS=-lX11 GTK2_LIBS=$LIBS LDFLAGS=-L/usr/lib ./configure" to compile.

However, I have a problem thou I do not know which of the 3 (glib, volume-monitor, drive-icons) generates it.
When I unmount a removable drive (by clicking the icon), the window does not close but just empties (from the file/folder icons). On consecutive mounts of the drive, it mount OK but the window that opens in blank.

Removing the drive and inserting a different one that has the same dev name but different volume name behaves OK the first time it mounts. Then blank.
If you restart the X server is OK again the first time.

I suspect is the drive-icons app and its interaction with ROX, but I wouldn't know. If it is and you get around to look at it, you may also want provide the option *not* to move the position of the drives when one with a long (3-4 lines) name is inserted or just limit it to 2 lines (and truncate after 6-7 letters)

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
akash_rawal

Joined: 25 Aug 2010
Posts: 232
Location: ISM Dhanbad, Jharkhand, India

PostPosted: Tue 13 Nov 2012, 15:11    Post_subject:  

I have moved desktop-drive icons here and made requested changes.

desktop-drive-icons updated to 0.0.2
Changelog:
  • Added post unmount command. By default it closes the open rox-filer window. (thanks mavrothal)
  • It is now possible to set maximum length of a drive label displayed. (thanks mavrothal)
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1703

PostPosted: Wed 14 Nov 2012, 02:44    Post_subject: Precise pet  

Akash,
Desktop-drive-icons-0.0.2 works fine in precise if the proper glib is install. Very Happy
So I made a pet for pup-volume-monitor/desktop-drive-icons for Puppy Precise 5.4/5,4,1.
It requires either BK's z_glib_fix-2.32.3-orig-precise540-i686.pet or your glib-2.32.3-patched-precise-i686.pet to work properly.

Edit Version 0.1.10-1has different defaults and a better pinstall script
Version 0.1.10-2 corrects a typo in pinstall (thanks peebee)
pup_volume_monitor_precise-0.1.10-2.pet
Description  pup-volume-monitor/desktop-drive-icons combo for Puppy Precise 5.4/5.5
pet

 Download 
Filename  pup_volume_monitor_precise-0.1.10-2.pet 
Filesize  161.65 KB 
Downloaded  584 Time(s) 

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy

Edited_time_total
Back to top
View user's profile Send_private_message 
mavrothal


Joined: 24 Aug 2009
Posts: 1703

PostPosted: Thu 15 Nov 2012, 01:35    Post_subject:  

Hi again,
I noticed that even when the max characters option is activated, unless you define enough only for one line (ie 6) the position of the drives still moves up and down when a device with more characters than the existing devices is inserted or removed.
I guess what it needs is to define the original position of the widget according to the max characters and then (with another option box) either expand the widget downwards or do not expand it at all.
To have a sensible initial position you may allow for 2 lines as a default and provide the full name upon hovering.

Tried to see into icon.c and icon-view.c (so I will not only ask Embarassed ) but my C is less than rudimentary.
(BTW I find that developing in git/cvs is very educational for others since it allows them to see the logic and the code changes. Eventually this may pay off Wink )


Latter (after some more use)
The option to hide specific volumes would be very handy. Your windows (or macintosh) volume for example or your backup drive.
So if you go for a v0.0.3 Wink Though is probably better implemented in pup-volume-monitor so certain drive/volumes will not show in other desktop managers of save dialog windows.

_________________
Kids all over the world go around with an XO laptop. They deserve one puppy (or many) too Very Happy
Back to top
View user's profile Send_private_message 
MinHundHettePerro


Joined: 05 Feb 2009
Posts: 853
Location: SE

PostPosted: Sun 18 Nov 2012, 21:12    Post_subject:  

Hello Smile!

Latest PVM & DDI for slacko, in slacko 5.3 (RC2, 5.2.97 actually, though it shouldn't matter).

I have 19 internal partitions, which means that - on my 1280x1024 screen - quite a few of them are way out to the right of the wieving area.

Adding another partition, say sr0, gives a "Floating point exception" in DDI, which crashes.

Recompiling DDI so as to stay within my horizontal screen estate (shrinking icon-size, inter-icon padding etc.) makes DDI work - until the horizontal right is passed; resulting in a "Floating point exception".

Strangely, in vertical view, although a lot of the icons are well below the lower screen limit - there are no crashes of DDI.


In both horizontal and vertical view, DDI can be started with "too many partitions", while removing one, USB or sr0, results in the same DDI crash of "Floating point exception" in horizontal view only.


A bit more serious, though, is that when plugging in a USB-stick, say sdd, partitions are shown (sdd1, sdd2 etc), as well as, the MBR-block sdd.

PVM actually offers to mount (and save to, at least in FF) the MBR-block of USB flash-devices (not for USB HDDs, though).


Perhaps a multi-row table for drive icons Wink Smile.

I would like to also see my FDD in PVM/DDI Wink.


Craps, a lot of critisism Shocked - but, I wouldn't have bothered if I didn't have high hopes for PVM/DDI Smile.


Cheers Smile/ MHHP
Internal_HDDs_with_2_USBs_plugged_in.jpg
 Description   
 Filesize   70.25 KB
 Viewed   1526 Time(s)

Internal_HDDs_with_2_USBs_plugged_in.jpg

Internal_HDDs_with_2_USBs_plugged_in_plus_CD.png
 Description   
 Filesize   410.27 KB
 Viewed   1533 Time(s)

Internal_HDDs_with_2_USBs_plugged_in_plus_CD.png


_________________
Celeron 2.8 GHz, 1 GB, i82845, many ptns, modes 12, 13
Dual Xeon 3.2 GHz, 1 GB, nvidia quadro nvs 285

Slackos & 214X, ... and Q6xx
Nämen, vaf.... ln -s /dev/null MHHP
Back to top
View user's profile Send_private_message 
01micko


Joined: 11 Oct 2008
Posts: 7836
Location: qld

PostPosted: Sun 25 Nov 2012, 17:12    Post_subject:  

Hello akash_rawal

I have built a compiz sfs for the new slacko (when released) and it will be based around lxpanel and pcmanfm. I installed your slacko-1.10 pet on the first page and it seems to run well.



Thanks for a great job!

_________________
Woof Mailing List | keep the faith Cool |
Back to top
View user's profile Send_private_message Visit_website 
technosaurus


Joined: 18 May 2008
Posts: 4353

PostPosted: Mon 26 Nov 2012, 22:57    Post_subject:  

mavrothal wrote:
Tried to see into icon.c and icon-view.c (so I will not only ask Embarassed ) but my C is less than rudimentary.
(BTW I find that developing in git/cvs is very educational for others since it allows them to see the logic and the code changes. Eventually this may pay off Wink )
its much nicer than gtk's builtin iconview, the made it nearly impossible to set the gtk version's background image let alone transparency - kudos
_________________
Web Programming - Pet Packaging 100 & 101
Back to top
View user's profile Send_private_message 
okokoook

Joined: 08 Dec 2011
Posts: 23

PostPosted: Fri 30 Nov 2012, 01:18    Post_subject:  

i just have little concern about the pup-volume-monitor. as instructed, i created those two scripts and left them in their corresponding directories respectively. but when i reboot, i got "not syncing, attempting to kill init" message. could anyone give me a hint on this? thank you

regards

michael
Back to top
View user's profile Send_private_message 
gmahuaer


Joined: 30 Nov 2012
Posts: 2

PostPosted: Fri 30 Nov 2012, 07:02    Post_subject:  

okokoook wrote:
i just have little concern about the pup-volume-monitor. as instructed, i created those two scripts and left them in their corresponding directories respectively. but when i reboot, i got "not syncing, attempting to kill init" message. could anyone give me a hint on this? thank you

regards

michael


Hi, michael,
Your sysytem might get other troubles. My test is ok (v789), but Chinese characters in file-name are garbled when I inserted a USB disk with vfat FileSystem.
Back to top
View user's profile Send_private_message 
simargl
Guest


PostPosted: Tue 18 Dec 2012, 07:08    Post_subject:  

removed
Edited_time_total
Back to top
tenochslb

Joined: 10 Jul 2010
Posts: 36
Location: Mexico

PostPosted: Sat 29 Dec 2012, 01:27    Post_subject:  

Is it just me or the source tar contains nothing to extracr?
Back to top
View user's profile Send_private_message 
Geoffrey


Joined: 30 May 2010
Posts: 1435
Location: Queensland Australia ɹǝpu∩uʍop

PostPosted: Sun 30 Dec 2012, 11:05    Post_subject:  

tenochslb wrote:
Is it just me or the source tar contains nothing to extracr?


It appears fine to me, I assume you are referring to pup-volume-monitor-0.1.10.tar.gz

it contains
Code:
aclocal.m4    config.h.in   daemon      ltmain.sh    missing
admin         config.sub    depcomp     m4           module
compile       configure     install-sh  Makefile.am  plugins
config.guess  configure.ac  libpupvm    Makefile.in  tester

_________________
Carolina: Recent Repository Additions
Create strikethrough text HERE
Back to top
View user's profile Send_private_message 
sc0ttman


Joined: 16 Sep 2009
Posts: 2385
Location: UK

PostPosted: Wed 27 Mar 2013, 11:35    Post_subject:  

I tried to compile , and I get this:

Code:
  CCLD   pup-volume-monitor
pup_volume_monitor-drive-probes.o: In function `pup_volume_assert':
/root/Downloads/pup-volume-monitor-0.1.10/daemon/drive-probes.c:172: undefined reference to `blkid_new_probe_from_filename'
collect2: ld returned 1 exit status
make[2]: *** [pup-volume-monitor] Error 1
make[2]: Leaving directory `/root/Downloads/pup-volume-monitor-0.1.10/daemon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/Downloads/pup-volume-monitor-0.1.10'
make: *** [all] Error 2


I'm using glib-2.30 if that makes a difference, not patched... Is that my problem? Will it be a problem if I get past this one above?

I'm using blkid 1.0.0 (12-Feb-2003)... I assume it's too old, or needs re-compilng etc... If so... Where are the sources? Do I need specially patched puppy sources for blkid? Is ther ea pet for blkid or do I need to update the whole e2fsprogs pkg (if that is where blkid comes from)..?

If the problem is not with blkid, why can't I compile this?

Or maybe there is a pet for wary 51x somewhere? That should work for me... I already tried the latest version from the Carolina repo, but I did not get any drives listed in thunar, I only got these errors(?) in the terminal:

Code:
# pup-volume-monitor-starter
/usr/bin/pup-volume-monitor-starter: line 7: 26836 Trace/breakpoint trap   pup-volume-monitor-admin --list-all &>/dev/null

_________________
Akita Linux, VLC-GTK, Pup Search, Pup File Search
Back to top
View user's profile Send_private_message 
peebee


Joined: 21 Sep 2008
Posts: 1465
Location: Malvern, Worcs, UK

PostPosted: Thu 28 Mar 2013, 15:57    Post_subject: Re: Precise pet  

mavrothal wrote:
Edit Version 0.1.10-1has different defaults and a better pinstall script


Hi Mav

Was looking inside the Precise pet......

Is there a typo at line 14 in pinstall.sh ? - fasle - should be false ??

Also the puninstall.sh looks for file /etc/.eventmanager_ORIG but this file is not created by the pinstall.sh - should it be??

Cheers
peebee

_________________
LxPup-14.10 = Puppy + LXDE
Back to top
View user's profile Send_private_message Visit_website 
Display_posts:   Sort by:   
Page 6 of 11 Posts_count   Goto page: Previous 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11 Next
Post_new_topic   Reply_to_topic View_previous_topic :: View_next_topic
 Forum index » Advanced Topics » Additional Software (PETs, n' stuff) » System
Jump to:  

Rules_post_cannot
Rules_reply_cannot
Rules_edit_cannot
Rules_delete_cannot
Rules_vote_cannot
You cannot attach files in this forum
You can download files in this forum


Powered by phpBB © 2001, 2005 phpBB Group
[ Time: 0.1000s ][ Queries: 12 (0.0066s) ][ GZIP on ]